PDA

View Full Version : problem with USB ; please help..



micxuy
16th November 2006, 08:47 PM
hi guys;

I have an USB which i stored a lot of "important databases, informations". Because for some reason my laptop can boot the Fedora 6 CD, so i have tried to boot it by USB. I followed every steps from here here (http://fedora.redhat.com/docs/install-guide/fc6/en/sn-preparing-usb-media.html) . After i do this command :dd if=diskboot.img of=/dev/<device> , then when i mount it again, i dont see any of my databases anymore.... so is it already formatted my USB? I tried to plug it to Windows pc, it didnt show anything also.

Please guys, help me out... This is very important for me, cause all my database is inside that USB...

Thanks, hope to hear from your guys soon

Regards

nick.stumpos
16th November 2006, 09:01 PM
if you dd an image onto your drive you overworte your data

micxuy
16th November 2006, 09:15 PM
oh god.... there are anyway to rescue it? if it really no way; im going mad :(

thanks for your reply

nick.stumpos
16th November 2006, 09:18 PM
there are data recovery programs, I've never had to use one, but google should turn something up fo you, I bet someone around here knows a good one though

parish
16th November 2006, 09:28 PM
A couple of people here have recently reported success recovering lost partitions using TestDisk (http://www.cgsecurity.org/wiki/TestDisk). You might check it out, but I wouldn't be too optimistic considering you actually overwrote your data with the dd command.

Daniel

micxuy
16th November 2006, 09:47 PM
thanks for your replies; i will check out the TestDisk....

Since the document did not say it will overwrite the database on the USB.... so i did not know...

micxuy
16th November 2006, 10:13 PM
seems like cant recover... i do not know but it is strange when in windows it only show the disk size is 20 MB ; in fact it is 300 GB. furthermore, in linux it show the free disk is only 4.5 MB ... so what is really happening here?

nick.stumpos
16th November 2006, 10:15 PM
whenn you dd someithing you are doing a lowlevel copy and convert, which meands you copied the image bit by bit to the usb drive. what does fdisk -l say

parish
17th November 2006, 05:29 AM
seems like cant recover... i do not know but it is strange when in windows it only show the disk size is 20 MB ; in fact it is 300 GB. furthermore, in linux it show the free disk is only 4.5 MB ... so what is really happening here?
dd'ing the disk.img only overwrote part of your disk, which means some of the data may be recoverable. If the disk was formatted as a single, 300 Gb partition prior to the incident, you may be able to rewrite the original partition table using fdisk and recover the data that was not overwritten by the dd operation. Was it a single, 300 Gb partition? What is the output of fdisk -l?

Daniel

micxuy
17th November 2006, 01:35 PM
Thanks for the replies guys;

I am not sure what you guys want to know, but when i try to test my USB hard drive, the softwae said the header is wrong, and i saw that there are 3 partitions on it, FAT 32, 16 and Linux (or whatever the name) .

Itried to use windows with the recover hard disk, but it couldnt work out, it said error with the header and format. Neither in Linux...

I really do not know what to do, because there were a lot of database inside. There are anyway to fix it?

P/s: I do not know much about hardware...

Thanks for great help.

Regards

parish
17th November 2006, 04:14 PM
Open a terminal window and type fdisk -l /dev/<hd device of your usb disk> (for example /dev/hdd) and post the output.

All is not yet lost, but you've been asked for this twice and no one can help you if you don't supply the information they request. Also, did you try TestDisk and what did it tell you?

Daniel

micxuy
17th November 2006, 06:10 PM
bash: fdisk: command not found

i always got this error when do as you say

Thanks

nick.stumpos
17th November 2006, 06:34 PM
you need root preivs first
su -
then your paswword

micxuy
17th November 2006, 07:28 PM
yes i did; but it still the same...

nick.stumpos
17th November 2006, 07:40 PM
did you do a su -
with the dash if so maybe your path is meesed up use
/sbin/fdisk -l

micxuy
17th November 2006, 07:53 PM
# /sbin/fdisk -l /dev/sda

Disk /dev/sda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

This doesn't look like a partition table
Probably you selected the wrong device.

Device Boot Start End Blocks Id System
/dev/sda1 ? 188019 188051 253319 e4 SpeedStor
Partition 1 does not end on cylinder boundary.
/dev/sda2 ? 62656 186401 993984023 98 Unknown
Partition 2 does not end on cylinder boundary.
/dev/sda3 ? 105611 225119 959953209 7d Unknown
Partition 3 does not end on cylinder boundary.
/dev/sda4 ? 331 849 4161536 0 Empty
Partition 4 does not end on cylinder boundary.

Partition table entries are not in disk order

I got like this. I do not know what is it though...

Thanks

p/s i have mistaken; this usb is 80 GB, not the 300 GB one, sorry about that.

parish
18th November 2006, 03:27 AM
That's a mess. :eek:

At this point I think your choices are:
1. A professional recovery service -- $$$$
2. Restore the original partition table -- did the disk ship with a utility disk that would tell you the initial partition table or better would allow you to reinstall the original partition table without overwriting the data?
3. See if TestDisk can rebuild the partition table.
4. Repartition the drive as a single large partition.

In each case, assuming you haven't written to the drive, it may be possible to recover data not overwritten by the original dd command.

Sorry I can't be more helpful/optimistic.

Daniel

micxuy
18th November 2006, 11:12 AM
Thanks for your help.

I think i will have to bring it to the recover service...cause i can not lost those database.

Thanks again ;)

Regards

parish
18th November 2006, 05:36 PM
Another thought: Do you have access to an identical usb disk? If so, you could make the assumption that the partition table is the same, list the partition table from the identical disk (fdisk -l) and then recreate that partition table on your compromised drive.

Post the details of your drive (manufacturer, model, size, etc); maybe someone here has the same one and can help you out.

Daniel