PDA

View Full Version : how to turn back after yum remove?



pbx
12th November 2006, 12:26 AM
hi,
I was having problems with firestarter firewall and made yum remove firestarter... But now I want to reinstall it and when I make yum install firestarter it says "No Match for argument: firestarter".
How do I turn back now???
Thanks in advance :)

bob
12th November 2006, 12:49 AM
Firestarter is provided by Extras. You didn't mention your version of FC, but try 'yum provides firestarter' and see if it's available. Perhaps it's just a typo?

bob
12th November 2006, 12:53 AM
If you still have trouble - go here: http://fedoraproject.org/wiki/Extras ,check your version of FC and then look it up under the alphabetical listing on top.

pbx
12th November 2006, 12:56 AM
I'm runing fc6... output of yum provides firestarter:
No Matches found

I should say that I've desabled the development repositoires because I was getting packages from fc7 (this fc6 was fct2)

bob
12th November 2006, 01:13 AM
Well, make sure you add 'Extras' back in! That's where you've got your problem. Here's "fedora-extras.repo" to add:

[extras]
name=Fedora Extras $releasever - $basearch
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/$releasever/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=extras-$releasever&arch=$basearch
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-extras
gpgcheck=1

[extras-debuginfo]
name=Fedora Extras $releasever - $basearch - Debug
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/$releasever/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=extras-debug-$releasever&arch=$basearch
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-extras
gpgcheck=1

[extras-source]
name=Fedora Extras $releasever - Source
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/$releasever/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=extras-source-$releasever&arch=$basearch
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-extras
gpgcheck=1

pbx
12th November 2006, 01:43 AM
now i get:
Error: Cannot find a valid baseurl for repo: extras

bob
12th November 2006, 01:51 AM
Well, this HASN'T been your day! It may be that something's down, although I just tried it and it's working here. In any case, you sure can download the correct Firestarter directly from Extras and then install it with 'rpm -Uvh programname' .

pbx
12th November 2006, 01:56 AM
Well, this HASN'T been your day! .
lol

ok, I had this problem before when I first removed "development.repo". Then I had to remove "fedora-extras-development.repo" also, and the error disapeared?!?!?

Thanks for the reply :)

EDIT:

Solved by enabling again the fedora-development.repo and fedora-extras-development.repo...
But now if I make yum update I get fc7 packages!!! I need to disable it again... Will I miss anything by doing this while updating????

bob
12th November 2006, 02:06 AM
Well, you really didn't have to remove them, just change 'enabled=1' to 'enabled=0' to keep them out of the chain. But, is fedora-core.repo, fedora-updates.repo and livna.repo all working for you? Hmmm.... let me check a bit for a link to Rahul's alternate list when things borked a few weeks ago....

pbx
12th November 2006, 02:07 AM
EDIT:

Solved by enabling again the fedora-development.repo and fedora-extras-development.repo...
But now if I make yum update I get fc7 packages!!! I need to disable it again... Will I miss anything by doing this while updating????

Yes, i did not remove them (just disabled them) and the other repo's r working fine :)
Thanks again

bob
12th November 2006, 02:09 AM
No, don't enable the development repos! That's going to be a disaster. Disable them and try these mirrorlists for extras:

https://www.redhat.com/archives/fedora-list/2006-October/msg02614.html

pbx
12th November 2006, 02:12 AM
ok... its done (disabled)
thanks a lot

P.S. the firestarter package i've just installed after enabeling dev-repo's again, is for fc6... so its fine.