PDA

View Full Version : Dependency Errors - Updating Software



Huggles
11th November 2006, 06:10 PM
('file /usr/lib/libpcsclite.so.1.0.0 from install of libpcsclite1-1.3.2-8.fc6.at conflicts with file from package pcsc-lite-libs-1.3.1-7', (7, '/usr/lib/libpcsclite.so.1.0.0', 0L))

what do i do?? :mad:

ilja
11th November 2006, 06:30 PM
Please don't use capslock in the thread title....

bob
11th November 2006, 06:35 PM
Okay, first of all, a workaround: http://fedoraproject.org/wiki/Tools/yum Set up the yum.sh from the Tips & Tricks section. When you run that, it will bypass any problem dependencies. Then, did you get that pcsc-lite package and libs from a third-party repository or from the FC repositories? If it's not a glitch caused by downloading from an outside source, be sure to file a bugzilla here: https://bugzilla.redhat.com/bugzilla/index.cgi . The developers may have overlooked a dependency problem and need to know about it.

Huggles
11th November 2006, 06:42 PM
its in the auto updates and ty ill try it

ilja
11th November 2006, 06:48 PM
Which repositories are you using? This kind of faults are most often caused by mixing conflicting repositories... See http://stanton-finley.net/fedora_core_5_installation_notes.html#Warning

Huggles
11th November 2006, 06:52 PM
im useing yum?.. but im not in stalling through the terminal, im installing update packets with the auto update thinggy. bleh

ilja
11th November 2006, 06:53 PM
It does not matter. You are using yum, as yum is the background process of the GUI you are using. So the question remains: did you add any repositories or installed any packages by yourself from a third party?

Huggles
11th November 2006, 06:55 PM
no i didn't add any respatorys, i have added packets from a third party

Huggles
11th November 2006, 07:21 PM
i tried to install it through the terminal and i got the same error

ilja
11th November 2006, 07:59 PM
Then it looks like a bug. So please report it to bugzilla as bob suggested, so it can be corrected by the devlopers.