PDA

View Full Version : Problem with gnofract



Salamandra
10th November 2006, 05:18 PM
I have just installed gnofract4d from extras vía yum. I am using a standard FC6 install. It has no dependency, but when i try to run the program i get:



Traceback (most recent call last):
File "/usr/bin/gnofract4d", line 47, in ?
from fract4dgui import main_window, preferences, utils
File "/usr/lib/gnofract4d-2.14/fract4dgui/main_window.py", line 15, in ?
from fractutils import flickr
File "/usr/lib/gnofract4d-2.14/fractutils/flickr.py", line 244, in ?
def encode_multipart_formdata(fields, files, BOUNDARY = '-----'+mimetools.choose_boundary()+'-----'):
File "/usr/lib/python2.4/mimetools.py", line 130, in choose_boundary
hostid = socket.gethostbyname(socket.gethostname())
socket.gaierror: (-2, 'Name or service unknown')

I don't know what happens. Does someone have the same problem?

mwette
10th November 2006, 05:31 PM
What does your /etc/hosts file look like? Does it have localhost defined 127.0.0.1?
What is SELINUX in /etc/selinux/config set to? What is NETWORKING_IPV6 in
/etc/syscofnig/network set to? I am wondering if hostname resolution is not
working. Also, you can try this (this is on my system):


$ python
>>> import socket
>>> socket.gethostname()
'bluefin'
>>> socket.gethostbyname(socket.gethostname())
'192.168.1.25'
>>>


My /etc/hosts file has essentially these two entries:


127.0.0.1 localhost.localdomain localhost
192.168.1.25 bluefin.localdomain bluefin

Salamandra
11th November 2006, 08:14 AM
Yes, /etc/hosts is correct,
this is SELINUX

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - SELinux is fully disabled.
SELINUX=enforcing
# SELINUXTYPE= type of policy in use. Possible values are:
# targeted - Only targeted network daemons are protected.
# strict - Full SELinux protection.
SELINUXTYPE=targeted

# SETLOCALDEFS= Check local definition changes
SETLOCALDEFS=0

And all the other things are correct.

But it doesn't work...

Thanks.

mwette
11th November 2006, 03:34 PM
You have security enforcing. Maybe something in SELINUX is blocking
one or both of the socket calls (gethostname() or gethostbyname()).
You could check /var/log/messages and /ar/log/secure to see if you
can find anything there. If there is a violation then you can possibly
change with setsebool (try "getsebool -a" to see what is there).
Sorry, I can't offer much else.

Salamandra
12th November 2006, 10:43 AM
I find no violations, even tryed to disable SElinux, but get the same.
Gnofract worked flawlessly on FC5, then after an update stopped working, and keeps the same till now, after a fresh FC6 installation.

Thanks for your efforts.

Salamandra
4th December 2006, 05:10 PM
I posted the thing in the gnofract support forum. It got solved by:
Save this file:
http://gnofract4d.cvs.sourceforge.net/*checkout*/gnofract4d/gnofract4d/fractutils/flickr.py?revision=1.14
on top of fractutils/flickr.py
And installing the development tools (gcc, etc) which are needed, although the depencency was not detected nor solved.