PDA

View Full Version : Streaming not working



adad
8th November 2006, 07:50 PM
I've stored my mp3 collection in a local server, where I've created some shares. I can access the files without problem, but I'm not able to play the files over the LAN connection. I've installed the necessary codecs according to Firewing1's and Stan Finley's guides, and I am able to play local mp3 files in my computer without any difficulties.

It seems that my system does not support smb access to the files. I'm able to access the files via nautilus and via krusader without any problems (I have rw access to the share).

Any help is welcome!

adad
11th November 2006, 02:08 PM
Does anyone have seen something like this? Any idea about what can be wrong?

strikeforce
11th November 2006, 02:40 PM
Same issue with me on xmms I'm not sure if there is a way around it.

If you create a folder and mount that share in that folder it should work.

I remember doing that from my http server for my brother.

adad
11th November 2006, 06:01 PM
The fact is that no app is able to stream any media from the server. It happens with amarok, xmms, xine, totem, totem-xine, etc.

Seve
11th November 2006, 06:50 PM
Hello:
Just curious if the same thing happens with VLC ?

Seve

JordanN
11th November 2006, 08:03 PM
Maybe you could install a streaming server, such as Icecast (http://www.icecast.org) or Darwin Streaming Server (http://developer.apple.com/opensource/server/streaming/index.html)?

adad
11th November 2006, 08:36 PM
Haven't tried VLC myself...

strikeforce
12th November 2006, 12:49 AM
Doesn't mythtv stream?

bob
12th November 2006, 01:28 AM
Wonder if you could add to Streamtuner? It does have configuration possibilities - maybe under 'Local' ? (BTW if someone's using Streamtuner, I'd change that 'bmp %q' to 'xmms %q' under Preferences > Command)

strikeforce
12th November 2006, 01:37 AM
I've had time to think about it and give comparisons to windows.

If you access anything through the gnome folders it will be like accessing stuff through windows network.

If you mount it to a specific directory as in /mnt/test //192.168.1.1/Music it will be equivalent to mapping a network drive.

I found under windows that accessing stuff over the network was not stable unless I mapped a drive. I think the same applies to linux. Your best bet is to create a 'hardlinked' mount and you should be able to do it without streaming.

adad
7th December 2006, 08:30 AM
Sorry for the delay in my response, but I was abroad, with almost no connectivity to the net. I don't know if streaming is the right concept here. I just want to open an mp3 that resides in a samba share in my fileserver via nautilus/krusader, and I want any media player application to be able to play it.

I can do this from a FC5 box and from a winxp box without any glitches, but from FC6 it does not work. I can play local mp3 files in FC6, so there is no codec issue. I can open the mp3 files from other computers, so it's not a share config issue. Any ideas?

adad
12th December 2006, 07:06 PM
I finally got it to work. It was SELinux: I just added samba as a trusted service and it worked.

Thank you to all that tried to help me!