PDA

View Full Version : nvidian lan driver not working



Delarama
15th April 2004, 04:11 AM
Hi Everyone
I'm a newbie and I'm slowly learning Linux. I have a mb with nvidia lan. Ihave installed fedora (2.4 kernel) and download nvidia drivers off nvidia site. I extracted and installed it no errors. I did a "modprobe nvet" in root through terminal and said invalid command. So the driver is recognized in the network settings but i still can't get it ot work? Any ideas as to problem? I hop i can get it to work, cause i do enjoy learning linux.
Thanks
Del

SuperNu
15th April 2004, 05:15 AM
When you typed "modprobe nvnet", were you root or a normal user? You must be root to insert or remove modules. If you were root, how did you become root, log in, su - or su? The first two will set root's envrionment, the third will use your current user's envrionment. Try "/sbin/modprobe nvnet". Also, after you ran make, did you run make install? Remember, you have to be root to install the Nvidia modules.

I just updated to the latest Fedora kernel, 2.4.22-1.2179.nptl, and these are the steps I took to install the Nvidia network module (I logged into the command line as root)...
1 - tar xzvf NVIDIA_nforce-1.0-0261.tar.gz (I don't like the RPM)
2 - cd nforce
3 - make
4 - make install
5 - enjoyed network connectivity.

If you still need more help, please let me know.

--SN

Prometheus
15th April 2004, 08:19 PM
just out of curiosity, did you download the unified driver? I know that contains the lan drivers (i have a nf2 mobo), but im pretty sure none of the others do. Try using the unified driver if you didnt use that last time.

Delarama
17th April 2004, 02:28 AM
Hi Guys
Thanks for your responese. Prom. i did download the all one driver off the nvidia site (same one supernu has in his message). Supernu, i tied to follow your map but i can't log on as root as this file was put on my desktop as normal user so i don't have access to it. I tried to extract using it using your command but i get an error message saying it can't find file ot directory. Can't i double click on it and extract it to the directory needed? Actually i tried this ran the cd nforce through terminal and it say could not find directory. SO, that is what has happened. Not sure where to go from here!? Again any suggestions greatly appreciated.
Thanks
Del

mars_hall
17th April 2004, 03:49 AM
copy the file to somewhere on the / and change the ownership and permissions

SuperNu
17th April 2004, 06:12 AM
It doesn't matter where you place the file as long as you know the path to the file. The root account has access to every file at all times. I download all of my files to my user's account (/home/sn/stuff) and I just use the command line to copy files where I need them. I place all source tarballs in /usr/src so whenever I need to upgrade my kernel, I don't have to search everywhere for the nforce ethernet source.

Now, my directions were assuming that you logged in as root or used su - and you were using the command line. I don't like using a lot of GUIs to get my work done. They can be too buggy sometimes.

Now, I use KDE and I am going to type these instructions from using KDE, but you can adapt them to Gnome or whatever window manager you happen to use.

1 - Download http://download.nvidia.com/XFree86/nforce/1.0-0261/NVIDIA_nforce-1.0-0261.tar.gz somewhere as your regular user (/home/user)
2 - Open a command line (konsole in KDE)
3 - change directories to where you downloaded the file (if necessary)
4 - tar xzvf NVIDIA_nforce-1.0-0261.tar.gz
5 - cd nforce
6 - make
7 - su
8 - enter root's password
9 - make install (no error messages should be generated)
10 - /sbin/lsmod | grep nvnet (check to make sure nvnet was added to the kernel
11 - /sbin/modprobe nvnet if no response is generated
12 - less /etc/modules.conf to check that the alias was set up properly for nvnet (alias eth0 nvnet)
13 - setup your network card (run neat. you will need to enter root's password)

I know that this might be a little long, but I wanted to make sure you got enough detail to help out. If you still need help, let me know.

--SN

Delarama
17th April 2004, 05:32 PM
Hi
I followed your instructions and everything worked fine with nor errors until i did a modprobe nvnet in root and it couldn't find the file. I ran neat and it had nvnet in there bur it still wasn't hooking up so i deleted the profile and restarted hoping it would recognize the driver again but that didn't work. Is ther a way that i can start over by deleting all occurences of the nvidia installation? or should i go through the installation procedure again? I am thoroughly frustrated. If i had the internet for reference on linux wouldn't be so bad but popping in and out of windows to get info off net very annoying.
Thanks
Del

Delarama
17th April 2004, 06:14 PM
Hi Again
I tried the installation over again. Everything worked fine until step 11. At this point it sound command not found and then at setp 12, it showed audio and usb references but nothing about lan. I checked my network settings and there is anvidia device showing as ok. Do i have to configure this device? or should the device say "nvnet" instead of "Nvidia Ethernet Controller...". I've had bothe of these devices show up in my network settings. It shouldn't by this hard to install a lan driver! Unless i'm doing something wrong!?
Thanks
Del

SuperNu
18th April 2004, 01:46 AM
If you don't have modprobe on your system, then something is wrong/missing. modprobe is in the modutils RPM. Just run rpm -q modutils from the command line and see if it returns anything. On my system, when I run rpm -q modutils, I get modutils-2.4.25-13.

You don't have to run step 12 if step 11 returns nvnet.

When I run neat, under the Devices tab, I have under Devices, eth0, under Nickname, eth0, and under Type ethernet. Under the Hardware tab, I have under Description, nForce2 Ethernet Controller, under Type, Ethernet, and under Device, eth0. Since you said that the network settings is showing the nForce ethernet controller, then configure it for DHCP and see if it works.

<edit>
I forgot to mention that for each kernel, you have to recompile the driver. So, if you upgrade your kernel, you need to recompile the nForce driver. Also, the nvnet module should be in /lib/modules/<kernel version>/kernel/drivers/net/nvnet.o
</edit>

--SN

Delarama
18th April 2004, 04:50 PM
Hi SN
I finally got it my lan to work!!!!!!!!!!!!!! I disable onboard lan in bios booted up Fedora and shut it down. Then enabled it in bios and restarted computer. Launched fedora, kudzu picked new hardware, recognized nvidia lan and selected dyanamic ip etc... and let Fedora runs its course. I've decided to your route and use kde interface. It seems to have more programs and optios. BTW has the auto Updater ever worked. It seems to crash or hang alot. Thanks alot for your help SN. Your steps helped me get driver on linux system. Now i can focus on tweaking and learning linux.
Thanks Again
Del
P.S. I don't think this will be my last visit here!