PDA

View Full Version : Where can I get libgtk2.0-dev ?



chuong
4th November 2006, 04:56 PM
Hello guys.

Anyone know where I can get libgtk2.0-dev ?

Is this a file for all Linux distribution and can I get it for Fedora Core 6?

Or does it already come with the default Fedora Core 6 installation?

I have these gtk packages on my system:

gtk2-engines-2.8.0-1.fc6
gtksourceview-1.8.0-1.fc6
gtk2-devel-2.10.4-4.fc6
gtkhtml2-2.11.0-3
gtkspell-2.0.11-2.1
gtk-sharp2-2.10.0-3.fc6
usermode-gtk-1.87-3
pygtk2-2.10.3-2.fc6
pygtk2-devel-2.10.3-2.fc6
gnome-python2-gtksourceview-2.16.0-1.fc6
gtk-doc-1.7-1.fc6
gtk2-2.10.4-4.fc6
gtkhtml3-3.12.1-1.fc6
pygtk2-codegen-2.10.3-2.fc6
authconfig-gtk-5.3.10-1
libgtk-java-2.8.7-2.fc6
pygtk2-libglade-2.10.3-2.fc6


Is libgtk2-dev in one of those?

chuong
4th November 2006, 05:23 PM
I've tried to install DrQueue by scons and make/make install.

Scons worked with no errors, but I'm not sure if "scons" installs softwares . . .

so I decided to do make/make isntall after I entered "scons" and this came up:

[root@localhost drqueue-0.64.1]# make install
ar r libdrqueue.a libdrqueue/3delightsg.o libdrqueue/aftereffectssg.o libdrqueue/aqsissg.o libdrqueue/blendersg.o libdrqueue/bmrtsg.o libdrqueue/common.o libdrqueue/communications.o libdrqueue/computer.o libdrqueue/computer_info.o libdrqueue/computer_status.o libdrqueue/config.o libdrqueue/database.o libdrqueue/drerrno.o libdrqueue/envvars.o libdrqueue/generalsg.o libdrqueue/job.o libdrqueue/jobscript.o libdrqueue/lightwavesg.o libdrqueue/list.o libdrqueue/logger.o libdrqueue/mantrasg.o libdrqueue/mayasg.o libdrqueue/mentalraysg.o libdrqueue/nukesg.o libdrqueue/pixiesg.o libdrqueue/request.o libdrqueue/semaphores.o libdrqueue/shakesg.o libdrqueue/task.o libdrqueue/terragensg.o libdrqueue/turtlesg.o libdrqueue/xsisg.o
ranlib libdrqueue.a
gcc slave.o libdrqueue.a -o slave
gcc master.o libdrqueue.a -o master
gcc requeue.o libdrqueue.a -o requeue
gcc jobfinfo.o libdrqueue.a -o jobfinfo
gcc blockhost.o libdrqueue.a -o blockhost
gcc ctask.o libdrqueue.a -o ctask
gcc cjob.o libdrqueue.a -o cjob
gcc jobinfo.o libdrqueue.a -o jobinfo
gcc compinfo.o libdrqueue.a -o compinfo
g++ sendjob.o libdrqueue.a -o sendjob
install -d -m 0755 bin
install -m 0755 -p ./slave bin/slave.Linux.i686
install -m 0755 -p ./master bin/master.Linux.i686
install -m 0755 -p ./requeue bin/requeue.Linux.i686
install -m 0755 -p ./jobfinfo bin/jobfinfo.Linux.i686
install -m 0755 -p ./jobinfo bin/jobinfo.Linux.i686
install -m 0755 -p ./blockhost bin/blockhost.Linux.i686
install -m 0755 -p ./ctask bin/ctask.Linux.i686
install -m 0755 -p ./cjob bin/cjob.Linux.i686
install -m 0755 -p ./sendjob bin/sendjob.Linux.i686
test -x ./drqman/drqman && install -m 0755 -p ./drqman/drqman bin/drqman.Linux.i686 || exit 0
install -d -m 0777 /usr/local/drqueue/tmp
install -d -m 0777 /usr/local/drqueue/logs
install -d -m 0755 /usr/local/drqueue/bin
install -d -m 0755 /usr/local/drqueue/etc
install -d -m 0777 /usr/local/drqueue/db
install -d -m 0777 /usr/local/drqueue/contrib
cp -r ./bin/* /usr/local/drqueue/bin/ || exit 0
cp ./etc/* /usr/local/drqueue/etc/ || exit 0
cp ./contrib/* /usr/local/drqueue/contrib/ || exit 0
cp: omitting directory `./contrib/windows'
cp: omitting directory `./contrib/XSI-Splash'
chmod -R 0755 /usr/local/drqueue/bin/* || exit 0
chmod 0755 /usr/local/drqueue/contrib/* || exit 0
chown -R drqueue:drqueue /usr/local/drqueue/bin/*
chown: `drqueue:drqueue': invalid user
make: *** [Linux_install] Error 1
[root@localhost drqueue-0.64.1]#


Anyone have any ideas?

Drqueue is a render farm manager I'm trying to setup for a home for 3D rendering with Blender. Any help would be appreciated.

Simon_6162
4th November 2006, 05:34 PM
you have gtk2-dev installed it isthe gtk2-devel package, it is short for development

The install is failing on the fact you should have the user drqueue and group drqueue defined for command chown -R drqueue:drqueue don;t exist

use this line instead of make install

make INSTUID=myrenderuser INSTGID=myrendergroup install

but put in your username for myrenderuser and your group for myrendergroup, or make the user and group called drqueue

there is a post on here for the same problem.

http://www.drqueue.org/phpBB2/viewtopic.php?p=1915&sid=b68b6d07966f3e7fe275ab3779ac1973

Simon

chuong
4th November 2006, 06:34 PM
Sorry, just a quick question if you don't mind.

I've used the command "scons", does that install drqueue already?

It didn't have any problem if I issued that command, not like make install.

chuong
4th November 2006, 07:06 PM
My user account is "chuong", but I don't know what my group is.

Anyway to find out what my group is?

For the mean time, I decided to use the group name as the same one as my renderusername, I hope that's alright.

I really would love to get this render farm thing set up though, wanna have a try at using render farms, see how powerful they say it is.

Simon_6162
4th November 2006, 07:44 PM
i have no idea what scons is, i doubt it does the same as make install (though i hear they taste nice !) in fedora your user name is normally your group name. run system-config-users to fins your primary group.

chuong
4th November 2006, 07:56 PM
Oh, OK, I was right then.

I've manage to get Drqman running (the graphical user interface thing for drqueue).

But the shell says:

[chuong@localhost ~]$ ./drqueue-0.64.1/bin/drqman
Could not open config file: '/etc/drqueue/drqman.conf'
Parsing config at: /usr/local/drqueue/etc/drqman.conf
Could not resolve hostname
Could not resolve hostname

chuong
4th November 2006, 07:56 PM
Oh, OK, I was right then.

I've manage to get Drqman running (the graphical user interface thing for drqueue).

But the shell says:

[chuong@localhost ~]$ ./drqueue-0.64.1/bin/drqman
Could not open config file: '/etc/drqueue/drqman.conf'
Parsing config at: /usr/local/drqueue/etc/drqman.conf
Could not resolve hostname
Could not resolve hostname


Should I just ignore these messages?

chuong
4th November 2006, 08:00 PM
I think I set my master director wrong or something.

chuong
4th November 2006, 08:32 PM
OK, I needed to use my IP address for the Master to resolve the hostname. . . I'l work on this tomorrow, too tired right now.