PDA

View Full Version : Can't start Eclipse 3.2 after upgrading to FC6



eyp
3rd November 2006, 12:54 PM
Hello, I receive an error message when trying to start Eclipse 3.2.
The old version 3.1.2 from FC5 worked fine, but after upgrade to FC6 it doesn't.
Any ideas?

The log file is:

!SESSION 2006-11-03 12:39:48.133 -----------------------------------------------
eclipse.buildId=M20060921-0945
java.version=1.4.2_10
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.update.configurator 2006-11-03 12:39:49.188
!MESSAGE Could not load from shared install
!STACK 0
java.lang.Exception
at org.eclipse.update.internal.configurator.Configura tionParser.processConfig(ConfigurationParser.java: 311)
at org.eclipse.update.internal.configurator.Configura tionParser.startElement(ConfigurationParser.java:1 10)
at org.apache.crimson.parser.Parser2.maybeElement(Par ser2.java:1672)
at org.apache.crimson.parser.Parser2.parseInternal(Pa rser2.java:667)
at org.apache.crimson.parser.Parser2.parse(Parser2.ja va:337)
at org.apache.crimson.parser.XMLReaderImpl.parse(XMLR eaderImpl.java:448)
at javax.xml.parsers.SAXParser.parse(SAXParser.java:3 45)
at org.eclipse.update.internal.configurator.Configura tionParser.parse(ConfigurationParser.java:74)
at org.eclipse.update.internal.configurator.PlatformC onfiguration.loadConfig(PlatformConfiguration.java :1057)
at org.eclipse.update.internal.configurator.PlatformC onfiguration.initializeCurrent(PlatformConfigurati on.java:726)
at org.eclipse.update.internal.configurator.PlatformC onfiguration.<init>(PlatformConfiguration.java:102)
at org.eclipse.update.internal.configurator.PlatformC onfiguration.startup(PlatformConfiguration.java:68 0)
at org.eclipse.update.internal.configurator.Configura tionActivator.getPlatformConfiguration(Configurati onActivator.java:331)
at org.eclipse.update.internal.configurator.Configura tionActivator.initialize(ConfigurationActivator.ja va:111)
at org.eclipse.update.internal.configurator.Configura tionActivator.start(ConfigurationActivator.java:71 )
at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(BundleContextImpl.java:991)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:985 )
at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:966)
at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:317)
at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:329)
at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1037)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:573)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:495)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:27 5)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:455)
at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:189)
at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:291)

!ENTRY org.eclipse.core.runtime 4 0 2006-11-03 12:39:49.204
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.
2.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:294)
at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:329)
at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1037)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:573)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:495)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:27 5)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:455)
at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:189)
at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:291)

!ENTRY org.eclipse.osgi 4 0 2006-11-03 12:39:49.211
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2006-11-03 12:39:49.216
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.
ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseA ppLauncher.start(EclipseAppLauncher.java:65)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:177)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.invokeFramework(Mai n.java:336)
at org.eclipse.core.launcher.Main.basicRun(Main.java: 280)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)

!ENTRY org.eclipse.osgi 2 0 2006-11-03 12:39:49.252
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2006-11-03 12:39:49.252
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.252
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.252
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.253
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.253
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2006-11-03 12:39:49.254
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2006-11-03 12:39:49.254
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ [3] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.254
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.254
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.254
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.254
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2006-11-03 12:39:49.254
!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).

eyp
3rd November 2006, 01:30 PM
Well, after removing $HOME/.eclipse directory, all work fine again :)