PDA

View Full Version : Missing xine-lib(vdr) dependency issue



novGREEn-C
1st November 2006, 09:52 PM
This morning my updater felt like updating xine-lib but stopped with the following issue:

Error: Missing Dependency: xine-lib(vdr) >= 0.7.6 is needed by package xine

My xine-lib itself however should be providing xine-lib(vdr) = 0.7.9 already. At least thatr is what yum says. A little confusing to me :(

Anybody with the same or a similar problem?

Thanks,

nov

P.S.: Please be patient with me if I am missing something very simple ;)

Nefarious
1st November 2006, 09:55 PM
I'm having the same problem while trying to update.

xine-lib, actually...

"Package xine-lib.i386 0:1.1.2-17.fc5 set to be updated"

novGREEn-C
1st November 2006, 10:09 PM
Sorry! Forgot to add: I am on FC6

Thx.

nov

Nefarious
1st November 2006, 10:10 PM
I'm booting up my FC6 Machine right now. Mind you, I don't think I've got Xine installed. So, we'll see what happens.

EDIT

Unfortunately, I don't have xine installed on FC6.

Tyotyo
2nd November 2006, 01:19 AM
I have this exact same issue. Just updated to FC 6, and have been looking for good support.

# yum update -y
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package grip.i386 1:3.2.0-14.fc6 set to be updated
---> Package xine-lib.i386 0:1.1.2-17.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: xine-lib(vdr) >= 0.7.6 for package: xine
--> Finished Dependency Resolution
Error: Missing Dependency: xine-lib(vdr) >= 0.7.6 is needed by package xine

Iron_Mike
2nd November 2006, 01:27 AM
I concur, it is BORKED.......

JRR883
2nd November 2006, 01:53 AM
I'm having the same trouble, actually. I think it's a naming issue. I'm pretty sure vdr-xine fixes it, but Yum still sees it as a missing dependency.

IPI
2nd November 2006, 02:32 AM
Same here!



--> Processing Dependency: xine-lib(vdr) >= 0.7.6 for package: xine
--> Finished Dependency Resolution
Error: Missing Dependency: xine-lib(vdr) >= 0.7.6 is needed by package xine



Running:2.6.18-1.2798.fc6

:confused: :confused: :confused: :confused:

novGREEn-C
2nd November 2006, 03:15 AM
Seems like at least 3 people are seeing the same issue. Guess that is enough to call it a problem that needs to be fixed by somebody ;)

Anybody with enough experience to tell us where to take it from here?

Thx,

nov

IPI
2nd November 2006, 03:16 AM
OK, I got something temporarly .....

try:


yum --exclude=xine* --exclude=amarok* update



Use this if you want to do the update for everything beside xine & if you want support for non-free stuff, for now until experts figure out how to deal with this problem.

Hope it helps

Tyotyo
2nd November 2006, 04:25 AM
OK, I got something temporarly .....

try:


yum --exclude=xine* --exclude=amarok* update



Use this if you want to do the update for everything beside xine & if you want support for non-free stuff, for now until experts figure out how to deal with this problem.

Hope it helps
It helps tremendously! I have 38 MB back logged that's updating now. Thank you very much!

Thetargos
2nd November 2006, 06:51 AM
Check if a bug report has already been filed. I'm sure this is with Livna's xine-lib (as that's what I've got), and I too have the issue, this is a broken xine-lib dep release for Xine.

Thetargos
2nd November 2006, 06:53 AM
Actually there is a bug already filed at Livna's bugzilla: 1238 (http://bugzilla.livna.org/show_bug.cgi?id=1238)

novGREEn-C
2nd November 2006, 07:09 AM
Thanks Thetargos!

I guess I (or we all) just wait for it to be fixed. Thanks for all the help with my first issue here. I am impressed by this community.

Thanks everybody,

nov

Nefarious
2nd November 2006, 03:18 PM
It's been fixed for FC5. 'least, as far as I can tell.

IPI
2nd November 2006, 07:23 PM
It's been fixed for FC6 as well ... i just got the update reminder and everything went OK.

novGREEn-C
2nd November 2006, 08:40 PM
I can confirm the fix for FC6 as well!

Nice updating to everybody :)

nov

SORRY! Was a little slower than the previous poster but butter two confirmations then none!

Thetargos
3rd November 2006, 01:46 AM
Indeed! Don't you LOVE OSS? :D

xeonman9000
4th November 2006, 12:21 AM
I'm having troubles with:


Error: Missing Dependency: libkghostviewlib.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libkpinterfaces.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkorganizer.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkpgp.so.2 is needed by package kdepim-devel
Error: Missing Dependency: libkorganizer_eventviewer.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkpimidentities.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkimageviewer.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libksieve.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkcal.so.2 is needed by package kdepim-devel
Error: Missing Dependency: libkabckolab.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkgroupwaredav.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libksvg.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libkcal_slox.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkpimexchange.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkorganizer_calendar.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabc_groupwise.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkorg_stdprinting.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_resourceremote.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_xmlrpc.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libtext2path.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libknoteskolab.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkgroupwarebase.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libmultisynk.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libksync2.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkcalkolab.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkitchensyncui.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkode.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libknotes_xmlrpc.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libksync.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkocorehelper.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkslox.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libqgpgme.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_groupwise.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkleopatra.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabc_newexchange.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_groupdav.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabc_groupdav.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkpilot.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkabinterfaces.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkmultipage.so.0 is needed by package kdegraphics-devel
Error: Missing Dependency: libktnef.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabc_slox.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkholidays.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkscan.so.1 is needed by package kdegraphics-devel
Error: Missing Dependency: libkmime.so.2 is needed by package kdepim-devel
Error: Missing Dependency: libkdepim.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libindex.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libgpgme++.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkonnector.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkgantt.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libkontact.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_resourcefeatureplan.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkcal_newexchange.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkabc_xmlrpc.so.1 is needed by package kdepim-devel
Error: Missing Dependency: libkaddressbook.so.0 is needed by package kdepim-devel
Error: Missing Dependency: libmimelib.so.1 is needed by package kdepim-devel

when I run yum -y update.

axisaudio
4th November 2006, 06:49 AM
I get the same error, and i have tried to find the file, but obviously I have no luck. I think this affects my vlc as well, because it will not load at all. It's installed, but it won't open

Thetargos
4th November 2006, 07:45 AM
Either --exclude the offending package(s) or uninstall kde*devel packages

pbx
7th November 2006, 02:57 AM
Similar problem here (FC6):



[root@p3x ~]# yum update
(...)
--> Running transaction check
--> Processing Dependency: libcurl.so.3 for package: xine
--> Finished Dependency Resolution
Error: Missing Dependency: libcurl.so.3 is needed by package xine
[root@p3x ~]#

Main difference is that I dont even have the package (I guess).
When I try to install it the same error message shows up?!?!:


[root@p3x ~]# yum install curl ///please correct me if this is not the way!
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package curl.i386 0:7.16.0-2.fc7 set to be updated
--> Running transaction check
--> Processing Dependency: libcurl.so.3 for package: xine
--> Processing Dependency: libcurl.so.3 for package: gnupg
--> Processing Dependency: libcurl.so.3 for package: openoffice.org-core
--> Processing Dependency: curl = 7.15.5-1.fc6 for package: curl-devel
(...)
---> Package vorbis-tools.i386 1:1.1.1-4.fc7 set to be updated
---> Package curl-devel.i386 0:7.16.0-2.fc7 set to be updated
---> Package xine.i386 0:0.99.4-9.lvn7 set to be updated
(...)
--> Running transaction check
--> Processing Dependency: libcurl.so.3 for package: xine
--> Finished Dependency Resolution
Error: Missing Dependency: libcurl.so.3 is needed by package xine

I see in the end of the name of some packages FC7 (most part of them have FC6)... is it normal?
BTW, making "yum --exclude=xine* --exclude=amarok* update" does not work with me: Still geting the error message.
So, I'm unable to update yum... please help!

thanks in advance

P.S. Other thing is that I always had problems with xine (need run it with opengl driver) and mplayer (needed to add vo=x11 to /.mplayer/config file), while using compiz...

Thetargos
7th November 2006, 06:01 AM
I've seen something similar now that there's a new update to VDR, I have to exclude VDR because otherwise mplayer is at fault on my system. I hope Livna will pay more attention when they roll out their updates so that they won't brake other packages like this whoe vdr deal with xine and a bunch of other multimedia applications.

scotta3234
7th November 2006, 06:11 AM
Seriously.... I just tried to do a simple yum update and got weird dependency conflicts. Had to exclude some packages. They really need to get this under control.

Seve
7th November 2006, 06:16 AM
Similar problem here (FC6):

I see in the end of the name of some packages FC7 (most part of them have FC6)... is it normal?

Hello:
I am not sure why you would be getting .fc7 rpms ... not normal unless you have the development repos enabled?

If you do, you need to disable them as this is most likely causing you some dependency problems.

Seve

pbx
7th November 2006, 07:45 AM
Hello:
I am not sure why you would be getting .fc7 rpms ... not normal unless you have the development repos enabled?

If you do, you need to disable them as this is most likely causing you some dependency problems.

Seve

Is that because i'm using the teste 2 version?!
Can u please help me on how to disable the development repos?
Thanks

Seve
7th November 2006, 08:12 AM
Is that because i'm using the teste 2 version?!
Can u please help me on how to disable the development repos?
Thanks
Hello:
Yes, if you are running a test version that would explain why the development repos are enabled. The extras and core development repos are enabled by default on tests.

Why are you running a very old test version ?


If you want disable a repo
then edit /etc/yum.repos.d/xxx.repo
and change
enabled=1
to
enabled-0

Seve

pbx
7th November 2006, 08:56 AM
Thanks, i have already chanded it (disabled fedora-development.repo and fedora-extras-development.repo, even so i dont know if I should remove fedora-updates-testing.repo!) ...



Why are you running a very old test version ?
Seve

I thought that with all the updates this version would be equal to the official release of FC6. Do u recomend me to full install again?
Thanks again

P.S. Now, the error messages look like the ones from users of this topic:

Error: Missing Dependency: libxine.so.1 is needed by package xine-lib-extras-nonfree
Error: Missing Dependency: xine-lib >= 1.1.2-17 is needed by package xine-lib-extras-nonfree
Error: Missing Dependency: libxine.so.1 is needed by package xine
And the updates work adding --exclude=xine* to yum :)