PDA

View Full Version : Scrambled screen, Nvidia Drivers, and "unrecognized class"



GuyverScythe
1st November 2006, 07:51 PM
Hello all, this is my first post on the forum. I'm a refugee from the dictatorship of Microsoft, as I presume many have been. :D

A little background before my questions:

So I did some researching before choosing a distribution to go with, and Fedora Core seemed pretty tight. I downloaded FC 5 and tried for an install. Right then, the anaconda installer wouldn't work in graphical mode. I would get green and light blue stripes on the screen at trying to start it up. I just typed in Linux text or whatever the command was, to use a text-based installer. No problem. :confused:

HOWEVER, after the install I never got a GUI to start up. I logged in under root and could do stuff on the command prompt though. Somewhere on this forum I saw someone had a similar problem and typed in GME or something to start up GNOME. I tried it and I got the scrambled screen again. :mad:

It detects my video card, so I figured getting drivers would be good. I found this set of directions on the forum, when someone posted a similar problem: http://www.mjmwired.net/resources/mjm-fedora-fc5.html

Sweet.




So... I didn't encounter any GUI this time either... and here are my new questions:

I also have a small partition with Windows XP on it (because I knew I'd need it to go online and get FC to work, heh), so when I start up my PC the Fedora screen comes up with my OS list.

Question: After updating the kernel, now FC5 has TWO entries on the list... one for the old kernel and one for the update. Is this normal? :confused: wtf.

I figure I'm supposed to use the entry which is labeling itself the most updated. Even while it's still going through the startup script loading this program and that one etc etc, this strange message appears on my screen in bursts of 4 or more, at random intervals between each burst:

security_compute_av: unrecognized class 57

Question: What does it mean?


By the way, I made the changes at the end of the instructions labeled "SELinux users". I upgraded with YUM and Livna.


What can I do?



System specs:

ASUS A8N-E; NVidia NForce 4 Chipset
2 GB Corsair RAM
AMD Athlon X2 64 3800+
NVidia GeForce 6600
SATA Hard Drive, 250GB

clearer
1st November 2006, 09:49 PM
Could you try to press CTRL+ALT+F7 after you get the login-prompt? It's properbly not working, but just to be sure -- there is no point in not trying the obviouse.

Do you have SELinux disabled at all times? I would think that it should work if you installed the nvidia drivers while SELinux was off, and then have it turned on on the next boot, but it might not.

clearer
1st November 2006, 09:50 PM
And yes, it's quite normal to have (at least) two kernels after an update... FC removes the older kernels if you have more than two after an update -- that way you should be sure to have a functional kernel (you should remove non-functional kernels)

GuyverScythe
2nd November 2006, 07:58 PM
Nope nope, CTRL+ALT+F7 doesn't work. It doesn't do anything. I'll gather some information on SELinux... because I don't know how to exactly turn it off. I don't know too much yet at all. This:

"security_compute_av: unrecognized class 57"

is still a mystery to me. Thanks for the suggestion. =)

clearer
2nd November 2006, 11:26 PM
You can turn off selinux, by adding the option selinux=off to one of your kernel lines in /boot/grub/grub.conf

GuyverScythe
4th November 2006, 07:48 PM
Ok, I turned SELinux off and I stopped getting the unrecognized class argument. I still don't have a GUI though. CTRL ALT F7 doesn't work. I try run X, but that doesn't work. I get that green screen with blue stripes on it again.

I clicked on the link at the bottom ofthis (http://www.mjmwired.net/resources/mjm-fedora-fc5.html) page, which led me here (http://www.nvnews.net/vbulletin/showthread.php?t=68681).

It explained to update my X drivers. I followed the instructions there, (I do have a dual-core chip, so I changed the commands accordingly).

At this point, I don't want SELinux. I disabled it. Once I get this thing to work, then I'll think about security.

After installing the new packs and making the changes as instructed, I got the unrecognized class 57 argument again. When I try to start up using the new kernel, (2.6.18-x.xxxx) I get that unrecognized class message as various processes try to start up. Then, it continues to give me this message (I don't remember if it's before or after I login):

audit(xxxxxxxxxx.x:xxx):avc:denied {send} for saddr=192.168.195 daddr=192.168.1.254 netif=eth0 scontext=system_u:system_r:kernel_t:s0 tcontext=system_u:object_r:unlabeled_t:s0 tclass=packet

GuyverScythe
8th November 2006, 06:38 PM
I am posting to inform that I have resolved my display problem! I bungled, because it had nothing to do with drivers at all. It was simply a problem involving the plug that I was using for my VGA monitor.

I had evenalready read a post about how someone with my problem fixed it by removing the DVI adapter from the VGA monitor plug, and plugging the monitor in directly. I completely forgot that I had used the adaptor, to circumvent a problem that I had with this card in Windows where I couldn't use a dualscreen setup with my TV unless I did so.

I casually realized my mistake, plugged it into the correct connector, and I now have a working graphical Anaconda installer for Fedora Core 5. :)

Still... I have a new problem now. I'm about to search the forums on why after all this, my GRUB loader doesn't load anymore, and if I find no help, I'll post about it under the title "GRUB Loader doesn't Load??"


Thank you for the help, clearer.