PDA

View Full Version : Hanging at boot without acpi=off but...



kriz_gr
1st November 2006, 01:37 AM
Hi, my new FC6 installation has some issues I'd like to ask about...

I first tried to install the xen-enabled kernel to my laptop just to see and play a bit with it. It booted perfectly and without any problems. ACPI was working just fine.
Then I decided that I wouldn't be using it anyway so I make a new clean installation and that's where all the problems begin: At the first boot it hanged. I was used seeing this (but not at my computer!), so the first thing I tried was to add acpi=off to the kernel parameters. Now, to use my computer I have to have acpi disabled which is kinda annoying for a laptop. What makes me scratch my head is that the installation kernel identified my cpu correctly (acpi, freq. scaling and all).

Plus, as a bonus, the frequency scaling doesn't work. I was used from FC5 to have at least the crude was to change the frequency from /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor. But the cpufreq dir does not exist!

Any clues for my problems? Thanks.

(to save you from asking I have the correct kernel installed:
Linux eh-112-115-216.resnet.wisc.edu 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 i686 i386 GNU/Linux)

edit: in case it helps, this is my cat /proc/cpuinfo

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 1.86GHz
stepping : 8
cpu MHz : 1862.086
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx up est tm2
bogomips : 3727.26