PDA

View Full Version : libiso9660.so.4(ISO9660_4)



sgtbob
31st October 2006, 10:46 AM
I just installed FC6 but when I tried to update via yum this mornign, I got the following. In reviewing some message traffic, this error seems to have been in previous FC distros; however, I never encountered them until I installed FC6. This newie needs some guidance.

[root@localhost ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package rsh.i386 0:0.17-37.fc6 set to be updated
---> Package livna-release.noarch 0:6-1 set to be updated
---> Package libid3tag.i386 0:0.15.1b-3.fc6.rf set to be updated
---> Package fetchmail.i386 0:6.3.4-2 set to be updated
---> Package a52dec.i386 0:0.7.4-10.lvn6 set to be updated
---> Package libcdio.i386 0:0.77-3.fc6 set to be updated
---> Package anacron.i386 0:2.3-44.fc6 set to be updated
---> Package gstreamer-plugins-ugly.i386 0:0.10.4-3.lvn6 set to be updated
---> Package gnome-applets.i386 1:2.16.0.1-10.fc6 set to be updated
---> Package libbeagle.i386 0:0.2.10-5.fc6 set to be updated
---> Package imlib.i386 1:1.9.13-30.fc6 set to be updated
---> Package pygobject2.i386 0:2.12.2-1.fc6 set to be updated
---> Package pygtk2.i386 0:2.10.1-5.fc6 set to be updated
---> Package shadow-utils.i386 2:4.0.17-7.fc6 set to be updated
---> Package gsm.i386 0:1.0.10-12.lvn6 set to be updated
---> Package freeglut.i386 0:2.4.0-10.fc6 set to be updated
---> Package lame.i386 0:3.97-2.lvn6 set to be updated
---> Package flash-plugin.i386 0:7.0.68-1.fc6.rf set to be updated
---> Package id3lib.i386 0:3.8.3-14.fc6 set to be updated
---> Package libsidplay.i386 0:1.36.59-1.2.fc6.rf set to be updated
---> Package bind-utils.i386 30:9.3.3-4.fc6 set to be updated
---> Package bluez-utils.i386 0:3.7-2 set to be updated
---> Package HelixPlayer.i386 1:1.0.7-4.fc6 set to be updated
---> Package xmms-cdread.i386 0:0.14-12.fc6 set to be updated
---> Package amrnb.i386 0:0.0.1-2.fc6.rf set to be updated
---> Package xsane-gimp.i386 0:0.991-4.fc6 set to be updated
---> Package wpa_supplicant.i386 1:0.4.9-1.fc6 set to be updated
---> Package lirc.i386 0:0.8.1-0.2.pre2.fc6 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.4.1-3.fc6 set to be updated
---> Package portaudio.i386 0:18.1-8.fc6 set to be updated
---> Package enca.i386 0:1.9-3.fc6 set to be updated
---> Package xine-lib.i386 0:1.1.2-13.lvn6 set to be updated
---> Package mplayer-fonts.noarch 0:1.1-4.lvn6 set to be updated
---> Package system-config-date.noarch 0:1.8.8-1.fc6 set to be updated
---> Package beagle-gui.i386 0:0.2.10-5.fc6 set to be updated
---> Package ffmpeg.i386 0:0.4.9-0.24.20060817.lvn6 set to be updated
---> Package mplayer-skins.noarch 0:1.7-1.fc6.rf set to be updated
---> Package libxml.i386 1:1.8.17-15.fc6 set to be updated
---> Package libmp4v2.i386 0:1.5.0.1-2.lvn6 set to be updated
---> Package faac.i386 0:1.24-6.lvn6 set to be updated
---> Package yumex.noarch 0:1.1.7-1.0.fc6 set to be updated
---> Package gramps.noarch 0:2.0.11-5.fc6 set to be updated
---> Package xscreensaver-gl-extras.i386 1:5.01-3.fc6 set to be updated
---> Package directfb.i386 0:0.9.25.1-3.fc6 set to be updated
---> Package rhgb.i386 0:0.16.4-2.fc6 set to be updated
---> Package gdm.i386 1:2.16.0-18.fc6 set to be updated
---> Package mplayer.i386 0:1.0-0.64.pre8.lvn6 set to be updated
---> Package mplayer-gui.i386 0:1.0-0.64.pre8.lvn6 set to be updated
---> Package bittorrent-gui.noarch 0:4.4.0-2.fc6 set to be updated
---> Package audit-libs.i386 0:1.2.9-1.fc6 set to be updated
---> Package bluez-gnome.i386 0:0.6-1.fc6 set to be updated
---> Package xsane.i386 0:0.991-4.fc6 set to be updated
---> Package gtk-sharp.i386 0:1.0.10-12.fc6 set to be updated
---> Package xscreensaver-extras.i386 1:5.01-3.fc6 set to be updated
---> Package system-config-users.noarch 0:1.2.47-1.fc6 set to be updated
---> Package bittorrent.noarch 0:4.4.0-2.fc6 set to be updated
---> Package tar.i386 2:1.15.1-21.fc6 set to be updated
---> Package bind.i386 30:9.3.3-4.fc6 set to be updated
---> Package a2ps.i386 0:4.13b-57.fc6.3 set to be updated
---> Package lzo.i386 0:2.02-2.fc6 set to be updated
---> Package gtk+.i386 1:1.2.10-55.fc6 set to be updated
---> Package gaim.i386 2:2.0.0-0.17.beta4.fc6 set to be updated
---> Package arts.i386 8:1.5.5-0.1.fc6 set to be updated
---> Package gnome-libs.i386 1:1.4.2-3.fc6 set to be updated
---> Package libmodplug.i386 1:0.8-3.fc6 set to be updated
---> Package ORBit.i386 1:0.5.17-20.fc6 set to be updated
---> Package grip.i386 1:3.2.0-13.fc6 set to be updated
---> Package libdvdread.i386 0:0.9.7-1.lvn6 set to be updated
---> Package libxml2.i386 0:2.6.27-1.FC6 set to be updated
---> Package pango.i386 0:1.14.6-2.fc6 set to be updated
---> Package mplayerplug-in.i386 0:3.31-2.lvn6 set to be updated
---> Package audit-libs-python.i386 0:1.2.9-1.fc6 set to be updated
---> Package mpeg2dec.i386 0:0.4.1-2.lvn6 set to be updated
---> Package numlockx.i386 0:1.0-11.fc6 set to be updated
---> Package gdk-pixbuf.i386 1:0.22.0-30.fc6 set to be updated
---> Package selinux-policy.noarch 0:2.4.1-3.fc6 set to be updated
---> Package autofs.i386 1:5.0.1-0.rc2.17 set to be updated
---> Package tcsh.i386 0:6.14-12 set to be updated
---> Package xvidcore.i386 0:1.1.0-4.lvn6 set to be updated
---> Package python-reportlab.noarch 0:1.21.1-1.fc6 set to be updated
---> Package eject.i386 0:2.1.5-4.1.fc6 set to be updated
---> Package openal.i386 0:0.0.9-0.8.20060204cvs.fc6 set to be updated
---> Package qt.i386 1:3.3.7-0.1.fc6 set to be updated
---> Package libpng10.i386 0:1.0.20-4.fc6 set to be updated
---> Package xmms.i386 1:1.2.10-28.fc6 set to be updated
---> Package xscreensaver-base.i386 1:5.01-3.fc6 set to be updated
---> Package pygtk2-libglade.i386 0:2.10.1-5.fc6 set to be updated
---> Package graphviz.i386 0:2.8-5.fc6 set to be updated
---> Package glib.i386 1:1.2.10-23.fc6 set to be updated
---> Package gtk-gnutella.i386 0:0.96.2-1.fc6 set to be updated
---> Package python-crypto.i386 0:2.0.1-4.fc6 set to be updated
---> Package caching-nameserver.i386 30:9.3.3-4.fc6 set to be updated
---> Package xmms-flac.i386 0:1.1.2-27.fc6 set to be updated
---> Package xine.i386 0:0.99.4-7.lvn6 set to be updated
---> Package faad2.i386 0:2.0-19.20050131.lvn6 set to be updated
---> Package libxml2-python.i386 0:2.6.27-1.FC6 set to be updated
---> Package libsepol.i386 0:1.15.1-1.fc6 set to be updated
---> Package beagle.i386 0:0.2.10-5.fc6 set to be updated
---> Package vnc-server.i386 0:4.1.2-5.fc6 set to be updated
---> Package libmpcdec.i386 0:1.2.2-4.fc6 set to be updated
---> Package libdvdcss.i386 0:1.2.9-4.lvn6 set to be updated
---> Package bind-libs.i386 30:9.3.3-4.fc6 set to be updated
---> Package libglade.i386 1:0.17-19.fc6 set to be updated
---> Package imlib2.i386 0:1.2.2-2.fc6 set to be updated
---> Package aalib.i386 0:1.4.0-5.fc6.rf set to be updated
---> Package xmms-libs.i386 1:1.2.10-28.fc6 set to be updated
---> Package gnome-screensaver.i386 0:2.16.1-2.fc6 set to be updated
---> Package libmad.i386 0:0.15.1b-4.lvn6 set to be updated
---> Package mutt.i386 5:1.4.2.2-3.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libiso9660.so.4(ISO9660_4) for package: vcdimager
--> Processing Dependency: libcdio.so.6 for package: vcdimager
--> Processing Dependency: libmp3lame.so.0 for package: lame
--> Processing Dependency: libgnomecanvaspixbuf.so.1 for package: gtkhtml
--> Processing Dependency: libcdio.so.6(CDIO_6) for package: vcdimager
--> Processing Dependency: lame-libs = 3.97-2.lvn6 for package: lame
--> Processing Dependency: libmp3lame.so.0 for package: gstreamer-plugins-ugly
--> Processing Dependency: libmp3lame.so.0 for package: mplayer
--> Processing Dependency: libiso9660.so.4 for package: vcdimager
--> Processing Dependency: libmp3lame.so.0 for package: ffmpeg
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package lame-libs.i386 0:3.97-2.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: libiso9660.so.4(ISO9660_4) for package: vcdimager
--> Processing Dependency: libcdio.so.6 for package: vcdimager
--> Processing Dependency: libgnomecanvaspixbuf.so.1 for package: gtkhtml
--> Processing Dependency: libiso9660.so.4 for package: vcdimager
--> Processing Dependency: libcdio.so.6(CDIO_6) for package: vcdimager
--> Finished Dependency Resolution
Error: Missing Dependency: libiso9660.so.4(ISO9660_4) is needed by package vcdimager
Error: Missing Dependency: libcdio.so.6 is needed by package vcdimager
Error: Missing Dependency: libcdio.so.6(CDIO_6) is needed by package vcdimager
Error: Missing Dependency: libiso9660.so.4 is needed by package vcdimager
[root@localhost ~]#

Bob :confused:

Seve
31st October 2006, 10:56 AM
Hello:
Which repos do you have enabled?

Seve

markkuk
31st October 2006, 11:29 AM
FC6 has newer versions of libiso9660 and libcdio, both are from the libcdio package. Either you have the FC5 version of vcdimager installed on your system, or the Livna repo maintainer has made an error. What does "yum list vcdimager*" show?

sgtbob
31st October 2006, 12:37 PM
Seve - here is what I see in the 'repos.d':
[bob@localhost ~]$ cd /etc/yum.repos.d
[bob@localhost yum.repos.d]$ dir
dries.repo fedora-updates.repo livna.repo
fedora-core.repo fedora-updates-testing.repo livna-source
fedora-development.repo freshrpms.repo livna-source~
fedora-extras-development.repo livna-debuginfo livna-testing.repo
fedora-extras.repo livna-debuginfo~ macromedia
fedora-legacy.repo livna-devel.repo
[bob@localhost yum.repos.d]$

sgtbob
31st October 2006, 12:39 PM
markuk - here is the output:
[bob@localhost ~]$ yum list vcdimager*
Loading "installonlyn" plugin
Setting up repositories
Reading repository metadata in from local files
Installed Packages
vcdimager.i386 0.7.23-4.fc5.rf installed
Available Packages
vcdimager.i386 0.7.23-4.fc5 freshrpms
vcdimager-devel.i386 0.7.23-4.fc5 freshrpms
[bob@localhost ~]$

Perhaps I do not even need this program. How do I remove it from my installation?

markkuk
31st October 2006, 03:41 PM
As I thought, you have the FC5 version of vcdimager installed. Also it appears that your Freshrpms configuration points to the FC5 repo. If you fix your freshpms.repo file the update should work. If you decide you don't need the program, just use "yum remove vcdimager".

sgtbob
31st October 2006, 11:01 PM
markuk - Many thanks for pointing me in the right direction. I was able to correct Freshrpms.repo and it still would not work -kept giving me the same error - then I observed that 'pacjkges' was in the line of coding and when I corrected that to 'packages', it downloaded and installed all the items in the yum.repos.d file.

I compared the yum.repos.d file to a second PC I have and there were a bunch of repo's that were missing. So, using the copy/paste routine from my #1 PC, I was able to get that unit up to speed also.

Again thanks for the timely advice and guidance.

Bob