View Full Version : nvidia driver and runlevel help please

30th October 2006, 10:53 PM
i had to install fc6 with text install and i tried to change the runlevel to 5, but now when i boot linux, after it loads, it goes to the text based login screen instead of the graphical one. then when i try to startx it says i need to remove /tmp/.X0-lock file and restart x-server. how do i get it to go to the graphical login?

also, with runlevel 5, sometimes the nvidia drivers dont seem to load and i get a frozen, blurry loading screen, and other times, it boots up semi-succesfully as said above.

31st October 2006, 01:33 AM
maybe you can try installing the nvidia driver again. I found this post, and it worked ok for me:


31st October 2006, 03:50 AM
i have already updated my nvidia drivers to the new beta driver, so i have the most up to date ones

31st October 2006, 07:39 AM
would reinstalling fc6 w/ i386 architecture instead of x86_64 somehow be more stable and avoid this problem?

31st October 2006, 04:13 PM
just press ctrl-alt-F7, that'll bring you back to the graphical interface.

Citizen Kane
31st October 2006, 08:31 PM
Hmmm... I also have the problem that I only get into the terminal after startup. I can get in Gnome by loggin in and then typing "gdm".

After that, it's all visual.

3rd November 2006, 03:07 PM
just press ctrl-alt-F7, that'll bring you back to the graphical interface.

Well, that works for me. What makes it "drop" to the command line interface in the first place? Is there a config to force it to the GUI?

3rd November 2006, 03:10 PM
Did you edit /etc/inittab ??

Find the line that reads id:3:initdefault: and change it to id:5:initdefault: if you have not done so already.

9th November 2006, 02:09 AM
okay, so now for some reason (perhaps due to updates) when i boot in runlevel 5 it goes to the graphical login (if everything works)...
However, sometimes (and it seems random) when I boot up, I get a scrambled and frozen graphical loading services screen. I've noticed that the times that it has worked, a nvidia logo screen flashes right before the loading services graphical screen. Is there some reason that my nvidia drivers are not always loadiing? Would it have something to do with the "Modules" section that I'm not sure whether I should have or not in my xorg.conf?

i have latest nvidia drivers and properly configured xorg.conf (with possible exception stated above) file according to Firewing1 at: