PDA

View Full Version : Rhythmbox and ID3 Tags



progrock
30th October 2006, 05:47 PM
Hi all,
Rhythmbox (in FC6) doesn't recognize changes in id3 tags. I use easytag to change the tags, I remove them from the library, and put them back...but nothing's changed. I've also tried kid3, and both kid3 and easytag display the correct info, but Rhythmbox just won't change it. I even tried removing and re-adding all the songs in my library, and that didn't change it.

And I know that someone is going to ask why I don't just use xmms. So, to respond before you ask, I have lots of music, and I like to be able to peruse and play quickly, and not dig through a directory tree to find what I want and drag it to xmms.

One last thing, I installed bmpx, to see what it's like, and I click the icon, and nothing happens, so any help there is great if rhythmbox is just not gonna work.

Any help is awesome, you guys have been great in getting me setup with this fresh install, so I'm hoping you keep your streak going ;)

-prog

MountainMan101
31st October 2006, 05:40 PM
Try deleteing the contents of ~/.rhythmbox and then reimporting your library.

progrock
31st October 2006, 06:01 PM
Might I ask where to find said file? I searched in kde and couldn't find it.

duanecu
27th March 2007, 03:41 PM
The folder to delete is this one:

~/.gnome2/rhythmbox/

This will delete all of Rythmbox's data, including play counts. When Rythmbox opens again, it will re-create.

Does anyone know a way to have Rythmbox re-read the tags without this forcfulness?

wesamel
27th March 2007, 04:18 PM
I just tested your problem here and rhythmbox worked fine. I edited a song title in easytag, and it was updated in rhythmbox automatically and immediately. I didn't have to do anything.

What version of rhythmbox are you using? I have 0.9.7 so if your using an older version that may explain the problem. If not then maybe there is something wrong with the library database and you should try deleting the folder that duanecu named.

duanecu
29th March 2007, 02:34 PM
I have noticed odd behavior when it comes to Rhythmbox (no comments from the rhythmbox haters, please). If I edit a song title or two, or something simple like that, rhythmbox updates fine. But when I changed all my artists from "Elton John" to "John, Elton" for example, rhythmbox will never recognize that drastic of a change.

By the way, if you meet the person that first spelled rhythm in English the way it is, please kick 'em for me.

naz37
2nd April 2007, 03:25 PM
Im also experiencing the same id3 tag problem with Rhythmbox. Im using version 0.9.8 and have had this issue since i updated a few days ago.

I tried deleting the folder ~/.gnome2/rhythembox but it didn't help, after the music library was rebuilt the problem persisted.

I ran rhythmbox in a terminal but there was no useful output when i tried to edit a tag. looks like it might be bug in rhythmbox 0.9.8.

Hunt
2nd April 2007, 05:53 PM
If the problem persisted after removing ~/.gnome2/rhythmbox and rebuilding library then i guess it's not a rhythmbox problem.
Are you sure you modified and saved changes correctly to the files with easytag?
It is a powerful application but in my experience I found a little tricky to understand exactly how it works the first times...

sptj
2nd April 2007, 08:00 PM
The newer version does not work correctly, up to 0.9.7 the id3 tag edition worked onay with tags correctly recognized by the gstreamer library. Now the new version does not allow me to edit the tags (even on sogns I am sure they can be edited by gstreamer because I did the editing a few days ago with 0.9.7.

So for me this is completely a rhythmbox issue.

Anyone submitted a bug report?