PDA

View Full Version : how to add resolution in FC6?



willie82
30th October 2006, 06:55 AM
previous in FC5 i could add a line in xorg and that resolution would appear in system-config-display, now in FC6 it doesnt happen... or am i not doing it correctly?



Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1366x768" "1280x720" "1024x768" "1024x512" "800x600" "640x480"
EndSubSection
EndSection


in the example, i could add 1366x768 and that would show up in system-config-display.

iamroot
30th October 2006, 10:09 AM
Ahh. Go into system-config-display and then set your monitor to a monitor of whatever resolution you wish.

willie82
31st October 2006, 03:45 AM
yeah i know how to change the resolution that is available to me. what im trying to do i add a resolution that isnt in the list provided. for example i want to add a 1366x768 res, previously in FC5, i could do it in Xorg.conf, but now in FC6, added the option in Xorg.conf doesn't show up in system-config-display.

anyone?

Camberwell
31st October 2006, 03:49 AM
what you are doing looks correct

in your /var/log/Xorg.0.log does it say something like...

could not validate mode "1366x768" removing


also what video card do you use??

if you use an nvidia card you could try adding...

Option "UseEDID" "FALSE"

to your device section in xorg.conf

willie82
31st October 2006, 12:40 PM
what you are doing looks correct

in your /var/log/Xorg.0.log does it say something like...

could not validate mode "1366x768" removing


also what video card do you use??

if you use an nvidia card you could try adding...

Option "UseEDID" "FALSE"

to your device section in xorg.conf

what does

Option "UseEDID" "FALSE"

do?

i saw someone mention in another post that it should be done like that

Modes "1366x768" "1366x768" "1280x720" "1280x720"

instead of

Modes "1366x768" "1280x720"

he say the 1st one is the label and the 2nd is the resolution...
going to try it out tomorrow when i have the time...

kldixon
31st October 2006, 03:22 PM
I do not think you can do much with xorg.conf any more. Read Section 18 of the release notes.

sirius56
31st October 2006, 09:24 PM
kldixon, I am having the same problem as willie82 (please see my post in the Installation Forum).
The FC6 Release Notes are not available at this time. Please tell us what Section 18 says. Thank you.

sirius56
31st October 2006, 09:33 PM
kldixon, I am having the same problem as willie82 (please see my posting in the Installation Forum).
The FC6 Release Notes are not available at this time. Please tell us what Section 18 says. Thank you.

b_martinez
31st October 2006, 09:39 PM
Option "UseEDID" "false" ---- this tells the x-server/nvidia driver to 'not' probe the monitor for information. If not in the xorg.conf file, nvidia driver will query the monitor for information to ensure it doesn't toast the monitor by forcing it to operate out of specifications.
hth
Bill

sirius56
31st October 2006, 09:49 PM
I am using a generic CRT display (HP M70), Intel 82G965 Integrated Graphics Controller, Model i810 Intel Integrated Graphics Chipset.

Would the "UseEDID false" option make any sense here?

Any other thoughts on how I can change resolution to 1024 x 768?

Thank you.

sirius56
31st October 2006, 11:24 PM
b_martinez, I tried the option "UseEDID" "false" suggestion. Also eliminated all but "1024x768" from the Modes line. NO luck.

Any further suggestions you can make will be appreciated.

There are enough people talking about this problem on the Forum that it must be a system-config-display bug in FC6.

kldixon
2nd November 2006, 04:30 PM
Sorry for the delay in replying, sirius56. The forum notification mail message only just arrived.
I may have overinterpreted the release notes. After further investigations the only gripe I still have is that the keys Ctrl-Alt-Kpad+/- no longer function. This may be a bug worthy of posting a bugzilla but I am still investigating that. There are some more details in the post:-
http://forum.fedoraforum.org/showthread.php?t=134645

The release notes are on the first distribution CDROM, if you have no installation yet, or at file:///usr/share/doc/HTML/RELEASE-NOTES-en_US.html if you do:-

18.1. X Configuration Changes

The X.org 7.1 X server has been modified to automatically detect and configure most hardware, eliminating the need for users or administrators to modify the /etc/X11/xorg.conf configuration file. The only hardware configured by default in the xorg.conf file written by anaconda is:
* the graphics driver
* the keyboard map
All other hardware, such as monitors (both LCD and CRT), USB mice, and touchpads should be detected and configured automatically.
The X server queries the attached monitor for supported resolution ranges, and attempts to pick the highest resolution available with the correct aspect ratio for the display. Users can set their preferred resolution in System → Preferences → Screen Resolution, and the default resolution for the system can be changed with System → Administration → Display.
If the /etc/X11/xorg.conf configuration file is not present, X also automatically detects the appropriate driver, and assumes a 105-key US keyboard layout.

Look at /var/log/Xorg.0.log. It will tell you what modes have been found and are available and which driver is being used. (See the section 4 man pages or http://ftp.x.org/pub/X11R7.0/doc/html/manindex4.html for the options available for the driver.) It should also tell you if the monitor does not support DDC. I would guess if you want to add a mode, because the monitor does not have DDC, that you will also have to add a ModeLine entry to xorg.conf as well as the Modes entry. These can be generated using cvt or gtf. See the man pages for xorg.conf and cvt and gtf.

I still have an FC5 installation and on investigation it was using X.org 7.0 which I do not think was much different from 7.1.