PDA

View Full Version : Error when FC6 is loading



superartur0
30th October 2006, 06:15 AM
Hello all,

I installed Fedora Core 6 and I am getting an error when the operating system is loading:
The error is related with "acpi-cpufreq.ko" and it say something about "module not found".
It also says that I should look iptables-restore -h.

Does anybody know how to solve this or eliminate the error message?

Thanks! in advance.

superartur0
30th October 2006, 06:41 AM
When the sytem is loading the message that I get says:

Fatal Error /lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko
No such device.

I checked the directory and the file exists. Does anybody know how to get rid of the error message during boot up?

Seve
30th October 2006, 06:47 AM
Hello:
Just a thought?
Have you checked to see if you have your CPU speed daemon disabled and or enabled [one or the other] in your Services?

Seve

Saint Mike
30th October 2006, 06:50 AM
You could try turning off acpi service in system -> administration -> services

I think i had something similare come up, dont think its doing any harm, you can still boot right?

shap
4th November 2006, 05:30 PM
I have same problem. Interesting think that after loading windows on the same PC (IBM T41) and reinstalling FC6 - problem will gone ! It seems that the problem in install program...

MoonMoon
4th November 2006, 06:48 PM
When the sytem is loading the message that I get says:

Fatal Error /lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko
No such device.

I checked the directory and the file exists. Does anybody know how to get rid of the error message during boot up?

I had the similar symptom on one of my old Thinkpad, it's the problem of BIOS ACPI not standard compilant.

you may ignore it
or, turn off acpi in kernel loading option with acpi=off
or, put further strict loading with kernel options acpi=strict if BIOS ACPI is the causes.

**kernel option acpi=off may not power off the system in FC6 kernel 2.6.18-1.2798(TESTED,CONFIRM)


You could try turning off acpi service in system -> administration -> services

It's not help even startup service acpi is stop(TESTED,CONFIRM)

shap
4th November 2006, 07:30 PM
From what I found in other thread, it is the problem with install program - it install i586 kernel instead of i686. Manually install of Kernel i686 solve the problem.

MoonMoon
4th November 2006, 09:54 PM
From what I found in other thread, it is the problem with install program - it install i586 kernel instead of i686. Manually install of Kernel i686 solve the problem.

It's not the CAUSES of i586 kernel problem(I FULLY TESTED)
1. whether FC6 i586 or i686 kernel(kernel-2.6.18-1.2798.fc6), the error message still exist while kernel loading in acpi
Fatal Error /lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko
No such device.
2. if acpi=off in kernel option, the FC6 cannot POWER DOWN, it will stall at the final & display
Shutdown: hda
System halted.

Moreover, I force install the FC5 kernel kernel-2.6.18-1.2200.fc5.i686.rpm & tested, both the above 2 symptoms are not occured.

Temporary, I use the kernel-2.6.18-1.2200.fc5.i686.rpm in FC6 is quite normal in APM mode. (NOT RECOMMENDED!!!!) :rolleyes:

shap
5th November 2006, 10:17 AM
Maybe you are right. The fact is that after loading Windows (I have separate hard disk) and then reinstalling the FC6 solved the problem to me. Maybe BIOS is not initialized properly by FC6 install in some causes ...