PDA

View Full Version : Help New To Linux!!



xGutsAndGloryx
30th October 2006, 02:52 AM
--------------------------------------------------------------------------------
i am new to the linux operating system. i am very eager to learn it but i am running into some problems. i am looking for some assistance in the following problems.
i am trying to run updates using YUM. I kept getting various error message mostly half way through the update. I am still trying to understand how stuff works. I am trying to install new themes & stuff. I get the files downloaded into the correct folder but they aren't viewable by the control panel. I am wanting to update to the latest version of fedora core. i have kepting have problems doing so. I am really wanting to learn linux but has you can see i need a good bit of help getting me pointed in the right direction. any assistance is very much appreciated..


Jeff B

u-noneinc-s
30th October 2006, 03:24 AM
1; OS and arch FC4 FC5 FC6? i386 x86-64 PPC etc
2; Seperate your problems into seperate paragraphs. It makes it easier to follow. (We are all guilty of this from time to time).
3; Give some detail about how you proceded with your task. ie: I DLd a theme to my desktop or to my /home/username/packagename and "what" application you are trying to access it with. (Generally themes are .tar.gz or .tar.bz and need to be unpacked and installed the theme). There are different types of packages with different installtion methods. The .tar's already mentiond and rpms are typical for fedora but there are others .bin and .sh for example so that is helpful info too.
4; Error messages are essential. If you are using yum and getting errors in the middle of the process, I'll guess that it's dependencies, copy and paste the error into your message.

Post back.
Welcome and good luck. Learn a lot so you can contribute down the line :D

xGutsAndGloryx
30th October 2006, 03:29 AM
ok thanks! i will get the information tonight after work! i will posted on it here. i was looking to update to FC6. i hope that answers that question. do you know any websites that are good for newbies to learn??

u-noneinc-s
30th October 2006, 05:17 AM
This is the only one that really helped me. I probably learned more from just monitoring this form than from asking questions. There have been some lists of websites for newbies, but i haven't bookmarked any. I know I should have linked them for myself.

There is a how-to forum in the forum jump link below. Many may be over your head, but not all. Too many for me to think about. It's loaded. Look for something from Firewing1. I haven't checked it out but I think he has a newbie guide listed. (I would guess it's a FC newbie guide and not a Linux newbie guide but it should be pretty helpful.

xGutsAndGloryx
30th October 2006, 06:46 AM
I have downloaded several themes to /root/.kde/share/apps/kthememanager/themes.... they aren't showing up in the kthememanager.....

the yum error message i am getting is:
Traceback (most recent call last):
File "/usr/bin/yum", line 15, in ?
yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 149, in main
base.doTransaction()
File "/usr/share/yum-cli/cli.py", line 592, in doTransaction
problems = self.downloadPkgs(downloadpkgs)
File "__init__.py", line 565, in downloadPkgs
File "repos.py", line 605, in get
File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 414, in urlgrab
return self._mirror_try(func, url, kw)
File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 392, in _mirror_try
mirrorchoice = self._get_mirror(gr)
File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line 290, in _get_mirror
return gr.mirrors[gr._next]
IndexError: list index out of range


I am wanting to update to the latest verision of Fedora Core 6 but i am unsure how to do it...



i hope i am broken things down better now.


Jeff B

u-noneinc-s
30th October 2006, 07:19 AM
To upgrade to FC6 with yum will take some work. I'll leave that to someone with more knowlege.

For yum, first try yum clean all then try yum check-update and see if yum at least works now. If it doesn't work, post your yum config cat /etc/yum.conf and your repos cat /etc/yum.repos.d/*

What theme are you trying to install (include the extention .tar.gz or whatever) Post it, Is it from kdelook.org? I assume because you DLd it to /root/.kde/.....

You should DL them to your home dir unless the install instructions said to DL them to /root/.kde/share/apps/kthememanager/themes. (I don't have that dir, maybe that's why you can't find them). For KDE at least, they do go in /usr/share/apps/kthememanager/themes but usually after you unpack them and install them. DLing them will not install them.

xGutsAndGloryx
30th October 2006, 07:58 AM
i am having a hard time unpacking the theme files...

u-noneinc-s
30th October 2006, 08:07 AM
For a .tar.gz file, cd to the dir it is in and do
tar zxvf filename.tar.gz Then cd to the new unpacked dir and look for INSTALL. read it.

For .tar.bz (or bz2) cd to the dir it's in and do
tar jxvf filename.tar.bz (or bz2) and cd to the new dir and read INSTALL

There won't always be an INSTALL after you unpack it. Sometimes there will be a filename.sh. Get into that later (or if that is the case with this one).

xGutsAndGloryx
30th October 2006, 10:53 PM
If it doesn't work, post your yum config cat /etc/yum.conf and your repos cat /etc/yum.repos.d/*

where do i find that information??



i am having a hard time understand what the basic programs in the main kde menu do. do you know anything that can assist me with that?

u-noneinc-s
30th October 2006, 11:28 PM
Open a terminal and enter the following commands.
cat /etc/yum.conf and you will get a bunch of info. Then do the same for
cat /etc/yum.repos.d/*
Post them in seperate sections of the same message or in seperate messages if you need to (they shold fit in one message).

to do that, click on the "advance" button just below The message window. You will be presented with posting options. You can click Guided mode then click on the # and paste the info into the little window that pops up and click ok. Then click the # again and paste in the next set of info and click ok. (You can click on priview and see how it comes out).

If you don't know how to copy and paste with linux, it's not quite the same as windows. (It's easier). Just left click at the start of the text and drag to the end and release. The info is copied. middle click "in" the the code (#) window and it is pasted.

I may not be able to figure this out unless it's obvious but someone will.

xGutsAndGloryx
31st October 2006, 10:34 PM
i was able to get a theme installed last night... i have a questions about downloading programs and other stuff to the system.... do you go about installing them like i did the theme?

u-noneinc-s
31st October 2006, 11:00 PM
It all depends on the filetype.
Fedora is "based" on an rpm package manages. .rpm files can be installed with the rpm command.
read "man rpm" (without the quotes) for details, but basically rpm -i to install a package rpm -U to update a package (but will also install the package if it's not already there) and rpm -e to erase/remove a package. There are dependencies for many (most) packages so rpm was a hassle intalling packages because you had to track down and install all the dependencies first (and many dependencies may have dependencies) so yum was developed. It uses repos (locations on the web with all the core extras and available updates) and in most cases it takes care of the dependencies for you. There are also "3rd party" repos for stuff that isn't otherwise supported by Fedora.

You should use yum whenever possible. When yum can't find a bpackage you may be able to find an rpm on the net and DL it somewhere and still install it with yum.

Compiling is another option but is involved (like many themes). The are the .tar.gz (or .bz or .bz2 files) you generally unpack them like I showed you and they are usually compiled with ./configure make and make install but not all are compiled. some are sh or bin installers which need to be made executable (I'm not sure if .bin and .sh are handled the same but I think they are). If the file is executable you will see it with ls -l filename. it will show something like this on the left side -rwx-rx-x (may vary but the x means executable). If there is no x you need to chmod +x filename.sh or .bin. (You do not want to make "any old file" executable). To install them ./filename.sh (or.bin) (that is dot/). Sometimes this needs to be done as root sometimes as user.

Keep in mind that yum update will only update packages found in the rpmdb so compiled and bin/sh installed packages won't get updated when you update your system

This is a bit much so until you get the hang of it, ask.

BTW, all (or most) commands have manuals. man rpm man yum Some are straight forward some are very cryptic and hard to follow. The more you learn the simple ones, the easier it becomes to understand the cryptic ones. I still don't understand most so I've got a long way to go (but I've always been pretty slow with compters, your mileage may vary).

Hope this helps some and did you get yum taken care of? If not, you should start a new thread to attract the appropriate attention.

xGutsAndGloryx
2nd November 2006, 07:54 AM
I just tried installing a program. i got this error after using ./configure

This particular compiler version is blacklisted because it
is known to miscompile KDE. Please use a newer version, or
if that is not yet available, choose an older version.

Please do not report a bug or bother us reporting this
configure error. We know about it, and we introduced
it by intention to avoid untraceable bugs or crashes in KDE.


what do i do?

u-noneinc-s
2nd November 2006, 08:07 AM
I can't offer anything on this one except that the error says you need a newer compiler if one is availabel (or an older if one if is not available. Do you know what compiler it is? It should tell you in the output somewhere.
I haven't done much in the way of compiling myself. One or two app, and a couple of themes is about the extent of my experience.

u-noneinc-s
2nd November 2006, 08:16 AM
BTW, KDE is available from yum. What part of KDE are you compiling and is there a reason for compiling it instead of using yum?
Just for the experience? Is yum still broken?

xGutsAndGloryx
2nd November 2006, 08:53 PM
no i was finally able to update using yum... i am trying to install some programs... i thought ./configure was how you do it

u-noneinc-s
2nd November 2006, 09:16 PM
i am trying to install some programs... i thought ./configure was how you do it
This particular compiler version is blacklisted because it
is known to miscompile KDE This is why I asked what part of KDE you were installing. If it is "Part" of KDE [kde-toys kde-acces... kde--whatever] it can be done with yum (or all of KDE)
yum groupinstall "KDE (K Desktop Environment)" with the quotes, will get you the KDE desktop. If it's just a componint of KDE like kdegames
yum install kdegames
If it some other software that happens to require kde then it depends on the SW but nost of it is available through yum.
What is it you are installing?

xGutsAndGloryx
6th November 2006, 12:29 AM
i believe it was a flash plugin for firefox

u-noneinc-s
6th November 2006, 12:43 AM
So did you get it installed?

xGutsAndGloryx
6th November 2006, 12:44 AM
no i tried ./configure and it gave me a error message

xGutsAndGloryx
6th November 2006, 12:50 AM
no it wasn't flash plugin... it was some desktop software...i downloaded it from kdelook.org

u-noneinc-s
6th November 2006, 12:58 AM
1) Did you read the INSTALL after you unpacked the file (I assume it was flash-someversion.tar.gz?)
2) Was there a file called INSTALL or was there one called installer.sh or installer.bin or anything like that?
3) Flash can be installed with yum if you install the macromedia repo.
http://www.mjmwired.net/resources/mjm-fedora-fc6.html#flash (YOU MIGHT WANT TO LOOK THROUGH THE ENTIRE SITE!).
4) Many are recommending flash 9 beta (it will play the flash 8 media the the current flash7.0x won't play)
http://www.fedoraforum.org/forum/search.php?searchid=2620874
http://www.fedoraforum.org/forum/showthread.php?t=127216&highlight=flash+beta

xGutsAndGloryx
6th November 2006, 01:03 AM
i believe it wasn't flash... i think it was some desktop software from kde website

u-noneinc-s
6th November 2006, 01:07 AM
no it wasn't flash plugin... it was some desktop software...i downloaded it from kdelook.org
It helps to know what software and what type of package (.tar.gz .rpm etc). And the exact error message(s) you got.

Not all .tar.gz files will need ./configure make and make install to install them. That;'s why you need to read the docs (INSTALL and README if they are there) If INSTALL is not there, ./configure might not the the correct method.

xGutsAndGloryx
6th November 2006, 01:20 AM
how do you install rpm files? what all other file types are there? how do you install them?

u-noneinc-s
6th November 2006, 02:00 AM
The preferred method of installing rpms is through yum. however, if the rpm you want to install is not any of the repos, you can DL the file to some convinient location on your computer and still install it with yum. Lets say you have a directory called /home/username/Download and that's where you DL the file.

yum localinstall ~/Download/filename.rpm (~ is the same as typing /home/username) and yum will still search the repos for any dependencies (if needed) and install the package.

There is also the rpm command. (I'm sure I mentioned this in another thread) to install a package
rpm -i filename.rpm to update an existing package
rpm -U and to erase a package
rpm -e
man rpm will give you all the options for rpm.
man yum will give you all the options for yum

There are .rpm .tar.gz .tar.bz .tar.bz2 .sh .bin sometimes the .sh and .bin will be in the .tar.gz or bz or bz2 and sometimes they will be independent
There are probably some I am forgetting about (or am unfamiliar with) man is the command for reading manuals for most of these. (I don't recall the man for bz and bz2) man tar for tar (archiver) man gzip for .gz (gzip file compression).

How to do all these is too much for me to cover. I'm not the brightest bulb on the forum. I have compiled very few apps (./configure make make install). I haven't really played with rpm since I started using yum. .bin and .sh are "relatively" new with Linux.

rappermas
6th November 2006, 02:47 AM
Whoa, slow down. First of all, I saw that you downloaded something into the /root directory earlier on. If you're logging in as root, that's not a very good idea at all. Instead, create a user account to use--logging in as root is dangerous. When you need root access to something, just type:


su -

After asking for a password, you will become root temporarily, until you close the command line terminal.

Looks like you're trying to install software. Most can and should be installed from YUM. You want to use standard ways of installing software on any distribution, such as Fedora, so that it can be updated and kept track of by the system. If you are more comfortable with use a GUI application for YUM, you can do this:



yum install yumex


That will give you a graphical front-end for yum that you will be able to find in the Applications menu or by simply typing in "yumex" at the command line.

If you need to install an RPM, I usually do it by typing this in:


yum localinstall [packagename]

This will not only install that package, but all of the other packages that it needs to work, called dependencies. Now, sometimes, for other reasons, you may want to use the actual rpm command to install--to do that, type in:


rpm -iv [packagename]


RPM has a few options, or switches. I'll list the important ones here:


-i Install
-U update
-v verbose (tells you what's going on)
-h hash marks (command line version of the progress bar)
-q [packagename] query (find out if a package is installed
-qa query all (list all packages installed on system)


Of course, to install anything, you have to have root access.

The most difficult kind of software to install is from source. These usually come in a .tar.gz or a .tar.bz2 format. To extract them, you'd change to the directory in which they are installed and type in:


tar zxfv [archivename]

to extract a tar.gz archive.
Alternatively, you could type in:


tar xfvj [archivename]

to extract a tar.bz2 archive.

Then, most complex software will have a configure script that checks your environment and prepares makefiles. This script is run by typing in:


./configure

If this script fails, that means that you don't have some necessary software installed, such as GTK+, QT libraries, the g++ compiler, anything. Looking at the output will help you determine what it's missing. If the configure scripts succeeds and there are no errors, what you can do is go ahead and build the software by typing:


make

This might take a while. On my PIII machine running at 900 Mhz, wine, which is a compatibility layer that lets you run some windows applications, takes about one hour to compile. The same compilation, on a Pentium D running at 3.00 Ghz (another one of my machines) takes less time, but it isn't instantaneous either. Be patient during this part. After building the software, it needs to be installed. To do that, become root, and type in:


sudo make install

You'll see some more text fly by and the software will be installed. Usually, to run it, you can just type in the name and it will run (most software puts its binary executables in somewhere in your $PATH). Usually, the file to run the software will be installed in /usr/bin. If you, for example, compile anjuta, a C++ IDE, and follow the steps that I outlined for building from source above, you can just type in anjuta at the command line and the application will open. Some aren't as easy. You can usually find the right file for it if you type in the following:


cd /usr/bin
ls | grep [partial_name_of_recently_installed_program]

This will search all of the binaries in that directory and return the ones that match the argument that you passed to grep, in this case, the partial name for a program that you just recently installed and are looking for.

If the software is to be built in a non-standard way, there will usually be a README or INSTALL file that you can read to find out how to build it.

That's about it. Good luck!

u-noneinc-s
6th November 2006, 02:58 AM
You said it a lot better than I ever could have rappermas. (I hadn't noticed the root login either, so kudos there too ;))

rappermas
6th November 2006, 03:13 AM
You said it a lot better than I ever could have rappermas. (I hadn't noticed the root login either, so kudos there too ;))
I felt like I should make my 700th post special. :D

u-noneinc-s
6th November 2006, 03:29 AM
And special it was.
xGutsAndGloryx: I hope rappermas explainations were more helpful than mine, however. If you still have problems with installing packages in the future, it will be easier to explain (perhaps in more detail) with the "particular" package you have the problem with. Also starting a new thread with a specific title for the problem may be appropriate so it get the attention deserved.
(Just a thought, not a requirement)
Good luck. Stick with it. You'll be answering instead of asking in no time.