PDA

View Full Version : FC6 DVD issues



lisally
29th October 2006, 06:58 AM
I installed FC6 this past week, and now my computer is having issues reading and playing dvds.
Problems:
1.The disc is not automnatically recognized and mounted when i put in a dvd. Cds work fine in the drive and a dialog pops up when one is inserted
2. MNovie playback-although the dvd doesn't show up in the system folder, the disc is read by xine and kaffeine. however, all i get is sound without any picture

ANyone have similar issues or any idea what I may need to fix this?

rkl
29th October 2006, 11:37 AM
1.The disc is not automnatically recognized and mounted when i put in a dvd. Cds work fine in the drive and a dialog pops up when one is inserted

I'm assuming you're talking about a movie DVD here - try this:

System -> Preferences -> Removable Drives and Media -> Multimedia tab

I tick the "Play video DVD discs when inserted" option and then put this in the Command: box next to that:

xine --auto-scan dvd --auto-play -f --deinterlace

[This will run xine and play back the movie DVD automatically full screen - remove the "-f" if you don't want full screen]

You will need to not only have xine installed, but also libdvdread and libdvdcss from the livna repository. To enable livna, run this command:

rpm -ivh http://rpm.livna.org/livna-release-6.rpm

Once that's in place, something like "yum install xine libdvdread libdvdcss" should do the trick.

lisally
29th October 2006, 11:43 AM
Thanks for your reply.

I have both libraries installed, so that isn't the problem, and xine will read the disc but play only the audio with no video.

Aslo, when i insert a dvd, the system does not even recognize that a disc is present in the drive, despite the fact that xine and kaffeine read from it.

the drive is a combo cd-burner/dvd-rom, if that makes a difference.

varspigil
29th October 2006, 09:22 PM
Lisally,

I seem to be having the same problem you are. I get sound through xine just fine, but I'm not getting any video at all.

All I get is a dark window.

Interestingly, I don't get the Xine splash movie either. I thought that was odd and thing it may be symptomatic of the video problem.

Anyone have any advice?

Varspigil

lisally
30th October 2006, 06:59 AM
varspigil-the mount thing is a bug, but I found a way to fix the video.

Set xine configuration to advanced level, and then go to the video tab. For the video driver, instead of "auto", choose one of the drivers. I found that xshm is working well.

varspigil
30th October 2006, 03:07 PM
Woohoo! Success! Thanks millions...

akbowbender
4th November 2006, 03:03 AM
So far, this doesn't work for me. Is there a way to tell which driver xine has selected when I play a dvd and it is set on auto? I tried xshm, but it didn't work.

varspigil
4th November 2006, 08:57 PM
Try to XV driver, that's the one recommended by the xine website if you are experiencing high dropped frame rates (which I am on one of my laptops).

Are you also experiencing the same kinds of problems or are the symptoms different?

akbowbender
5th November 2006, 11:54 PM
Actually, my playback is just fine with the auto setting. DVD's just aren't recognized and mounted per the original post. Was hoping that the driver change might correct this.....

varspigil
6th November 2006, 12:33 AM
I don't think it will. It's likely your issue is before xine even gets involved.

I'm presuming that you are not seeing the disk appear on your desktop (hence you're saying that it's not mounted).

Can you mount the device manually (I used to have this problem with flash media, but once I mounted it manually it seemed to mount automatically there after.

akbowbender
6th November 2006, 02:07 AM
Yes, I can mount manually.

You're right about it being something not happening before xine. From other posts, HALD is having problems with DVD's. I have also noticed that it mounts CD's to /media/"volume_label" instead of /media/cdrecorder like FC5 did. Kind of frustrating that everything worked great under FC5, and now we have to work with these glitches in FC6.