PDA

View Full Version : Java JDK on Fedora 6



cruiseoveride
29th October 2006, 02:21 AM
I seem to have a problem getting JDK to run on my fc6 machine.

I installed jdk 1.5 update 9, which mind you, worked perfectly on Fedora 5. However with fedora 6, i am able to run a java program but the gui comes up blank (white java window).

For example if i try to start Netbeans. It shows me the splash screen, it loads all the stuff required, and when the splash disappears, I just a get a big white blank window.

Same thing is happening with Limewire

However, Bluej seems to work well, a little slow, but it works none the less. Initially it was complaining about a an over strict firewall, ( inever knew bluej needed tcp localhost access), so i opened "iptables -I INPUT -s localhost -j ACCEPT " and tried BlueJ again and now it works.

Why is Netbeans and Limewire doing this?

cruiseoveride
29th October 2006, 02:38 AM
If i replace compiz with metacity all java apps seem to work flawlessly again

who do i complain to about this :)

cruiseoveride
29th October 2006, 02:41 AM
http://lists.freedesktop.org/archives/compiz/2006-June/000224.html

mihaimm
13th November 2006, 01:32 PM
The bug id from Sun is 6429775 (http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6429775). If you have a Sun Developper Account you can vote for it.

In another interesting line of thought... If you change the execution VM for the "bundled" Eclipse that comes with Java and you use any Java VM (1.5, 1.6) that is normally failing to draw the windows with Compiz... it is working....

My question is... how does this happen? Is it a special compilation of Eclipse, so special that it works despite the named bug? Or is there a setting that could be done at VM level in order to work-arround this problem?

Other than that... you can always install j2sdk 1.4.13 that works just fine with Compiz. But somethimes you just need 1.5...

Edit: updated the bug link, thanks cruiseoveride

cruiseoveride
13th November 2006, 04:31 PM
Yah I need 1.5, the bug link u put up,, is that the one to do with compiz, seems to be a problem on windows?

mihaimm
13th November 2006, 05:48 PM
Sorry... you're right: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6429775. This is the correct bug.

cruiseoveride
13th November 2006, 06:02 PM
thanks a lot.
Ok, Sun is looking into it, You have 2 basic options

1. Use Xnest
2. Use AWT_TOOLKIT=MToolkit environmental variable // may work, (works for me)

EDIT: Beloved NetBeans works again :)

sblantipodi
15th November 2006, 01:44 PM
someone in compiz forums told me that this bug has been fixed from compiz.
If fedora updates his package with this new version of compiz we probably solve this problem.

cruiseoveride
15th November 2006, 02:37 PM
Anyone who has AIGLX working in Fedora, is probably using berly, instead of compiz,
so lets they have a fix too.

sblantipodi
15th November 2006, 05:25 PM
Anyone who has AIGLX working in Fedora, is probably using berly, instead of compiz,
so lets they have a fix too.

sincerely I prefer 100 times Compiz than beryl.
I have both installed on my system but I prefer Compiz.

cruiseoveride
15th November 2006, 06:00 PM
I seem to like the way I can easily manipulate my Desktop effects with "beryl-settings-manager" and also how easy it is to change the theme and add more themes with "emerald-theme-manage"
I'm yet to see something that does the above for compiz?

Why is it, that you like compiz 100x more then beryl?