PDA

View Full Version : fc6 vs fc6xen



mrlinuxnewb
28th October 2006, 08:21 PM
ok im slowely but surely learning here. need some more help though. Im using a laptop and dual booting XP and now FC6. I have installed FC6 multiple times now. the first couple installs i installed virtualization cause it sounded cool. well i since found out that doing so gives you a different kernel, the xen kernel. Upon trying to install the beta nvidia drivers i ended up installing the regular fc6 kernel, whichever the most recent one is, as a dependecy. The problem im having is that it seems teh xen kernel runs MUCH better for me. the bootup takes a total of 1-2 minutes. With the regular FC6 kernel it takes about 5-10 minutes to boot, and the cpu/video card fan is constatnly spinning.

The two hangups in the regular kernel i have are at

uncompressing linux...ok, booting kernel
PCi....(some random stuff)
PCi....(some random stuff)
ide0: I/O resource 0x1f0-0x1f7 not free
ide0: I/0 parts already in use, skipping probe

--------hangs here for about 1-2minutes-----

Red Hat nash version 5..1.19


Then it also hangs while loading UDEV for about 2 minutes aswell. I guess the simple solution for me for the time being is to use the XEN kernel, however i dont get the cool desktop effects because of issues with the kmod-nvidia-xen video driver.

There is no way i am the only one having these issues. I have installed about 6 times now, and the XEN kernel is consistently running much better than the update fc6 one. XP runs fine, so i dont thnk its a hardware issue. Anyone got any clues or give me any advice to finding the root of the problelm?

tgm4883
28th October 2006, 09:01 PM
did you have the correct architecture when you installed the non xen kernel?

mrlinuxnewb
28th October 2006, 09:50 PM
they both from the same dvd. which was given to me. the fc6 from the dvd, and the yum updated one are both giveing me trouble. however the xen from the dvd gave me no problems

tgm4883
29th October 2006, 06:30 AM
I was referring to the anaconda bug in FC6. When I had the i586 kernel instead of the i686 kernel installed my system ran slow.

From Livna


Wednesday, October the 25th: kmod packages from livna

When installing packages with kmods (e.g. the ati and nvidia drivers) you might run into trouble like this:

Transaction Check Error: package kernel-2.6.18-1.2798.fc6 is already installed
file /boot/System.map-2.6.18-1.2798.fc6 from install of kernel-2.6.18-1.2798.fc6 conflicts with file from package kernel-2.6.18-1.2798.fc6
file /boot/config-2.6.18-1.2798.fc6 from install of kernel-2.6.18-1.2798.fc6 conflicts with file from package kernel-2.6.18-1.2798.fc6
file /boot/symvers-2.6.18-1.2798.fc6.gz from install of kernel-2.6.18-1.2798.fc6 conflicts with file from package kernel-2.6.18-1.2798.fc6
file /boot/vmlinuz-2.6.18-1.2798.fc6 from install of kernel-2.6.18-1.2798.fc6 conflicts with file from package kernel-2.6.18-1.2798.fc6

This is due to a bug in anaconda (the Fedora Core installer) that accidentally installed an i586 kernel on your i686 machine. Workaround

* switch to the i686 kernel and try again after a reboot
* install the i586 version of the kmod (e.g. run "yum install kmod-nvidia.i586")

mrlinuxnewb
29th October 2006, 03:39 PM
thanks for the reply. I think i actually came across your topic or someone elses maybe where that was happeneing. I dont think that is my issue because when i type 'arch' i get i686, and when i do a 'yum list kernel' it shows the one i have installed is an i686 kernel. so that seems to match up right now, but its still taking me like 5 minutes to get to the splash screen where you can click 'show details' to see what it is loading. makes for a pretty unefficient OS when you gotta wait 3-4 times the length it takes me to get into windows.

jazzyjerome
29th October 2006, 04:34 PM
I am trying to get nvidia drivers to work on Fedora 6. I tried to install files from http://rpm.livna.org/fedora/6/x86_64/repodata/ and I'm going through dependency hell. If anyone know how to resolve this issue please post it.