PDA

View Full Version : beta nvidia drivers



mrlinuxnewb
28th October 2006, 02:09 PM
ok if you couldnt tell by my name i am fairly new to linux. I installed the beta nvidia drivers from the livna testing repo. Prior to this install bootup took about a min or two. Since then it takes about 10 mins to boot into FC6.

The desktop looks great once i get in, but its getting there that takes forever. The first slowdown seems to be when "loading Red Hat nash version 5.1.19" which is like the first thing after you select the kernel in grub i think. Then it is realllly slow to load 'udev'. These two steps take about 8 mins combined, the rest is quick as normal. I understand that these are beta drivers so Im not supprised to see some bad side effects, but i guess im trying to get an better understanding of what is going on.

pparks1
28th October 2006, 02:52 PM
I'm not aware of the reason for your slowdown, but I am running the Nvidia beta drivers as well on FC6 to enable the desktop-effects and I am not haivng the slowdown problem that you mention. The addition of the nvidia drivers added 2 seconds to my overall boot process to the desktop.

mrlinuxnewb
28th October 2006, 04:44 PM
thanks for the reply fellow michigander. I did a fresh install and went about using yum to update my my drivers and stuff. Among the dependencies for kmod-nvidia was a new kernel. So i installed that solo just to see if that was the cause of the slow booting. Sure enough it was. Here is a list of the kernels i have installed.

[root@localhost andy]# rpm -qa | grep kernel
kernel-headers-2.6.18-1.2798.fc6
kernel-2.6.18-1.2798.fc6
kernel-xen-2.6.18-1.2798.fc6

kernel-2.6.18-1.2798.fc6 is the kernel yum installed. when i select this kernel from the grub menu, as I stated above, it boots very slowley through a couple areas. I will go about installing kmod anyways, but im kind of looking for some advice as to why im having these hangups while others arent. you must have installed this kernel too, correct?