PDA

View Full Version : Samba makes no sense



lightnb
28th October 2006, 10:13 AM
So far I've worked through three or more Samba file sharing tutorials online, and read through all the Samba help documentaion, but still can't figure out why some folders share and others dont.

I have two folders:

"/home/rahl" shared as 'home'
"/files" shared as 'files'

I have '/files' setup as a share in samba config (system-config-samba), and it is owned by user rahl, group rahl.

'/home/rahl' is not setup as a share in Samba config. It is also owned by rahl/rahl.

When I login to my windows computer as rahl, using the samba password as my windows login password, and access the server (run command '\\RMS' ) both of these show up as shares.

I can access '/home/rahl' just fine and it works perfectly. (Even though I'm not intentionally sharing it!)
When i try to access the '/files' share (by double clicking "files"), I get a login box.

I try typing 'rahl' and my password, but windows keeps changing my login ID to 'RFS\rahl' and making the box pop back up. over and over again.

This makes no sense. Why is it doing this?

Thanks in advance for any help.

ZeusZon
28th October 2006, 02:54 PM
Do you have to have secuirty? You can switch it off to make life easier.

System>Administration>Server Settings>Samba

Preferences>Server Settings

Basic Tab:
Workgroup=MyWorkgroupName

Security Tab:
Authentication mode: share (important)

Click OK


On Main window "Add Share"

Directory: /share (must exist)

Tick Visable
Tick Writable


Access Tab > Allow access to everyone

Click OK

On window machine:

Start>Run

Enter: \\localhost and hit enter (or whatever you hostname of your linux box is)

Waggoneer
29th October 2006, 04:39 PM
I followed these directions. From the windows box I can see my /jason/public folder, but when I try and open it, I get a "You dont have permission to access this network resource"
I wonder if it is because on the Server Settings window, Security tab the guest account is set to "No Guest Account" Is it supposed to be set to "everybody" or must I create a login for my windows box?
I never could get it to work under FC5 either.

fedorafan2
29th October 2006, 04:57 PM
Here is a good tutorial the Firewing1 wrote and this is what i used and had no problems. http://forums.fedoraforum.org/showthread.php?p=448977

ZeusZon
29th October 2006, 06:01 PM
I just reinstalled fc6 and tried the instructions in root account and worked perfectly fine.

I tried them in a user account and it didn't work. I'm still pretty new to fedora. I will have a play.

ZeusZon
29th October 2006, 06:07 PM
Ok. Well I figured it out on a user account.

Do what I mentioned in my first post.

Open a terminal:
su
cd /
mkdir share
chmod 777 share
exit

\\localhost on windows client

I can't share a folder inside my user account yet. I think it could be down to chmodding.(directory permssions) Might give it a go later.

ZeusZon
29th October 2006, 06:22 PM
Yep. Folder permissions.

chmod 777 /home
chmod 777 /home/user

Add as share in samba and works fine.

But I feel this is the wrong way to do it even if it works. Secuirty wise. Certainly if you have multiple users on your linux system. But I'm the only one that uses this machine.

lightnb
30th October 2006, 11:00 AM
Thank you all.

I'm trying to create a multi-user file server for multiple users on multiple computers, so having user based authetication keyed to thier windows login is important.

I'm having no problem sharing the "/home" folder, or any folder within the "/Home" folder.

It seems that only the folders that are higher in the directory structure are causing problems. ie. "/files" "/myshare" etc.

even with these folder chmoded to 777, they aren't behaving. Windows is just giving a login box.

Thanks again,

Nick

lightnb
3rd November 2006, 04:34 AM
Is there some strange thing built into Fedora that doesn't allow sharing of higher level directories?

lightnb
6th November 2006, 05:13 AM
Is there some strange thing built into Fedora that doesn't allow sharing of higher level directories?