PDA

View Full Version : 'Win + Key' keys combination doesn't work in selfcompiled KDE 3.5.5



birdie
28th October 2006, 06:33 AM
Hello, guys

I've recently installed FC6 from the scratch then I compiled from the sources and installed KDE3 into /opt/kde3. The problem is that my KDE is unable to intercept 'Win + Key' keys combination.

This is how it happens: in Keyboards Shortcuts kcm module I choose to modify any global shortcut and e.g. press Win + Esc. I see "Win + " on the screen but when I press 'Esc', the only 'Esc' key got entered into the "Primary Shortcut". And yes I've already tried enabling "Multikey" mode with no success. It looks like my X.org 7.1 server doesn't treat Win key as a modifier - so it doesn't allow "Win" key to be pressed together with any other key.

Please, give me an idea how to solve this problem.

Here's my keyboard section of xorg.conf


Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru(winkeys)"
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
Option "Xleds" "1 2 3"
EndSection

birdie
28th October 2006, 07:14 AM
I have just installed FC6 on another PC with supplied KDE 3.5.4 and the same issue arose.

It seems like "Win" key handling in FC6/X.org 7.1 is completely broken.

birdie
29th October 2006, 10:09 AM
I'm sorry but I have to put this topic upper. How can it happen that no one doesn't have such a problem?

birdie
30th October 2006, 05:16 PM
I'm sorry but I have to put this topic upper. How can it happen that no one doesn't have such a problem?