PDA

View Full Version : Dual head problem with NVidia graphics card (FC6)



OOOOO
27th October 2006, 07:34 PM
Hi all,

At the moment, I am runnning FC6 on a Acer 1913 only and I have no problems. Also connected to my NVIDIA graphics card (dual head) is a dell E773P, which I want to run as a dual view on fc6. THe problem I have is that whenever I enable dual head in display settings, when I restart the X server it crashes and reverts to the old backup.

I have attached my 2 xorg.conf file for oyu to view if it helps


current xorg.conf - single acer monitor - this works.

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768"$
EndSubSection
EndSection


Xorg.conf for dual head, which causes the X server to crash.

GNU nano 1.3.12 File: /etc/X11/xorg.conf

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Dell E773p"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nv"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation NV34 [GeForce FX 5200]"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x1024" "1280x960" "1280x960" "1280x800$
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Many thanks in advance for your help

Melio
27th October 2006, 08:05 PM
This is my setup in FC5, it may help.

leon85
27th October 2006, 08:16 PM
I have dual head and it does the same thing, apparently from your xorg.conf you dont have the nvidia drivers installed, in order to have dual head, you need to have your video card installed



Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nv"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation NV34 [GeForce FX 5200]"
BusID "PCI:1:0:0"
Screen 1
EndSection


if you already installed your video drivers then in you xorg.conf in the device section "driver" change booth from "nv" to "nvidia" then enable your dual head

NOTE: when you enable dual head fedora will ask you to log out and log back in, BEFORE YOU LOG OUT, go back to your xorg.conf and make sure that it says "nvidia" and not "nv" on both devices because the Fedora core display utility tend to change it to default which is "nv" and thats why it gives you errors

let me know how that works out for you! :D

OOOOO
28th October 2006, 04:35 PM
Hi

I have now installed the NVIDIA drivers. When I go to system > administration > Display > hardware and choose the nvidia drivers (as opposed to the nv drivers), and restart the x server, it crashes and says there was a fatal error and has to generate a new xorg.conf.

Any ideas?

Thanks for your help

JaRaEeZ
28th October 2006, 05:13 PM
Ive noticed in your dual xorg.conf you have only 1 monitor listed!

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Dell E773p"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"

OOOOO
28th October 2006, 05:34 PM
oh yes - that is strange, i have regenerated my xorg.conf using system-config-display and it has produced this


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "on"
Option "Clone" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Dell E773p"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor 1280x1024"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 79.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nv"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation NV34 [GeForce FX 5200]"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

However it still does not work. :(

What do you recommend now?

Thanks again

OOOOO
29th October 2006, 11:10 AM
Just another thing to add, when liinux is starting up, it says
´Loading NVIDIA kernel modules' [ Failed ]

Could this be causing the problem?

OOOOO
29th October 2006, 02:51 PM
Ok,

an update now to the problem...I think I am now almost there.

I have successfully installed the nvidia drivers. In system-settings-display, dual head in enabled and the x server no longer crashes. The xorg is also configured to use nvidia drivers, not nv. The problem is that the secondary monitor is just on standby the whole time and I cannot move my mouse of the primary monitor - so basicly it is still only running 1 monitor.

Here is my xorg.conf


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
ModelName "LCD Panel 1280x1024"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 67.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor 1024x768"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"

### Screen 1
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation NV34 [GeForce FX 5200]"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Extensions"
Option "Composite"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Thanks for your help so far

Melio
29th October 2006, 04:12 PM
so how's it going now?

OOOOO
29th October 2006, 04:16 PM
so how's it going now?

At the moment the primary monitor is working 100% properly, however the secondary monitor is on power saving mode constantly and my mouse is confined to one desktop

zeno0771
29th October 2006, 05:25 PM
Try this xorg.conf...
I'm running an nVidia 5500 dual-head (PNY Verto) with a pair of Dell flat-panels; just install the 8774 nVidia drivers (8776 glitches on kernel headers and I hear FC6 has this problem too) and copy/paste this .conf (edit it for your own monitors and video card, AGP or PCI etc), I'm running it as I write this and no issues whatsoever-

leon85
30th October 2006, 02:14 AM
Ok,

an update now to the problem...I think I am now almost there.

I have successfully installed the nvidia drivers. In system-settings-display, dual head in enabled and the x server no longer crashes. The xorg is also configured to use nvidia drivers, not nv. The problem is that the secondary monitor is just on standby the whole time and I cannot move my mouse of the primary monitor - so basicly it is still only running 1 monitor.

Here is my xorg.conf


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
ModelName "LCD Panel 1280x1024"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 67.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor 1024x768"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"

### Screen 1
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation NV34 [GeForce FX 5200]"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Extensions"
Option "Composite"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Thanks for your help so far

Thats because you have your "Xinerama" turned off, in order to have it working you need to turn it on in the xorg.conf file, at the top you should see Option "Xinerama" "off" change it to Option "Xinerama" "on"

OOOOO
30th October 2006, 07:15 PM
wow! Youŕe a genius! Now, my dual head is working, with both monitors showing FC6!

However, there is one small problem. Both displays are 1280x1024, screen0 is 1280x1024 but screen1 is 800x600. So, basicly, the problem is that screen 1 is (for some reason) set at 800x600 yet the desktop is 1280x1024, so when I move the mouse to the edge of screen0, the display navigates around.

I hope you understand what I mean, if not, let me know and I will try to explain better.

Anyway, if anyone knows why this is happening, it would be much appreciated as this is the last herdle.

Thanks!

leon85
30th October 2006, 07:19 PM
can you post you xorg.conf ?

OOOOO
30th October 2006, 07:22 PM
Sorry, I have just got it working! whoooooooooo!

Thanks for all your helps guys - really appreciated!

Melio
4th November 2006, 06:47 PM
Yer welcome, happy fedoraing!