PDA

View Full Version : New guy needs help!



rybowilson
27th October 2006, 05:32 PM
Hello

I recently put together an Athlon64 system to mess with in my spare time. I've installed the 64-bit version of XP pro on my main hard drive (SATA), and on an old drive (IDE) I had laying around I decided to try some linux. Here's what's in the computer, before I go on:

Athlon64 3700+, 2.2 GHz
Asus A8-X mobo
1 GB RAM
eVGA GeForce 7300LE 256MB DDR video
Maxtor 80GB SATA150 HDD
really ancient Quantum Fireball 10GB drive, like I said it was laying around

So I just installed Fedora Core 6 on this thing, and after battling with GRUB and hours of google searching I finally got the bootloading to work the way I want it. So I'm trying to install drivers for things so that the system runs smoother and I get the proper video settings I want. I downloaded the newest driver from nVidia, and the .run file they gave me won't run in X Server, according to the error message. It said to try runlevel 3 to install it. Fine and dandy, except I cannot get to runlevel 3. When I try to go from 5 to 3 in the console it freezes at Starting irqbalance. So I go to single user mode, then go to runlevel 3, and it freezes at these SMART errors. I get stuff like this:

hda: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
hda: drive_cmd: status=0x04 { DriveStatusError }
ide: failed opcode was: 0xb0

I've seen in some other forums that smartmontools can help with this, but I know very little about it. Also, for that old hard drive (which is hda), the BIOS shows a SMART error for the drive as well. I really don't care about this drive, it has nothing important on it, Linux is just a project until I know how to use it better. How do I disable SMART so I can get on with the rest of my day? Thanks!

P.S.- I'm sure there are more errors and obstacles in the way, so you probably haven't heard the last of me

multescugeorge@
27th October 2006, 06:01 PM
you can try disableing SMART from both linux and the bios.
for linux type in a terminal:
system-config-services
there find and disable smartd, (or smart, not sure)
I had similar errors on my cd-drive (i still do actually), but they don't freeze my system.
You can also try booting with:
ide=nodma
option at the kernel comand line: at the grub boot screen select fedora, press a, then add that option, perhaps will help.

space_cadet
27th October 2006, 08:32 PM
Hello

I recently put together an Athlon64 system to mess with in my spare time. I've installed the 64-bit version of XP pro on my main hard drive (SATA), and on an old drive (IDE) I had laying around I decided to try some linux. Here's what's in the computer, before I go on:

Athlon64 3700+, 2.2 GHz
Asus A8-X mobo
1 GB RAM
eVGA GeForce 7300LE 256MB DDR video
Maxtor 80GB SATA150 HDD
really ancient Quantum Fireball 10GB drive, like I said it was laying around

So I just installed Fedora Core 6 on this thing, and after battling with GRUB and hours of google searching I finally got the bootloading to work the way I want it. So I'm trying to install drivers for things so that the system runs smoother and I get the proper video settings I want. I downloaded the newest driver from nVidia, and the .run file they gave me won't run in X Server, according to the error message. It said to try runlevel 3 to install it. Fine and dandy, except I cannot get to runlevel 3. When I try to go from 5 to 3 in the console it freezes at Starting irqbalance. So I go to single user mode, then go to runlevel 3, and it freezes at these SMART errors. I get stuff like this:

hda: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
hda: drive_cmd: status=0x04 { DriveStatusError }
ide: failed opcode was: 0xb0

I've seen in some other forums that smartmontools can help with this, but I know very little about it. Also, for that old hard drive (which is hda), the BIOS shows a SMART error for the drive as well. I really don't care about this drive, it has nothing important on it, Linux is just a project until I know how to use it better. How do I disable SMART so I can get on with the rest of my day? Thanks!

P.S.- I'm sure there are more errors and obstacles in the way, so you probably haven't heard the last of me
Same problem here, and here is solution:

As root edit file '/etc/smartd.conf'. Delete first line (second line describes why you should do that). When find line that says '#/dev/hda -a' and uncomment it (delete # character). After that find line that says '/dev/hda -H -m root' and comment it (add # character to beggining of that line). After that restart smartd daemon '/sbin/service smartd restart'. Try to test your hard drive: '/usr/sbin/smartctl -H /dev/hda'. If your hard drive is OK test should PASS! Error messages from smartd daemon will be logged in /var/log/messages if there are any (hope not)!
Futher reading: http://www.linuxjournal.com/article/6983

I assumed that you have ata drive /dev/hda as your linux hard drive. If that is not the case (if you have scsi or sata drive read article on given web address for furher info)!

rybowilson
27th October 2006, 08:47 PM
Yeah, I did that, and it just keeps giving me device I/O errors and stuff. I think it's about time to pitch this hard drive, I hate getting hung up on something so stupid. What I don't understand is how it accesses the drive perfectly but for some reason smart just isn't working. Whatever. I'll track down another HD and see if I can start over