PDA

View Full Version : Deleted FC6, Grub still there



Dead1nside
27th October 2006, 10:12 AM
I deleted FC6 as I thought it'd be easier to reinstall than to mess around. I've done this with FC5 too and I remember having the same problem. I deleted the /boot partition this time round and set my main XP one as active... there is one other partition left at the end of the drive, very small... but it's empty and hidden. So I don't know what I'm doing wrong.

Would appreciate the pointer to the probably obvious solution.

Thanks. :)

Sheph
27th October 2006, 11:53 AM
If you want to have the windows booter installed you have to insert your windows CD, boot this.. from here you have to get to the changes menu or something, cant really remember (think its the option called "fix windows xp").. Well you at some point reach a black screen much like a terminal.. :) Here you type help to find commands after loggin in.. The command you're looking for is called something like "fix-mbr" (masterboot record) which totally reinstalls the bootsector with windows' booter.. :) hope it helps though alittle vauge..

sn68
27th October 2006, 11:56 AM
Boot with XP install cd
Choose repair option, this will lead to command prompt
at command prompt type
>fdisk /mbr

press enter and reboot

Dead1nside
27th October 2006, 03:14 PM
My laptop only has recovery cds and it wasn't immediately obvious to me how to get to a recovery console. And fdisk /mbr wasn't on the Windows XP Home install cd that I used instead but fixboot and fixmbr were. So I went for fixboot, and it still comes up with grub.

sn68
27th October 2006, 03:36 PM
grub is installed in mbr portion of disk, so deleting /boot directory will have no effect.
Basically the OS looks in a fixed place ie mbr for initial boot directions, these boot directions, so to say, will subsequently lead to /boot directory. So by deleting the /boot directory initial bootloader is not affected but on not finding /boot, it will hang.

sn68
27th October 2006, 03:41 PM
Try fixmbr

Dead1nside
27th October 2006, 04:06 PM
Bit scared to try that one, I did try it but it came with a warning and asked me if I'm sure.

sn68
27th October 2006, 04:24 PM
can't get worse than this, can it?
No one can give an absolute gaurentee, but it should work
Best of luck..

Dead1nside
28th October 2006, 02:57 AM
I just reinstalled FC6 instead *smiles*