View Full Version : can't dual boot

27th October 2006, 08:08 AM
So. Fedora Core 6 works great that I can tell!

But I can't access windows. (Shoot. Which may, in the end, be my own fault. Oops.) First, yesterday was pretty much the first time ever I've worked with Linux, so please be patient with me. I did search for other threads, and I tried Firewing's solution listed in the "Howto" section:

I was using the mapping function, as makeactive was always hanging the system.

I ran through hd0 with the following results
1 no response; it just hangs.
2 - 13: invalid or unsupported executable format
3 - 13
4 - disk read error. (reproduced multiple times.)
5 - 13
6 - 13
7 - 13
8 - 13
9 -13

trying anything with HD1 came back as 21 - selected disk does not exist.

in my search for answers, I did find the fdisk function:
Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 14 112423+ 83 Linux
/dev/hda2 15 9728 78027705 f W95 Ext'd (LBA)
/dev/hda5 15 7663 61440561 7 HPFS/NTFS
/dev/hda6 7664 7728 522081 82 Linux swap / Solaris
/dev/hda7 7729 9728 16064968+ 83 Linux
[root@localhost ~]#

-- hda5 is the windows partition; but I think *I* may have caused a problem because of limited knowledge. I was doing research as I had trouble installing an earlier version of Fedora Core, and received an error when I tried to create a boot sector. From what I gather, it has to do with my hard drive being to large and bios not being able to read over a certain number of cylinders. So the faq said create a small partition first, then create the windows partition, then free space. (I was able to create the partition swhen I was reinstalling windows.)

No problem, right? well. the first partition (which was taken over as the boot sector when I installed Fedora Core) was listed as C:/. the Windows was under D:/. I *really* need Windows to work: Fedora core was for fun. When I try and boot from CD and have the (windows) Operating System CD in the drive, the screen just goes blank.

Yeah. I'm kind of an idiot? But any help getting windows functioning again would be absolutely great. I'd really like to have Fedora too so I can play around, and I'm willing to uninstall and re-install as necessary. I will run *any* command line that you need, even.

I tried looking at other threads, but they either didn't apply or I couldn't understand them.

Thank you for your time.

the stats:
Compaq Presario x6000
Pentium 4 chip, 3 GHz
ATI Mobility Radeon X600 with 256 MB RAM
80 GB HD
and...uh...I can get anything else you need if you tell me where to look?