PDA

View Full Version : ntfs-3g with FC6 x86_64



McLite
27th October 2006, 04:44 AM
Running FC6 x86_64.

Having a spot of trouble with ntfs-3g, got it and fuse installed. If I try to mount the filesystem after I've logged in, from GNOME, it works just fine. But fstab is another story...

When I put them in fstab, I get the following errors when it tried to mount at startup:

failed to create /dev/fuse: file exists
fusermount: failed to open /dev/fuse
failed to exec fusermount: permission denied

What in blazes is happening here? Also, when I do a manual mount after logging in from GNOME, when I reboot, I get screenfulls of errors:

transport endpoint is not connected
block devices not permitted on fs

Any help would be appreciated. :)

ilbh
27th October 2006, 08:59 PM
it happens to me too...

and im using i386 cpu, p4

ilbh
29th October 2006, 09:42 AM
after many googling i found that:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211767

wich means that you must change your selinux policy to permissive.
goes to /etc/selinux and edit the config file,
changing where is enforcing to permissive

it worked for me, now i can mount on startup

McLite
30th October 2006, 05:59 AM
Yup, I found that too. :) Annoying bug, glad there's a quick workaround for now.


audit2allow -M local < /var/log/messages
Also worked for me, letting me keep SELinux in Restrictive Mode.

This should help other Fedora Core users having the same problem when using ntfs-3g (not that it's an ntfs-3g bug, the problem clearly likes with Fedora/SELinux).

richjoh
23rd November 2006, 06:17 PM
McLite,

I installed semodule required for the command above. After setting SELinux to Enforce and issueing the command I get what below and now ntfs does not mount (pernission denied). vfat does mount. I have to set SELinux back to Permission for now.

[root@localhost richjoh]# whereis semodule
semodule: /usr/sbin/semodule /usr/share/man/man8/semodule.8.gz
[root@localhost richjoh]# /usr/sbin/semodule -i local.pp
libsepol.check_assertion_helper: assertion on line 0 violated by allow system_mail_t fixed_disk_device_t:blk_file { read };
libsepol.check_assertions: 1 assertion violations occured
libsemanage.semanage_expand_sandbox: Expand module failed

ilbh
24th November 2006, 05:36 AM
i think its related to the kernel you are using. it happened to me when i tryid with different kernels.
before it was working, but now its not working w me.

ilbh
24th November 2006, 05:41 AM
now its xen kernel. it wasnt that before

Eric Buist
26th November 2006, 07:47 PM
I had the same problem with FC6 x86_64 and I reverted to the read-only kmod-ntfs. Setting SELinux in Permissive mode gets it almost useless; rather put it in Disabled mode.