PDA

View Full Version : FooBillard Broke



glenngds2006
27th October 2006, 12:19 AM
I am a little mad. I just discovered that one of my favorite games no longer works. I just recently upgraded to Fedora Core 6. I have tried running it from gnome and from a terminal. In a terminal a new prompt line appears just as if I had typed nothing and hit enter. From the games menu if I click FooBillard, I can just make out that the entire monitor flashes and then nothing.

glenngds2006
27th October 2006, 12:49 AM
I just discovered that Konqueror does the exact same thing as FooBillard. Thank God Firefox works just fine or I would be stuck with no internet. I just had a thought, maybe I should try every program on my system just to find out what no longer works.

u-noneinc-s
27th October 2006, 01:03 AM
I am monitoring the progress of fc6 for a week or 2 before I install, so I am curious. Was this a yum upgrade a CD/DVD upgrade or a fresh install (which many people seem to refer to as an upgrade)?
I'd also be interested in anything else you find that doesn't work.
Thanks

glenngds2006
27th October 2006, 01:54 AM
usage: foobillard [--option [<arg>]]
options:
--player1 <arg>
arg=ai|human set player1 ai/human
--player2 <arg>
arg=ai|human set player2 ai/human
--p1 <arg>
arg=ai|human set player1 ai/human
--p2 <arg>
arg=ai|human set player2 ai/human
--name1 <arg>
set name of player1
--name2 <arg>
set name of player2
--8ball
8ball pool game
--9ball
9ball pool game
--carambol
carambol billard game
--snooker
snooker billard game
--tablecolor <arg>
table color in C-style hex notation <0xrrggbb>
--edgecolor <arg>
edge color in C-style hex notation <0xrrggbb>
--framecolor <arg>
frame color in C-style hex notation <0xrrggbb>
--chromeblue
blue table with chrome edges
--goldgreen
green table with gold edges
--goldred
red table with gold edges
--blackwhite
balck table with white frame
--blackbeige
beige table with balck metal
--tablesize <arg>
table size (length) in foot (default=7.0)
--lensflare
turn on lensfare
--nolensflare
turn off lensfare
--poslight
use positional light
--dirlight
use directional light
--ai1err <arg>
to err is artificial (player1 error 0..1)
--ai2err <arg>
to err is artificial (player2 error 0..1)
--balldetail <arg>
set ball detail l[ow] m[edium] h[igh] or v[eryhigh]
--rgstereo
start in stereo mode (red-green(cyan))
--rgaim <arg>
arg=left|right|middle for aiming eye position
--hostaddr <arg>
arg=IP-address for TCP/IP connection
--portnum <arg>
arg=port# for TCP/IP connection
--geometry <arg>
<width>x<height> window geometry
--fullscreen
play in fullscreen mode
--freemove <arg>
arg=on|off free move in external view mode
--cuberef <arg>
arg=on|off rendered cubemep reflections
--cuberes <arg>
arg=<texture size for cuberef> (must be power of 2)
--bumpref <arg>
arg=on|off bumpmap reflections of edges
--bumpwood <arg>
arg=on|off bumpmap of wood covers
--balltraces <arg>
arg=on|off trace lines of balls
--gamemode <arg>
arg=match|training|tournament
--fresnel <arg>
arg=on|off fresnel ball reflections
--avatar <arg>
arg=on|off enable/disable avatar
--tourfast <arg>
arg=1.0..10.0 AI fast motion ratio for tournament
--clothtex <arg>
arg=on|off for table detail map
--help
this help
the color <0xrrggbb> means one byte for each red, green, blue

libGL warning: 3D driver claims to not support visual 0x4b
player_copy1
player_copy2
player_copy3
human player 1
player_copy3.5
player_copy4
player_copy1
player_copy2
player_copy3
human player 2
player_copy3.5
player_copy4
FT_Load_Glyph:error#6
Well FooBillard did something and this is the result of running it in a terminal the third or fourth time

Anyway I did a full install--by that I mean I formatted the hard drive and installed from the DVD.

meverhagen
27th October 2006, 07:28 AM
I got the same error with foobillard and I did an upgrade.
I found more recent posts on other forums with a simular problem. So I suspect the video driver.

After installing the nvidia-x11-drv the 'libGL warning: 3D driver claims to not support visual 0x4b' message disappears.

I hope foobillard wil word again when I restart my pc.

The last line with the glyph has got something to do with the freetype fonts. And foobillard stops after that line.

meverhagen
27th October 2006, 05:29 PM
The last line has got to do with the freetype2.

http://bugs.archlinux.org/task/4711

Somehow downgrading freetype to freetype2-2.1.10 will fix this.

Download the four freetype rpms from: (foobillard worked in fc5 ...) to the same dir http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/Fedora/RPMS/

su
rpm -Uhv freetype*.rpm --force
/sbin/ldconfig


(and the freshmeat lvidia rpm's don't work...try http://forums.fedoraforum.org/forum/showthread.php?t=99285&highlight=nvidia)

Archw
28th October 2006, 03:40 AM
Neither Konqueror nor FooBillard works here (new install of FC6).

meverhagen
29th October 2006, 07:01 AM
Konqueror runs perfect on my fc6 box, it starts almost immediately.

Foobillard runs with after downgrading freetype. It seems that the freetype bug is already fixed in freetype cvs, so I expect an update for freetype very soon.
However I experience a flaw with foobillard, the collored balls turn white after potting them. I think this will be fixed with updates.

meverhagen
29th October 2006, 07:57 AM
Restoring the old xorg.conf from before the nvidia install brings back the colors. The nivia driver didn't load correctly when I rebooted, so the glx was lost !
It think the glx message of foobillard is simply a warning an can be ignored.

glenngds2006
8th December 2006, 11:49 PM
if anyone is curious. After six weeks of updates to my system, foobillard now works better than it ever did with fedora core 4 or 5. I can actually see the billard balls moving after I hit them.

meverhagen
9th December 2006, 02:08 AM
To play 3d games you need a 3d card with at least 32 mb memory.

It is a good idea to check if the graphics card is linux compatible, more and more of the manufacturers of the video cards are actuallly shipping linux drivers with their newest cards.

glenngds2006
9th December 2006, 06:52 PM
Actually that is no problem with my video card, because it is a ATI Radeon 9660 with 256MB of ram onboard. My video card is about a year and a half old. I guess that somebody somewhere has produced a linux video driver that is appropriate for my video card. I didn't do anything but update my computer a few times with PUP.

meverhagen
9th December 2006, 07:04 PM
The best drivers for the new radion cards are at http://ati.amd.com/support/drivers/linux/linux-radeon.html

I am not sure if these are already integrated in fc6