PDA

View Full Version : Installing Fedora in Microsoft Virtual Machine



turboenvy
14th April 2004, 01:38 AM
I am running:
pentium 4 1.5 MHz
512 ram
10 gig hard drive
win XP pro

I am trying to install fedora in virtual machine. When anaconda reboots, I get the grub boot loader, and then when it trys to load fedora I get a file not found error. Sorry I don't have the exact error message, I'll have to write it down sometime but thats the jist of it. As far as I can tell, it should be working. I gave the virtual machine 256 of ram and almost 4 gig of hard disk space. Any thoughts on why it's not working?

kbradl1
14th April 2004, 02:59 PM
I hate to say it but Fedora may not work in Microsoft's Virtual Server product. I know Microsoft won't support it. You really should have expected that.

Get back to us with what file it can't find and what your /boot/grub.conf looks like.
I recommend you just partition your drive and then dual boot instead of trying the Virtual Machine route. VMs can cause alot of issues. VMWare is better too.

turboenvy
14th April 2004, 05:14 PM
I actually got virtual machine for free, so thats why I'm using it. But back to the problem, this is what the screen says when it stops loading:
_____________________________
Booting 'Fedora Core (2.4.22-1.2115.nptl)'

root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.4.22-1.2115.nptl ro root=/dev/hda2 rhgb

Error 15: File not found

Press any key to continue...

___________________________
I'm brand new to linux and I don't know what any of it means except for the 'file not found' part. Mabey someone could recomend a free resource for learning linux. I did find a web page of someone who succesfully installed Fedora on microsoft virtual machine so I'll email him about how he did it. If anyone has any ideas though about why mine isn't working, I'd love to hear them. :-)

turboenvy
27th April 2004, 07:24 PM
Well, I tried installing Fedora on a spare 4 gig hard drive I have and I got the same error message while trying to reboot. Could the .iso's I downloaded be corrupted somehow? I did test them with the install program and they checked out. Another interesting problem is this: the install program reports an error while trying to write to the floppy. I've tried different floppy disks with none of them working. Mabey these two problems are related somehow? Anyways, advice please!!

GLG
4th February 2005, 09:51 AM
You've to use a special kernel for running core3 on a MVMS...
Try this site:
http://vpc.visualwin.com/
It helps me a lot...

yur1022
4th February 2005, 05:30 PM
There is a step-by-step instruction on installing FC3 under MS Virtual PC:

http://vpc.visualwin.com/Notes/FedoraCore.3.Final.html

I have not tested, but it seems quite convincing.

yur

pparks1
4th February 2005, 08:27 PM
If you following the guide on vpc.visualwin.com you will be just fine.

I used to be a user of VMWare, but honestly Microsoft Virtual PC 2004 is working just as well for me. I've had no major problems aside from what is covered on the vpc.visualwin.com website.