PDA

View Full Version : fedeora core 6 and ati (not)



leigh123linux
26th October 2006, 07:58 AM
hi have tried livna ati drivers (dont work no dri) , also have tried ati s binary driver ( no luck there? error can't find /etc/profile.d/qt.sh ) .I would have preferred waiting another month for fedora 6 ( buggy crap) so they could get it right ( it is not a race with ubuntu to see who can release first) any clues. LEIGH

brahms
26th October 2006, 10:18 AM
hi have tried livna ati drivers (dont work no dri) , also have tried ati s binary driver ( no luck there? error can't find /etc/profile.d/qt.sh ) .I would have preferred waiting another month for fedora 6 ( buggy crap) so they could get it right ( it is not a race with ubuntu to see who can release first) any clues. LEIGH

Perhaps you should not be using fedora. It would seem to be the ATI drivers in this instance that are the "buggy crap". Fedora[1] is about FOSS[2] which the ATI drivers are definitely not.

By all means use these forums to ask for help and advice, but don't come here and slag off Fedora for failing to do something for which it was not designed.

[1] http://fedoraproject.org/wiki/Overview
[2] http://en.wikipedia.org/wiki/Free/Libre/Open-Source_Software

leigh123linux
26th October 2006, 10:39 AM
i belive my problem is due to missing qt.sh and thats a fedora bug . this is not the only problem i have had with FC6 x86_64 .I have none of these problems with FC5 x86_64 so put down to FC6 (buggy crap) . I know this status will change over the next few weeks.

p.s look at the countless other bugs and problems other people are having with FC6

who are you to say what i should use . i have used linux for years , debian and fedora are my favorites with a leaning towards fedora. leigh

kaconst
26th October 2006, 10:44 AM
Read this: http://www.phoronix.com/redblog/?p=blog&i=NTAwMA

Then run the installer with --buildpkg Fedora/FC6, and install all of the RPMs.

You have to do this because the ati drivers do not support FC6 yet, the next release of the drivers should work fine. Until then, use the patch above.

brahms
26th October 2006, 12:43 PM
i belive my problem is due to missing qt.sh and thats a fedora bug .

$ yum provides qt.sh
qt-devel.i386 1:3.3.7-0.1.fc5 updates
Matched from:
/etc/profile.d/qt.sh
Of course this is on FC5.i386, but there are no bugs filed qt that suggest this is not the case for FC6 also. If, of course, that file is missing in the FC6.x86_64 version of qt-devel, then you should file a bug. FC6 qt bugs (https://bugzilla.redhat.com/bugzilla/buglist.cgi?product=Fedora+Core&version=fc6&component=qt&bug_status=NEW&bug_status=VERIFIED&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=CLOSED&bug_status=NEEDINFO&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=UNCONFIRMED&bug_status=ON_QA&bug_status=FAILS_QA&bug_status=NEEDINFO_REPORTER&bug_status=RELEASE_PENDING&bug_status=POST&short_desc_type=allwordssubstr&short_desc=&long_desc_type=allwordssubstr&long_desc=)

this is not the only problem i have had with FC6 x86_64
Perhaps not, but it is the one we are discussing here.

.I have none of these problems with FC5 x86_64 so put down to FC6 (buggy crap) . I know this status will change over the next few weeks.
Or you could put it down to ATI's binary driver.

who are you to say what i should use . i have used linux for years , debian and fedora are my favorites with a leaning towards fedora. leigh
I was merely suggesting that it is ridiculous to criticise Fedora for this particular problem. Just wondering why you installed FC6 on release day if you really would have preferred waiting until the bugs were ironed out, as you accept they will be over the next few weeks.

leigh123linux
27th October 2006, 02:52 PM
hi have sorted ati driver (installed livna ati ) problem was with aiglx being enable by default .so i disabled composite in xorg.conf . never got ati binary driver to build ( think it was a bug in ati 64 bit driver installer ).

I take back what i said about FC6 being buggy ( its hardware detection is second to none with my Rig ) Its quite stable for such a new release.

leigh

ALiAs
28th October 2006, 05:08 PM
Leigh, would it be possible for you to post your working xorg.conf as mine seems not to want to work no matter what path i take, quite frustrating at the momment.. (i386-686 Ati-x800Pro)

leigh123linux
28th October 2006, 05:29 PM
heres my xorg.conf

Firewing1
28th October 2006, 05:46 PM
Fixing the no DRI with Livna drivers is a common problem in FC6 - You'll find it will also occur with your manually built pacakges - It's because of the Composite extension in the Xorg server. Please see the end of my ATi howto for the exact xorg.conf code, but once that's added it should be sorted out.
Firewing1