PDA

View Full Version : having troubl e installing via YUM



BoyWonder410
26th October 2006, 06:14 AM
Ok, trying to install ndiswrapper, and it keeps trying to install a version of the kernel that I already have. I don't know how to get past this, any help would be appreciated.

[root@localhost kasey]# yum install kmod-ndiswrapper
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kmod-ndiswrapper.i686 0:1.25-1.2.6.18_1.2798.fc6 set to be installed
--> Running transaction check
--> Processing Dependency: ndiswrapper-kmod-common >= 1.25 for package: kmod-ndiswrapper
--> Processing Dependency: kernel-i686 = 2.6.18-1.2798.fc6 for package: kmod-ndiswrapper
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.18-1.2798.fc6 set to be installed
---> Package ndiswrapper.i386 0:1.25-1.lvn6 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
kmod-ndiswrapper i686 1.25-1.2.6.18_1.2798.fc6 livna 92 k
Installing for dependencies:
kernel i686 2.6.18-1.2798.fc6 core 16 M
ndiswrapper i386 1.25-1.lvn6 livna 29 k

Transaction Summary
================================================== ===========================
Install 3 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 16 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error: package kernel-2.6.18-1.2798.fc6 is already installed
file /boot/System.map-2.6.18-1.2798.fc6 from install of kernel-2.6.18-1.2798.fc6 conflicts with file from package kernel-2.6.18-1.2798.fc6
file /boot/config-2.6.18-1.2798.fc6 from install of kernel-2.6.18-1.2798.fc6 conflicts with file from package kernel-2.6.18-1.2798.fc6
file /boot/symvers-2.6.18-1.2798.fc6.gz from install of kernel-2.6.18-1.2798.fc6 conflicts with file from package kernel-2.6.18-1.2798.fc6
file /boot/vmlinuz-2.6.18-1.2798.fc6 from install of kernel-2.6.18-1.2798.fc6 conflicts with file from package kernel-2.6.18-1.2798.fc6

markkuk
26th October 2006, 09:10 AM
Perhaps you have been hit by the bug (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211941) that causes an i586 kernel getting instead of the i686 one? What does "yum list installed kernel*" show?