PDA

View Full Version : X non-resposnive, but not frozen



clearer
26th October 2006, 02:28 AM
I'm not quite sure if it's metacity or X that's the problem -- my money is on X though.

X seems to lock mouse input and keyboard input as well from time to time. it's not that they stop working completly, but the keyboard will ussually only work if a window already has focus and clicks with the mouse doesn't seem to register. This problem was also present in FC5, though not as heavily, and only on x86_64 -- just like FC6. I never had this problem with FC5 i386 (which was also why I ued that instead of x86_64 -- back in those days :p ).

I am determined to use the x86_64 version of FC6, since I am getting sick and tired of not being able to use my CPU the way it was ment to be used -- screw it if there are a few extra bugs... that's just part of the ride :).

I was wondering if someone has had the problem in FC5/6 and know how to fix it.

clearer
26th October 2006, 02:30 AM
BTW, these locks usually have a limited life. They usually disappear with a few seconds, and then reappear in a flash again (enough to make you angry, but not enough to let it work). It has been working almost perfectly for a couple of hours now, with only one lock, that went away rather quickly.

mkobetic
27th October 2006, 01:42 AM
I've had similiar problems trying to get any Linux going on my new Dell Latitude D820. I suspect the issue is the Dual Core rather than 64-bit, because I've been running 64-bit FC5 on my single core desktop (Athlon 64) and never had any issues of this type. With the Laptop I tried the latest Ubuntu, FC5 and finally FC6 and all were showing the same problem with X locking up. Sometimes it was just that it stopped responding to mouse clicks (often with cursor stuck with some temporary pointer, like the resizing one or so), but I could still Alt-Tab between the windows and work that way. However sometimes it froze hard and I couldn't even get out into the text consoles with Ctrl-Alt-F1. But I could still ssh in and sometimes I could get the X back by killing metacity or gnome-panel (just kill not kill -9).

Finally I decided that I'm going to try something else than metacity and installed and switched to XFCE and it's been running without any hicups for past 5 or so hours. Before, the freezing would happen in matter of minutes, sometimes seconds. So I finally have something I can use reasonably. I have still to work out some issues, like getting a bluetooth mouse and keyboard combo going, but that's just icing on the cake.

One semi-annoying issue that I've still seen even with XFCE is that sometimes my keystrokes get multiplied, instead of getting single character I get three or four. But that's not terribly often and I can live with that for now. But again I suspect some dual-core related issues here.

HTH,

Martin

Berdman
27th October 2006, 02:39 AM
I am also having the same issue wth 64-bit. I just got a Dell Latitude D820 with a Core 2 Duo T7600 processor. X freezes constantly, easily within a minute of doing anything. I can only work in a terminal session if the focus is set to it. All other mouse clicks are not accepted. I have to perform the ctrl-alt-bksp to reload X. This happens on both FC5 and FC6.

I started with FC5. I then loaded FC6, choosing the Virtualizations (xen kernel). I did not have this issue with the xen kernel, however, when I put FC6 x86_64 without the xen kernel, it continues to happen.

Any ideas on this?

mkobetic
27th October 2006, 04:50 AM
I've had the same problems even with the xen kernel. The only thing that seems to be working so far is avoiding the metacity setup. I'm not sure it's actually problem with metacity but whatever is included in that setup is causing problem. The XFCE setups still works fine for me.

spartas
27th October 2006, 06:08 AM
Same locking issues here as well. I have one of the newer intel P965 chipsets (Core 2 Duo 6400 proc) and this is the first OS I was able to install using the IDE CDRom (a different issue). However, I am running x64 with the xen kernel as well and I am experiencing locking issues.

clearer
27th October 2006, 10:42 AM
It may be the combination of dual core and x86_64 -- when I run dual core with a i386 installation there are no prroblems.

I think the problem is thatt input often generates too many interrupts. At any rate, my keyboard generates too many hits when I hit a key, resulting in double, tribble or no letters at all. My mouse also jumps around some times.

It was a pain to write this message just somewhat correct.

Berdman
27th October 2006, 04:42 PM
Put the Xen kernel bak on, and have had no freezes since. Laptop seems much more responsive as will. I will have to leave this kernel on since FC6 is unusable with the normal x86_64 kernel.

clearer
29th October 2006, 04:49 PM
So, the Xen kernel fixes the problem? WIll try this solution right away.

clearer
29th October 2006, 05:33 PM
Ok, so the Xen solution did not work for me. The nVidia drivers did not load right resulting in no X being functional -- ofcourse I could just use the open source drivers, but with no hardware acceleration in those, it's not really an option. *sigh*. I'll try to compile a kernel on my own and see if I can get things working using that.

clearer
29th October 2006, 07:56 PM
kernel building...

clearer
30th October 2006, 10:54 PM
I believe I have a solution to the problem -- I am building a new kernel to check if it is a solution or not (baseing it on the old config from erd hats kernel).

It appears that having the hyperthreading scheduler and the multicore scheduler enabled at the same tiime causes problems. I should be able to verify if this infact is the problem in about 1 hour, when the new kernel is ready and installed and I have had a chance to test it..

I still seem to have problems with dual hits from the keyboard though.

clearer
30th October 2006, 11:55 PM
hmm... disabling the hyperthreading scheduler certainly does help a lot -- I am able to click on anything without problems, which I wasn't with the red hat supplied kernel. It also takes a lot longer before I get my input locked in any way, and so far it has only been the keyboard.

I am going to check what happens if I disable the multicore scheduler as well -- it will properbly break something, but better safe than sorry.

clearer
31st October 2006, 08:26 AM
It appears to work even better now. For people interested in trying this, I did do a few other things than just remove the scheduler -- I also removed NUMA support (completely) and increased the clock frequency to 1000Hz, changed the preemption model to "Voluntary kernel preemption", removed the support for AMD MCE features, changed the memory model to flat, and changed the type to EM64T (since it's an intel -- this should not, stressing should, make any difference execpt for perhaps size or speed).

Everything appears to be working the way it should now -- but i might just be lucky. I'll return in a couple of days with a report.

clearer
1st November 2006, 07:25 AM
It helped, but didn't solve the problem entirely.
XFce AND KDE works fine -- no problems when they are running. This makes me think that it might be things like nautilus or metacity that's the problem.

trevor_larock
4th November 2006, 02:05 AM
I see this also, especially key repeats. Seems guarantee freeze if I plug in wired ethernet while booting.

DIsabling 2 cpu in BIOS seems to help but not the best sol'n.

Anybody seen other threads on the topic?

dyqith
6th November 2006, 07:44 AM
Maybe the problem is related to this:

http://doc.gwos.org/index.php/Double_Clock_Speed

I haven't tried it myself, but had been using "clock=pmtmr notsc" which worked fine for me.

If someone tries the 64 bit no_timer_check solution, let us know the outcome.

MitchLoft
9th November 2006, 11:46 PM
OK - I am intermittantly having a somewhat similar problem. At odd intervals, my keyboard seems to disappear from the system. Meaning, I can use the mouse, clicks work, can change sessions, etc, - however the keyboard is non-responsive - I can type away, but nothing shows up on screen on any sessions I happen to have open. Tapping the num-lock causes the LED to go on/off so I'm sure it's plugged in OK. I am running an AMD64 X 2 on an MSI Motherboard - 2GB of DDR2 RAM - SCSI Raid - NVidea chipset which I have downloaded and installed the livna drivers for and they installed and appear to be working OK. FC6 with all updates installed and using KDE 3.5. If I restart the Xserver using <CTRL><ALT><BKSP> it resets and works OK again for a time. The glxgears program DOES run and is reporting about 1118 FPS. I -thought- I saw a mention of this problem somewhere on this site, but I'm damn if I can find it again. On MY wishlist, a better full text search algorithm for this site. {;>p)=

bthornton
11th November 2006, 07:25 PM
I thought I'd chime-in on this convo because I'm having the exact same problems--however, I'm having these problems in Ubuntu Edgy-Eft (6.10). The mouse moves but won't respond to clicks until I change workspaces, the keyboard "reeegisterrrs multipppple keeeeystrokkkes" at random. I really think that clearer is on to something when he says that this is related to a combination of dual-core and 64-bit. Here are some observations from my machines:

1. On my Pentium D 945 desktop running Ubuntu 6.06.1 LTS (32-bit), I have no problems whatsoever. Both cores are being recognized and used.
2. On my Pentium D 945 desktop running Ubuntu Edgy-Eft (64-bit), I have the problems that people are reporting here--it is generally unusable by my judgement. Both cores are being recognized and used. (* This was tested using the exact same xorg.conf file from my 32-bit Ubuntu.)
3. On my Turion64 laptop running both Fedora Core 6 (64-bit) and Ubuntu Edgy-Eft (64-bit), I have no problems whatsoever. There is only one core on this machine.

So I've tested a few different combinations and it seems that, like others here, the problems only arise on dual-core, 64-bit kernels.

For the record, the problematic machine is:

Pentium D 945 (3.4 GHz, Dual-core, EM64T)
ECS P4M800PRO-M motherboard
1 GB Kingston DDR2 (400 MHz) RAM
256 MB nVidia GeForce 6200 AGP 8x video card

Waggoneer
28th February 2007, 06:37 AM
I too am having this issue. The system will freeze when I am working, and while the mouse moves, all buttons are unresponsive.
My work around is to hit ctrl-alt-<- or ->. The workspace switches and I get response back.
I notices the repeated characters issue when I did the ctrl-alt-f2 to get to a terminal. It was hard to type in my user name.

I would love to find a work around for this. Occasionally the whole dang thing locks up too and I have to reboot. I hate that since Linux is supposed to have great uptime.

MitchLoft
28th February 2007, 04:27 PM
Just an update - there have been several updates to Xorg and the kernel since the original post. One or more of these updates appears to have addressed/solved the problem as I don't have it any longer. If you haven't, you should do a yum update to get all the updates onto your system and see if that helps.

Waggoneer
26th March 2007, 12:25 AM
nothing in FC6 updates fixed my issues.
Since then, I have upgraded to FC7 T2 and it runs like butter.

MitchLoft
26th March 2007, 02:43 PM
Sounds like a plan. I think I neglected to mention that the FC6 I have that is working well is the64 bit -xen version, NOT the standard 64 bit version.

JonC
26th March 2007, 03:08 PM
not that it is likely to help much, but after a recent ish update my swap partition was no longer being mounted - and this lead to similar problems to those you describe. Might be worth just checking your swap is still being mounted.

jsalvo
5th April 2007, 12:32 PM
Is this problemm still true today? I am running FC6 x86 on an AMD Turion64, but I would like to switch over to using FC6 x86-64.

sancho
8th April 2007, 06:10 AM
FC6 x86_64 runs like a charm on my Turion64 notebook--just not my Pentium D boxen.

jsalvo
12th April 2007, 12:38 PM
FC6 x86_64 runs like a charm on my Turion64 notebook--just not my Pentium D boxen.
Hi sancho .. I forgot to mention that I have an AMD Turion64 X2 ... dual-core and not single-core. Is this what you are running FC6 on ?

sancho
19th April 2007, 07:38 AM
nope; single core

jsalvo
19th April 2007, 09:22 PM
nope; single core

I see .... The problem that most users are having in this thread is with dual / multi-core though. Single-core CPUs are not having this problem.

sancho
20th April 2007, 06:07 PM
I see .... The problem that most users are having in this thread is with dual / multi-core though. Single-core CPUs are not having this problem.

Yeah, it's only happening on dual-core machines, but also only those running 64-bit OSes. I'm on a dual-core machine right now which is running fine, but I've been forced to run a 32-bit OS on it (Ubuntu Edgy Eft). If I run the 64-bit version Edgy, I get all the same problems you previous posters are reporting--and if I run the 64-bit version of Fedora Core 6, it won't even boot (something about being unable to find the root fs; seems unrelated, yet simply installing the 32-bit FC6 solves it).

It seems like running the most recent distros helps, however, as Waggoneer has said. I'm anxious to upgrade to Ubuntu Feisty and am curious to see how the 64-bit version would do on this machine.

sancho
1st May 2007, 03:34 AM
Just thought I'd add to this once more:

I just installed Ubuntu Feisty (x86_64) on this same Pentium D system, and the results were similar. In general, X was unusable. At first, I could move the mouse but not click it. I tried rebooting but then X wouldn't even start (it just crashed at a black screen when X tried to start). I did try doing some things in a terminal and didn't seem to have any problems there.

I want to go out on a limb and just say that Pentium D processors were not meant to run 64-bit OSes.

Only reservation I have about that is that I'm running a "cheapo" ECS motherboard that has a VIA chipset that I haven't seen anywhere else. It has the odd trait of having no PCI Express slots and one AGP slot, yet it apparently will support Core 2 Duo. Maybe it's a buggy chipset?

Either way, I've installed the 32-bit version of Feisty, and it's running smooth as silk.

spartas
1st May 2007, 04:23 AM
I've recently upgraded the firmware on my motherbord, however, the issues are still prevalent on my system. I've switched away from the xen kernel, as it was nearly unusable for me. I still get X hangs every so often though.

Output from dmesg:


hda: cdrom_pc_intr: The drive appears confused (ireason = 0x01). Trying to recover by ending request.


I'm currently running the 2944 x86_64 kernel with an IDE cdrom drive on the IDE channel.