PDA

View Full Version : "Desktop effects could not be be enabled" umm What??



rayyes
25th October 2006, 11:42 PM
Hi there
Just got FC6 running. Using the nvidia drivers from livna with no problem.
I decided to try out the 'out-of-the-box' desktop effects from the System > Perferences menu, but I got the most unhelpful error message I have ever encoutered.
Basically i clicked 'enable desktop effects' and after a few seconds a window popped up that says 'Desktop effects could not be be enabled' ... :confused:
thats nice and all, but for the love of God....*WHY* could they not be enabled??
sorry if this has been asked before, but i found nothing on google / this forum. and the error message...well you know

glennzo
25th October 2006, 11:51 PM
I have the same problem. Run desktop-effects from a command window and you will see output that may be helpful. BTW, mine still doesn't work.

Janl
25th October 2006, 11:53 PM
I was having the same problem (as well as not getting DRI working among a few other issues) due to the installer having installed the i586 kernel on my system instead of the i686 kernel. After correcting that problem (removing i586 kernel and replacing with the i686 version) all is working now.

rayyes
25th October 2006, 11:54 PM
hi glennzo...
ya i ran it from the command line, and the output was :

gnome-window-decorator: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.
compiz: No sync extension
Xlib: extension "SHAPE" missing on display ":0.0".
Xlib: extension "SHAPE" missing on display ":0.0".
Xlib: extension "SHAPE" missing on display ":0.0".
Xlib: extension "SHAPE" missing on display ":0.0".
Xlib: extension "SHAPE" missing on display ":0.0".
Xlib: extension "SHAPE" missing on display ":0.0".
Xlib: extension "SHAPE" missing on display ":0.0".
Xlib: extension "SHAPE" missing on display ":0.0".

then i looked for this error and found a post suggesting to add some lines into xorg.conf:

Section "Extensions"
Option "Composite"
EndSection

AND under the device section:
Option "AddARGBGLXVisuals" "True"

I did that, but its still giving the same error..??

rayyes
25th October 2006, 11:55 PM
thanks for the tip Janl i'll give it a shot

edit: i already have the i686 kernel :confused:

07dcolem
25th October 2006, 11:56 PM
If you've been reading around lately, the beta nvidia drivers will support AIGLX however I am waiting until the drivers are out of beta and livna releases them. That means no support as of yet.

rayyes
26th October 2006, 12:00 AM
07dcolem i hear you man, but there are people (such as Janl) who have gotten it to work, so there must be a fix

07dcolem
26th October 2006, 12:02 AM
I went to the livna website and they have the beta drivers in their testing repo for those that are interested!

07dcolem
26th October 2006, 12:04 AM
One question, If I install drivers from the testing repo, how will yum know to not update from the testing repo again then the current beta drivers become stable. I guess what I'm asking is if I install the stable repos and then install testing packages, what repo will yum look for updates in?

tronic
26th October 2006, 12:06 AM
try adding this to your device section


Option "RenderAccel" "true"

Janl
26th October 2006, 12:09 AM
Actually I have an ATI card. Somehow missed the part about you using the Nvidia drivers. Sorry about that.

KClaisse
26th October 2006, 12:30 AM
Same thing with mplayer. I seems this xshapes extension is highly used.

rayyes
31st October 2006, 12:35 AM
There seems to be a "solution" for this problem.
I tried it and it didnt work for me, so I will post it here maybe someone else can get it to work?

http://scribez.wordpress.com/2006/10/29/how-to-enable-compiz-effects-on-fedora-core-6-with-an-nvidia-card/
here is the proposed solution (from link above):
1. Enable livna-testing repo.
2. Go to the update view in Yum Extender
3. Select kmod-nvidia and the xorg-x11-drv packages which are 1.0-9626. Update your drivers people!! and Boom!! After a reboot - thou shall be able to enable Desktop Effects. Enjoy rotating the cube and all sortsa window wobbly effects.

mapalma
31st October 2006, 12:48 AM
Try this:


1. Get nvidia beta driver install:
yum install kmod-nvidia --enablerepo=livna-testing

2. Get Xorg.conf ready:
gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true

Add the following in /etc/X11/xorg.conf:

Section "Extensions"
Option "Composite"
EndSection

In the "Device" section, add:
Option "AddARGBGLXVisuals" "True"

In the "Module" section, add:
Load "extmod"

3. Logout, login again and type: desktop-effects

Enable the effects. :)

rayyes
31st October 2006, 02:59 AM
@mapalma

DUDE! it works! thanks man! :D

mspengle
1st November 2006, 10:01 PM
Try this:


1. Get nvidia beta driver install:
yum install kmod-nvidia --enablerepo=livna-testing

2. Get Xorg.conf ready:
gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true

Add the following in /etc/X11/xorg.conf:

Section "Extensions"
Option "Composite"
EndSection

In the "Device" section, add:
Option "AddARGBGLXVisuals" "True"

In the "Module" section, add:
Load "extmod"

3. Logout, login again and type: desktop-effects

Enable the effects. :)

For those of you who couldnt get the "yum install kmod-nvidia --enablerepo=livna-testing" to work, you have to enter this first:

rpm -ivh http://rpm.livna.org/livna-release-6.rpm

Hope this helps!

chuong
2nd November 2006, 05:53 AM
I don't understand step 2. how do I get xorg.conf ready?

and some of those sections such as "modules" and "extensions" are not in my /etc/X11/xorg.conf file.

This is all I have in my xorg.conf file:


# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

I've just installed the livna-testing through yum, what should I do next?

By the way, any idea how to revert back to the stable kmod-nvidia driver if all this livna-testing driver doesn't work?

Dead1nside
6th November 2006, 03:53 AM
I've got a ATI Mobility FireGL T2 128MB



[Jon@Vigor10 ~]$ desktop-effects
Xlib: extension "GLX" missing on display ":0.0".
compiz: Root visual is not a GL visual
compiz: Failed to manage screen: 0
compiz: No managable screens found on display :0.0


My /etc/X11/xorg.conf looks like this:



# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite"
EndSection

Section "Module"
Load "extmod"
Load "dri"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection



Anybody got any ideas, it worked before my reinstall.

louspag
7th November 2006, 02:17 PM
I must of been one of the lucky ones. I just installed fc6 on an old laptop with an ATI video card. The install went well, no issues to speak of and I was able to enable the desktop effects as well but I had to lower my resolution to 800x600. I guess my video card didn't have enough memory for the 1024x768 resolution with desktop effects. It does work just fine at 1024x768 with desktop effects though.

rlozano
8th November 2006, 09:11 AM
i have the same problem as well enbling the desktop-effects. im getting the error GLBXConfig missing from the command line, and i can't seem to find a link that will point me to correct this error.

is there anyone out there that have an idea how to resolve this? i have resolved some earlier problems and it was actually reduced to that last error.... :confused:

here's what i have is my xorg.conf and btw, my ibm notebook is using a radeon X200 video card and im not running fglrx, i just want to make use of the aiglx..


Section "Module"
Load "extmod"
Load "dri"
Load "glx"
EndSection

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1024x768"
### Comment all HorizSync and VertSync values to use DDC:
# HorizSync 31.5 - 48.5
# VertRefresh 40.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
#Option "AddARGBGLXVisuals" "True" ---> For Nvidia
Option "DRI" "true"
Option "ColorTiling" "on"
Option "EnablePageFlip" "true"
Option "AccelMethod" "EXA"
Option "XAANoOffscreenPixmaps"
Option "RenderAccel" "true"
Option "AGPMode" "2" # <- x may be 2 or 4 depending on your system
Option "AGPFastWrite" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

dustman
16th February 2007, 11:25 PM
Hello....I have the same problem with enabling the desktop effects : "Desktop effects could not be be enabled". The thing is that I have a laptop with ATI RADEON XPRESS 200M graphics card ( cause I saw here the solving for nVidia graphics card) :( ... How can I get them started with ATI?

dustman
16th February 2007, 11:29 PM
oh,btw......when I try to run the command "desktop-effects" from the terminal, I get the following errors:

[dustman@localhost ~]$ desktop-effects
compiz: No GLXFBConfig for default depth, this isn't going to work.
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0
gtk-window-decorator: Could not acquire decoration manager selection on screen 0 display ":0.0"


:confused: :confused: wtf? I'm at the end of my wits :|

fedora_frank
6th May 2007, 09:50 PM
i am new to linux, i just set up a dual boot machiene with linux and windows a week ago and I got same problem. an even bigger problem is i doan't understand what half of the people in this forum are telling me to do. pls simplify instructions on fixing problem. i am using a ATI ES1000 video card and i have a proview model 900W monitor but i couldnt find that in list of monitors so i just selected model 860 and the display seems to work fine with that setting. any help on desktop effects will be helpful

dva
19th October 2007, 12:41 AM
I tried desperately to get the nv drivers to work before accepting defeat. I was beating my head on the table while I installed Nvidia's proprietary drivers and even then could not enable compiz.

Following steps 2 and 3 of Mapalma's post got it all working. Alas, there's no going back to a clean driver, but I think I'm already over it

BTW. ..This was on a T61p, or more specifically a 6460-67U



Try this:


1. Get nvidia beta driver install:
yum install kmod-nvidia --enablerepo=livna-testing

2. Get Xorg.conf ready:
gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true

Add the following in /etc/X11/xorg.conf:

Section "Extensions"
Option "Composite"
EndSection

In the "Device" section, add:
Option "AddARGBGLXVisuals" "True"

In the "Module" section, add:
Load "extmod"

3. Logout, login again and type: desktop-effects

Enable the effects.

irkannan1985
9th February 2008, 08:11 AM
There seems to be a "solution" for this problem.
I tried it and it didnt work for me, so I will post it here maybe someone else can get it to work?

http://scribez.wordpress.com/2006/10/29/how-to-enable-compiz-effects-on-fedora-core-6-with-an-nvidia-card/
here is the proposed solution (from link above):
1. Enable livna-testing repo.
2. Go to the update view in Yum Extender
3. Select kmod-nvidia and the xorg-x11-drv packages which are 1.0-9626. Update your drivers people!! and Boom!! After a reboot - thou shall be able to enable Desktop Effects. Enjoy rotating the cube and all sortsa window wobbly effects.



thank you.finally it is working.

powder21
23rd July 2008, 03:40 AM
Thanks everybody for your posts on this issue. I read 'em, but figured the drivers that could handle this should be stable by now so tried it out and it worked. Thanks again

For those of you who just got FC9 and it's July (or later), you don't need the livna test repo and you don't need to edit anything. You do need the base livna repo though, get the latest release by running...

rpm -ivh http://rpm.livna.org/livna-release-9.rpm

Once you've got livna then run...

yum install kmod-nvidia

Restart (or maybe just log-out and back in, I restarted), then enable desktop effects. All should be well.

Thanks again FedoraForum users.

Wayne
23rd July 2008, 04:24 AM
It's generally frowned upon to dig up skeletons and resuscitate them in the forum :) It makes a mess for the CMs with all the bones and other fragments to clear up....

There are plenty of how-tos for the nvidia drivers and desktop effects here:

http://www.fedoraforum.org/forum/forumdisplay.php?s=&daysprune=&f=12

Wayne

powder21
23rd July 2008, 07:27 AM
Sorry bout that :(