PDA

View Full Version : FC5 errors with HTTPD (apache)



DarkSoul1985
25th October 2006, 07:20 PM
Hi I installed httpd by doing

yum install httpd

this has worked for me on my remote text based fedorace core 5. However on my home installed fedora core 5 (with gnome/KDE graphical interface) I get this error when going to a website.


Forbidden
You don't have permission to access / on this server.


--------------------------------------------------------------------------------

Apache/2.2.2 (Fedora) Server at 192.168.1.12 Port 80

I already tried

chmod 777 /var/www/html

It did not work:(.
I used to have problems with FTP aswell (not able to write) but this was a security setting in the graphical interface. I already disabled httpd deamon security AND disabled the firewall.

Can anyone help me fix this?

kai4785
25th October 2006, 11:17 PM
Can you post your httpd.conf?

Check:
DocumentRoot "/var/www/html"

Or any directory that exists.

DarkSoul1985
26th October 2006, 06:47 PM
The directory does exist.

I uploaded the conf for you (did not make any changes to it).

http://sdkfiles.mine.nu/fedora/httpd.conf

DarkSoul1985
27th October 2006, 03:38 PM
Anyone with ideas? So the main difference is that the server is running in a Gnome environment instead of text/console only. I have no idea what to do about this:s. Even when I use realvnc to login and then fire up firefox and go to localhost I get: Forbidden.

at startup I get this error:

Starting httpd: httpd: apr_sockaddr_info_get() failed for Vigor12
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

maybe that is related?

DarkSoul1985
28th October 2006, 12:51 PM
I also have no acces though ftp:


Status: Connected with 192.168.1.12. Waiting for welcome message...
Response: 220 Welcome to test FTP service.
Command: USER phpmyadmin
Response: 331 Please specify the password.
Command: PASS ********
Response: 500 OOPS: cannot change directory:/var/www/html/phpmyadmin
Error: Unable to connect!