PDA

View Full Version : FC6 Headaches



ALiAs
25th October 2006, 05:31 PM
I've installed a fresh core 6 last night, and I am having some serious issues with yum updates and generaly installing anything, could this be the i586/i686 bug in anaconda that I currently know so little about, if I try to install kmod-ntfs from Livna this is the output:
--> Populating transaction set with selected packages. Please wait.
---> Package kmod-ntfs.i686 0:2.1.27-2.2.6.18_1.2798.fc6 set to be installed
--> Running transaction check
--> Processing Dependency: ntfs-kmod-common >= 2.1.27 for package: kmod-ntfs
--> Processing Dependency: kernel-i686 = 2.6.18-1.2798.fc6 for package: kmod-ntfs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.18-1.2798.fc6 set to be installed
--> Running transaction check
--> Processing Dependency: ntfs-kmod-common >= 2.1.27 for package: kmod-ntfs
--> Finished Dependency Resolution
Error: Missing Dependency: ntfs-kmod-common >= 2.1.27 is needed by package kmod-ntfs
What's with the re-install of my current Kernel, I smell the anaconda bug...
I'll be off doing some light reading I think.
http://rpm.livna.org/
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211941
*Sigh* Just when you think Fedora 6 is going to be a little better than the last, and also after being delayed for a week to iron out the nasties, an anaconda bug of all things jumps out and bites you on the ass, uh!, does anyone know how to get this i686 kernel in and the i586 out safely?
Any help would be much appreciated..

clearer
25th October 2006, 08:21 PM
as root


yum -y install kernel.i686
rpm -e kernel.i586

Should get the trick done.

ALiAs
26th October 2006, 01:13 PM
I tried that, it started spitting a few dependency errors at me.
To correct the issue I used this : https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211941
Comment #24 From Jason Farrell on 2006-10-25 14:26 EST [reply]

My fix was to swap out the i586 kernel for the i686 with yum, rather than rpm
directly, and it worked just fine:
1) yum remove kernel kernel-devel
2) yum install kernel.i686 kernel-devel.i686
3) yum install (the list of a dozen odd i386 kernel depencies removed in step
#1, such as "gnome-volume-manager" and "compiz")
Seems to have done the trick nicely.

timdsmith
26th October 2006, 01:59 PM
Download this...
http://mirrors.kernel.org/fedora/core/6/i386/os/Fedora/RPMS/kernel-2.6.18-1.2798.fc6.i686.rpm
Change to directory where you saved it.
su -


rpm -Uvh --nodeps kernel-2.6.18-1.2798.fc6.i686.rpmReboot. Kernel fixed.

dlm4ut
26th October 2006, 04:05 PM
To deal with the ntfs-kmod-common I had to look in another place on livna. I think it was in the development directory rather than in the testing or livna directory.

However, I just checked and it is there now. So try again.

ALiAs
26th October 2006, 05:05 PM
I downloaded the ntfs-kmod-common from some dev repo out there, can't quite remember which one though, it's been a long day, after the i586/686 kernel was bannished and the right one thrown in, it's all systems go for now..
Oh wait, it seems I have problems with the flgrx driver not enabling direct rendering, fun, fun, fun...... ; )

Janl
26th October 2006, 05:39 PM
If you are using the fglrx drivers you have to turn off AIGLX.

ALiAs
26th October 2006, 05:52 PM
AIGLX is turned off as I play quite a few games on this machine, unreal tournament, ut2004, enemy territory and so on, well used to on core 5 that is, I may have to sit and wait for a fix or become impatient and start breaking my install.. : )