PDA

View Full Version : gspcav1 Webcam Driver



dvn805
15th October 2006, 11:36 AM
On Fedora FC5 x86-64, I'm getting the following errors when I try to install this driver:
--------------------------------------------------------------------------------
Installed: kernel-devel.x86_64 0:2.6.17-1.2187_FC5
Complete!
[root@localhost ~]# cd gspcav1-20060925
[root@localhost gspcav1-20060925]# make
make -C /lib/modules/`uname -r`/build SUBDIRS=/root/gspcav1-20060925 CC=cc modules
make[1]: cc: Command not found
make[1]: Entering directory `/usr/src/kernels/2.6.17-1.2187_FC5-x86_64'
CC [M] /root/gspcav1-20060925/gspca_core.o
/bin/sh: cc: command not found
make[2]: *** [/root/gspcav1-20060925/gspca_core.o] Error 127
make[1]: *** [_module_/root/gspcav1-20060925] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.17-1.2187_FC5-x86_64'
make: *** [default] Error 2
[root@localhost gspcav1-20060925]# make install
mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
install: cannot stat `gspca.ko': No such file or directory
make: *** [install] Error 1
--------------------------------------------------------------------------------
Someone (anyone who knows) :) please explain to me in depth pertaining to the meaning of these error messages. I'm not sure if it's me who's missing a step; as far as support on this driver, I've barely found anything.
see
http://forums.fedoraforum.org/forum/newthread.php?do=newthread&f=7

Thank you.

Iron_Mike
15th October 2006, 01:07 PM
Are you sure you have the correct directory names, I'm running the 20060930 release and the main directory is gspca-20060930 not gspcav1-20060930. Also the "makefile" is locate /~/gspca-20060930/gspcav1

Try running the make and make commands from there

dvn805
15th October 2006, 01:20 PM
[root@localhost gspca-20060930]# cd gspcav1
[root@localhost gspcav1]# <------>

I am running the make command from [root@localhost gspcav1]. I still am getting the same error message.

Iron_Mike
15th October 2006, 07:43 PM
Try running this command as root, goto goes to gspcav1 directory and run:
./gspca_build

Wayward4now
4th November 2006, 05:00 AM
Iron Mike, I used that and still it complains... the tarball worked just fine with kernel-2.6.17-1.2187_FC5
but with kernel-2.6.18-1.2200.fc5 it bombs with this:
gspca: Unknown symbol video_devdata
gspca: Unknown symbol video_unregister_device
gspca: Unknown symbol video_device_alloc
gspca: Unknown symbol video_register_device
gspca: Unknown symbol video_usercopy
gspca: Unknown symbol video_device_release
Linux video capture interface: v2.00
gspca: Unknown parameter `index'

No clue.

The error message I get during the ./gspca_build is:
LOAD gspca in memory
FATAL: Error inserting gspca (/lib/modules/2.6.18-1.2200.fc5/kernel/drivers/usb/media/gspca.ko): Unknown symbol in module, or unknown parameter (see dmesg) (which I posted above)

Maybe something was left out in the FC5 2200 kernel? I also uninstalled the beta nVidia video drivers and installed the good ole standard nVidea drivers from Livna. I hope none of it is floating around.
I might be better served to re-check out my xorg.conf file. Maybe therein lies the problem? Ric