PDA

View Full Version : Nvidia installs fine, until i reboot



ruthik
14th October 2006, 09:52 AM
Alrighty, I have been stumped for a couple hours now. A week ago, I got everything running first swing. Then I dicked around in the xorg.conf file without knowing what I was doing and had to reinstall. A week later and about 6 reinstalls later I am still stuck, but so close to figuring this out. I am left with one problem. Dont flame me after you read it lol, its probably simple but i cant find it on forums or faqs anywhere, and yes i did google it.

When installing the nvidia driver package for my "updated" kernel, I get 0 errors. I load up GDM (without restarting) and I have direct play and everything is working super perfect. I run that glxconf and everything checks out fine. Well.... I reboot... and all of a sudden... on boot up... the kernel module cant find the nvidia.ko file and loads up the default nv file.

IN TERMINAL
locate nvidia.ko
/lib/modules/2.6.17-1.2187_FC5smp/kernel/drivers/video/nvidia.ko
/usr/lib/xorg/modules/nvidia.ko << -- This was me copying it. I made a wrong guess lol

My question to you is. WHERE DOES IT GO!? lol. Where should I copy this stupid ko file for it to work? It is the default everything straight from nvidias official site. So maybe it is configured for fc4 or something and x11 or someone changed the default directory for linux to look for .ko files in fc5. Any help would be greatly appreciated.

edit:
Just an update to prevent links that dont help being sent to me.
I have installed:
- most recent kernel and source
- the xorg-server-sdk
- gcc
- installed kmod-nvidia-smp

NO errors reported during install and that is why it works fine when I run GDM right after the install. If possible, finding out where the kernel is looking for nvidia.ko is so I can simply copy-paste it to the location should solve it. If not, I'll have to find a different way to fix this.

ruthik
14th October 2006, 10:23 AM
Woohoo. I found it! Site credit -> THIS ONE! (found it through google though, search here didnt work it and i was desperate when I found it in this situation. Glad I found it...) http://forum.fedoraforum.org/showthread.php?t=99285&page=1&pp=15

The problem was that nvidia/xorg (one of the 2) was installing original release of 2.6.17 kernel when I had smp. Therefore the nvidia drivers followed into that kernel. If you are having this problem. Skip to the bottom.

A small tutorial for future users that cant find another tutorial helpful...

1. Disable SELinux OR run the following commands:
setsebool -P allow_execmod=1
setsebool -P allow_execstack=1

2. Make absolute certain that you have the following packages installed and updated (easier to use YUM):
To install / update using YUM type : yum (update or install) (package name)
gcc
make
glxutils
xorg-x11-server-sdk
xorg-x11-server-Xgl
xorg-x11-drv-nvidia

3. Type /sbin/init 3 and login as root

4. Run the driver (sh NVIDIA-Linux-"blablabla")

5. IF ANY ERRORS COME UP press CTRL Z and fix them if possible. A faulty install is a faulty driver in the end. I've learned that in more than just computers, if you half ass something, you come up with half ass results.

6. I half-assed it without choice, it wouldnt see my xorg sdk for some reason. So it installed the drivers to a default location (/usr/lib/modules i think). Anyways I did the following to fix it.

Run service nvidia-glx restart and if any "Failed" comes up, you have a problem. If it can't find the nvidia.ko file, do the following.
updatedb
locate nvidia.ko

location/of/nvidia.ko/file
to
/lib/modules/2.6.17-1.****_FC5smp/extras/nvidia/nvidia.ko

Run
service nvidia-glx restart
to confirm.
Should be all green now.

UPDATE:
After doing the above and making sure that Direct Rendering was possible, I moved onto the next step of installing XGL (without compiz at this point... I want to find the problem) and I noticed that when I rebooted and it came up in XGL that Direct Rendering was indeed not enabled and the following:
server glx vendor string: SGI
came up, rather than the usual:
server glx vendor string: NVIDIA Corporation

Just to make sure that it was XGL, I ran gdmsetup and changed back to standard. Reboot. Whaddya know...Direct Rendering: Yes.
So I have narrowed it down to XGL at this point. For some reason it isn't wanting to use the GLX for my nvidia card.