View Full Version : Trying to run WoW on FC5 with wine 0.9.22

12th October 2006, 09:59 PM
Im trying to World of Warcraft on

my asus m6va centrino 2.0ghz
ati radeon x700m with livna drivers
wine version 0.9.22

when i installed and tried to run wow for the first time i got error saying memory cant be read. then I edited the regedit as in this guide tells you to do(and config the WTF.conf file) http://appdb.winehq.org/appview.php?iAppId=1922

Now i got a very "borken" wow that looks like this

http://img455.imageshack.us/img455/9337/skjermdumpux6.th.png (http://img455.imageshack.us/my.php?image=skjermdumpux6.png)

somebody who knows how to fix this bug?

extra info: i have installed crossover office and there the games work FLAWLESSLY for like 10 sec after I entered the world, then the program hangs and i need to reboot, everytime... so what i want is to get wine to work

12th October 2006, 11:00 PM
I haven't really spent much time playing with WINE yet, but I was able to play WoW using Cedega fairly well a couple months ago.

12th October 2006, 11:16 PM
im already paying for wow, and other users have no problems running wine and wow.... why cant i?

12th October 2006, 11:44 PM
it looks like this when i drop the "opengl" after wow.exe...

[img=http://img214.imageshack.us/img214/8391/skjermdump1cf3.th.png] (http://img214.imageshack.us/my.php?image=skjermdump1cf3.png)

so i guess there is something wrong with the opengl :P someway i can fix that?

13th October 2006, 12:26 AM
Are you sure that your fglrx drivers are actually working? maybe try to run fglrxinfo and see if it's using the ATI drivers or using Mesa. Other than that, like I said before, I haven't really used WINE, so can't be of much help.

13th October 2006, 09:56 AM
[lars@larsey ~]$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON X700 Generic
OpenGL version string: 2.0.6011 (8.28.8)

13th October 2006, 02:29 PM
Ok, so that does show that you are infact using the fglrx drivers from ATI. I did a little searching and found this (http://appdb.winehq.org/appview.php?iVersionId=5606). Have you checked this page and are these the .reg edits you mentioned?

13th October 2006, 03:52 PM

I get opengl to work now, but after i logged in and entered the world the game(and the whole laptop) crashes!!! Why is this?

13th October 2006, 07:54 PM
wine errorlog:

err:wgl:X11DRV_wglGetPixelFormatAttribivARB Unable to convert iPixelFormat 0 to a GLX one, expect problems!

someone who know how to correct this error?

25th October 2006, 01:50 AM
You have patched it and all of that? I used to get a heap of issues with wine when it was unpatched. Another suggestion is to post on the wine appdb page because generally they have all seen or experienced it.

Also when you post there just make sure you've tried EVERYTHING out :)