PDA

View Full Version : problems with grub



liamtheloser
30th September 2006, 09:59 PM
When I boot up my computer from a fresh install of fc6t3, it loads grub into command line mode, and i have to manually enter my kernel and initrd, then boot every time. I've looked at my grub config and it's set up to display a menu with my 3 OS's... Anyone had this problem before? with grub just throwing you into a command line?

I recently re-installed fedora because i was having troubles with fc3, which worked fine until i switched monitors, and I'm not sure if it was lilo before, or if fc3 had grub natively, but it worked perfectly, letting me boot between xp, fedora and slackware, i now just want the boot menu back!

please help! -- liam

liamtheloser
1st October 2006, 01:26 AM
No one? I'd really like to know what I'm doing wrong, or what I'm not doing that's making grub commandline only...

Seve
1st October 2006, 02:11 AM
Hello:
It could be that grub did not get installed correctly or mucked something up during the install?
Can you post the output of fdisk -l ?

Seve

Jongi
1st October 2006, 02:47 AM
Are you multibooting?

Post cat /boot/grub/menu.lst

Post cat /boot/grub/device.map

Also, go into your BIOS and find out what the boot order is.

liamtheloser
1st October 2006, 04:05 AM
I'll do all of those as soon as I get home... Waiting for my ride right now.

Although I will say the fdisk -l does show all 3 of my hard drives, only 2 of which have operating systems on them at the moment.

hda is my 20 gig winxp drive
hdb is my 160 gig media storage drive
hdd is my 120 gig linux drive

to boot from grub command line, i have to input the following

kernel /vmlinuz(tab)
initrd /initrd(tab)
boot

then fedora comes up just fine.

also, my boot order is hd0,hd1,hd2 in my bios.

I haven't tried booting into XP yet, just because I still don't exactally know what I'm doing in grub.


I'll be posting in about an hour or so with those cats, and the fdisk list

liamtheloser
1st October 2006, 10:34 AM
Here is the fdisk:

[root@localhost ~]# fdisk -l

Disk /dev/hda: 20.4 GB, 20496236544 bytes
255 heads, 63 sectors/track, 2491 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 2491 20008926 7 HPFS/NTFS

Disk /dev/hdb: 163.9 GB, 163928604672 bytes
16 heads, 63 sectors/track, 317632 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 317631 160085992+ 55 EZ-Drive

Disk /dev/hdd: 122.9 GB, 122942324736 bytes
255 heads, 63 sectors/track, 14946 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdd1 * 1 13 104391 83 Linux
/dev/hdd2 14 14946 119949322+ 8e Linux LVM
[root@localhost ~]#


here are the cats of my menu.lst and my device.map

[root@localhost ~]# cat /boot/grub/menu.lst
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd2,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd2,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.18-1.2708.fc6)
root (hd2,0)
kernel /vmlinuz-2.6.18-1.2708.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-1.2708.fc6.img
title Fedora Core (2.6.17-1.2630.fc6)
root (hd2,0)
kernel /vmlinuz-2.6.17-1.2630.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.17-1.2630.fc6.img
title Other
rootnoverify (hd0,0)
chainloader +1
[root@localhost ~]# cat /boot/grub/device.map
# this device map was generated by anaconda
(hd0) /dev/hda
[root@localhost ~]#

Seve
1st October 2006, 10:39 AM
Hello:
As Jongi suggested are you able to post the output of:

cat /boot/grub/menu.lst

and

cat /boot/grub/device.map

Seve

liamtheloser
1st October 2006, 10:54 AM
sorry, i just updated, i accidently pasted the fdisk list 3 times... there, that should be correct

Seve
1st October 2006, 11:21 AM
Hello:
You may want to check your BIOS in the hard drive area to make sure that all your discs are enabled properly?
Your output of cat /boot/grub/device.map
only shows
(hd0) /dev/hda

which is only 1 of the 3 drives that you have installed?
Or, did I miss something?

Seve

liamtheloser
1st October 2006, 06:53 PM
all 3 drives are enabled in bios.

liamtheloser
1st October 2006, 11:14 PM
anyone else have any ideas?

liamtheloser
10th October 2006, 06:08 AM
Going to bump this, but it's been a week, anyone have any ideas?

:confused: :confused: :confused:

liamtheloser
12th October 2006, 01:44 AM
Can anyone help?

*bump*

bob
12th October 2006, 02:07 AM
No solution, but this is something that should be reported: http://www.redhat.com/mailman/listinfo/fedora-test-list I'd sign up and see if there's anyone who can give you a quick answer. If not, it's bugzilla time!: https://bugzilla.redhat.com/bugzilla/index.cgi

William Haller
18th November 2006, 08:41 AM
Just did an upgrade to a working FC5 to FC6 WIn98 on sda, FC5 in sdb. Everything sucessfully installed and I did a reboot. grub was configured on sdb before and I had told it to upgrade the grub configuration.

Got a grub> prompt instead of the splash screen. After searching through some posts.

did a find /grub/stage1
root (hd1,0)
setup (hd1)

and rebooted and it was OK. It looks like if grub is on some disk other than 0 it isn't getting updated right. Don't know if this is the exact same issue, but it is close. I had poked around and looked at the device.map file produced by anaconda and it didn't have (hd1) /dev/sdb in it, but just adding that wasn't enough - I had to go through the setup again using the above steps directly from the grub> prompt after reboot.

Other posts mention that you have options on how to configure grub. That isn't true on an upgrade.