View Full Version : I can't start Xwindow as a root.

22nd September 2006, 02:53 AM
Dear All,

Xwindow couldn't start as a root account, but as an other user it starts and works well.

I am a beginner at using linux and poor at English. So it's diffcult problem for me.

I think some configuration files are different between root and other user.

Before this problem occurs, I installed MicroSoft Trutype font and changed xwindow fonts as a root. But I used xwindow several times with no problem.
So It may not the reason.

Then I add user account and startx. It works well.

I want start xwindow as root account. Help me plz.

a thing
22nd September 2006, 05:40 AM
Why would you want to use X as root?

22nd September 2006, 06:15 AM
I just want to know what the problem is and how can I fix it.

22nd September 2006, 03:41 PM
I just want to know what the problem is and how can I fix it.
one possible problem is a full partition. so if you setup an own partition for /home it could be (its one possibility) that your /-partition is full? (check with 'df -lh')...

another realy helpful step would be to check /var/log/Xorg.0.log. Whats says the messages there? Can you use 'system-config-display' as root from runlevel 3 or does even this crash?

to get through this list of steps to get x working with root, you can start as described here:

- any partition full (/, /tmp,...)?
- is it possible to start a single X (not the full desktop), just run 'X'
- check messages in /var/log/Xorg.0.log

cheers, liro