PDA

View Full Version : weird crash: amarok crash jammed external hdd



newbie_fin
20th September 2006, 08:39 PM
Hi!

I just had the weirdest crash/problem I've ever had with linux. I was just normally doing some school coding with eclipse, had azureus, firefox, a couple of terminals, nautilus and amarok running.. then suddenly the music stops playing. Amarok stopped responding and my usb external hdd:s led was all red (not even blinking). I managed to get rid of amarok but ps -e | grep amarok showed that it was actually still running and the hdd led was still indicating I/O. On the terminal I tried to display the root of the hdd but nothing happened. I opend gnome-system-monitor and saw that azureus had become a zombie and ls was still running too and it said ls could not be stopped which proved to be the truth as nothing happened when I tried to kill ls.
Ok I that's when I ran out of ideas about what to do. I knew only one thing that I could do. Just try to reboot. And that's what I tried... with no succes. The hdd could not be unmounted and the reboot failed. I pressed the power button. The computer tries to shut it self but (ofcourse) was unable to do any better than when trying to reboot... At that point I was really scared.
Only one thing I knew that I could do. Press the computers power button for a long period and make the computer powerless. I wait for a moment.. and start the computer. The computer freezes with the startup screen saying press F2 to get to bios (or something like that). Well obviously there wasn't anything else to do so I tried F2 and then it says loadin... but nothing happens. Now I'm really REALLY scared! What if I lose all my data on my computer too??
Ok, second try. I shut the computer again. Unplug the external hdd. Wait for a moment. Start the computer. And the relief is great when grub asks me which os to load. I choose FC5 and then everything goes here on normally (except for a couple of lines about recovering from bad shut-down).
As I type my user name on the login screen I'm feeling a little bit down about maybe loosing all my data on the external hdd. I was just hoping I could recover it maybe with the help of the ext3 fs journal from the drive.. I plugged the drive in and as usual it says it can't read the NTFS-partition... end then nautilus opens the ext3 fs on the external hdd and boy I'm sooooo happy and reliefed. I check dmesg for info about what it did:

usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
Vendor: Maxtor 6 Model: L250R0 Rev: BAH4
Type: Direct-Access ANSI SCSI revision: 00
usb-storage: device scan complete
0:0:0:0: Attached scsi generic sg0 type 0
SCSI device sda: 490234751 512-byte hdwr sectors (251000 MB)
sda: Write Protect is off
sda: Mode Sense: 03 00 00 00
sda: assuming drive cache: write through
SCSI device sda: 490234751 512-byte hdwr sectors (251000 MB)
sda: Write Protect is off
sda: Mode Sense: 03 00 00 00
sda: assuming drive cache: write through
sda: sda1 sda2 < sda5 > sda3
sd 0:0:0:0: Attached scsi disk sda
SELinux: initialized (dev sda1, type vfat), uses genfs_contexts
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda3, internal journal
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
SELinux: initialized (dev sda3, type ext3), uses xattr

I'm just wondering that what caused this (I suppose no-one knows..)? And what saved my external hdd? Well I don't recall doing any writing on it so I suppose that's it.. And what about the ext3 fs? I just less than a month ago converted the external hdd from ext2 to ext3. If it would have had ext2 fs on it would I have lost my data? Does the ext3 fs provide any protection for usb storage on unsafe unplugs? And why did my computer freez on the first startup? And those linux gurus of you, how wolud have you handeled this kind of sitaution?