PDA

View Full Version : Unable to mount kernel - what did I do wrong!?



itsthescottdog
20th September 2006, 05:31 PM
I've been learning Linux for the past week and I've had some major problems with Fedora Core 5 - possibly user error, I will admit.

Install 1
I installed support for reading ntfs file systems via livna's kmod-ntfs and I still couldn't view the ntfs partitions on my hard drives - filesystem: unknown. Then I modified the fstab file to mount a fat32 partition automatically when booting. At some point, my terminal became inoperable and said something to the effect that it couldn't create a child process for this terminal. The only other settings I changed were my Desktop background, login screen background, samba shares, and my network configuration. FC5 would not successfully boot again when I restarted it. I tried linux rescue and restored my backup fstab file but to no avail. Does anyone know what I did wrong here?

Install 2
I did every update that was available thru the update manager - (15 hours of downloading time wasted). Now I installed support for reading ntfs file systems. No ntfs support after the install and I've determined that I'm just going to move my files around in Windows so I can reformat all my ntfs drives to fat32. I restart my computer and boot into Windows, I move some of my movies to a fat32 drive and restart the computer. This is when I was greeted by a grub prompt! WHERE DID MY LINUX KERNEL GO? I ask grub, but it didn't have an answer. I ran Linux rescue and looked at my grub.conf file and copied the contents of the linux booting commands to the grub prompt but grub couldn't mount the kernel. I typed in the Windows boot command from the grub.conf file and it booted Windows just fine.

What am I doing wrong?

I'm not an idiot, but I'm still very new to Linux. (A friend pointed me to the grub.conf and fstab files - I know nothing about linux and I don't want to give anyone the impression I do know anything)