PDA

View Full Version : Basic YUM Question



RossGoodman
16th September 2006, 12:23 PM
Hi
I recently applied a lot of updates to my PC, I've not been using it in ages. this went well.
When I updated today I got the following:

Error: Missing Dependency: libexif.so.9 is needed by package nautilus
Error: Missing Dependency: libexif.so.9 is needed by package eog
Error: Missing Dependency: libexif.so.9 is needed by package gimp
Error: Missing Dependency: libexif.so.9 is needed by package gphoto2
Error: Missing Dependency: libexif.so.9 is needed by package gthumb
[root@ross-fc3 ~]# yum install libexif.so.9
Setting up Install Process
Setting up Repos
fedoralegacyupdates 100% |=========================| 951 B 00:00
livna-stable 100% |=========================| 951 B 00:00
extras 100% |=========================| 951 B 00:00
updates 100% |=========================| 951 B 00:00
atrpms-stable 100% |=========================| 951 B 00:00
release 100% |=========================| 951 B 00:00
livna-unstable 100% |=========================| 951 B 00:00
livna-testing 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
fedoralega: ################################################## 92/92
livna-stab: ################################################## 306/306
extras : ################################################## 1763/1763
updates : ################################################## 661/661
atrpms-sta: ################################################## 994/994
release : ################################################## 1652/1652
Parsing package install arguments
Nothing to do

Any ideas?

Seve
16th September 2006, 02:15 PM
Hello:
Which FC version are you trying to update?
It looks like you have a lot of repos enabled that don't mix that well i.e. livna and Atrpms. see :http://stanton-finley.net/fedora_core_5_installation_notes.html#Yum
Alsoo, not sure why you have all the unstable and testing etc, repos enabled?

Seve

Jongi
16th September 2006, 07:20 PM
# yum provides libexif.so.9

This should give you a list of packages that provide libexif.so.9. You can then install one of them. The underlying problem though is that highlighted by Seve.

RossGoodman
17th September 2006, 11:26 PM
I'm using FC3

So what repos would you recommend that I use?