PDA

View Full Version : Kernel Panic with 2.6.17-1.2187_FC5 and Samba



bart3005
16th September 2006, 09:06 AM
Hi

The new 2.6.17-1.2187_FC5 kernel is getting a panic when any client access Samba shares that are served from this machine. The not happening with the kernel before 2.6.17-1.2174_FC5 in fact this box is normally very stable.

Message dumped to console is: 'Kernel Panic not syncing: Aiee, killing interrupt
handler'. There is nothing in the logs, the kernel must panic before anything can be
written to the log files. The box completely locks up and has to be hard booted with the power button.

This is a X86_64 machine with Fedora Core 5 64bit. It has all the available updates.

Anyone have any ideas? I am booting into the old kernel for now.

Thanks!

Regards
Daniel

bart3005
16th September 2006, 09:09 AM
I forgot to say that if I shut Samba down or not allow clients to access the shares the machine seem to work fine. I can browse the file systems, start a X session, browse the Web and do network stuff. Seem to be just Samba causing the panic.

david homborg
18th September 2006, 09:58 PM
hi,

i'm having problem as well with this kernel. for me the computer locks up when sending mail , or browsing some web pages. it seems to be network related , so i was wondering networkdriver you are using. i'm using the forcedeth network driver

david

bart3005
19th September 2006, 01:51 AM
Hi

Yes I am using the forcedeth network driver. Must be that.

Regards
Daniel

bart3005
19th September 2006, 01:55 AM
BTW I submitted a bug at redhats bugizilla for this.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=206744

Might pay to make a comment there.

david homborg
19th September 2006, 07:20 AM
Hi,

i wil add a comment at bugzilla.

david

sej7278
19th September 2006, 08:28 AM
2187 seems to be a total mess, all kinds of nvidia problems as well as nfs, udev etc. for me.

bart3005
20th September 2006, 03:48 AM
I dowmload the test kernel from http://people.redhat.com/davej/kernels/Fedora/ to see if the problem is fixed for me and my Areca RAID driver won't complie under this kernel. I download the srpm and rebuild it so I got the devel rpm so I could compile the driver. Looks like I'm out of luck as devfs has been removed form the newest kernel and the driver includes one of the includes from devfs.

apr
28th September 2006, 01:51 PM
I also have this problem with 2187 kernel. Similar hardware config to bart: X86_64, 64-bit FC5, crash when accessing samba shares. I too am using forcedeth. I've got an NVidia graphics card and am using their driver.