PDA

View Full Version : 5.1 Audio Not Working



raman_tx
15th September 2006, 02:49 AM
Hi Guys!
I am newbe to this forum. I have recently installed FC5. The prb that kills me is SOUND. I cant hear from centre and rear speakers in my creative Inspiron. Here are specs

SND CARD SBLIVE 5.1 24 BIT
BUILT INTEL : 82801 JUST NORMAL 2 SPEAKER SOUND CARD

I am able to set creative as default and even I can get it work to 2 speakers front L/R but not centre and rear. I did what ever I can spending whole lot of time... :mad: Editing .asoundrc...etc/rc.local or what evr files i found on forums...NO HELP...

Appreciate your suggestions/help

ONCE AGAIN i JUST NEED ALL SPEAKeRS 2 WORK

thnks in advance

daneel971
15th September 2006, 07:30 AM
the howto section of the forum is for solutions, not problems... :)
Anyway, alsa defaults using the front channel, so you have to set up all of your apps to use the 6 channel configuration when playing 6 channel audio (if you're trying to playing a regular stereo sound with all of your speakers, that's a different question). Xine has an audio tab in the configuration window; for mplayer you can write a general config file in ~/.mplayer or a file-specific config file (read the mplayer manual and docs fo this).
On the command line, with a file with 6ch audio or a DVD you can use mplayer with

mplayer -ao alsa:device=surround51 yourfile.mkv
mplayer -ao alsa:device=surround51 -aid 128 dvd://1
(the aid value is an example - select the right one).
Remember that aac 6ch audio has a different channel order than 6ch ac3 audio, so you need to use the channel filter for mplayer.