PDA

View Full Version : Gobbledy Goop



mlissner
14th September 2006, 08:01 AM
Fedora is irking me, and I can't figure out how to fix it...

If I boot her up, hit CTRL+ALT+F1, and then wait a few seconds, a bunch of Gobbledy Goop pops up on the screen. Stuff about kernels and buses, and PIDs...looks like useful info, but I wish it weren't just popping onto my screen all the time...

It makes using the virtual terminals pretty much a pain in the @$$.

Anybody know what's causing this? It's not doing it in the terminal terminal in the graphical desktop...only in the virtual ones...

I can't figure out how to copy and paste it out of there either, so if you know how to do that, let me know and I'll post it.

Thanks

b_martinez
15th September 2006, 12:52 AM
Is FC fully booted? It may take a while to get fully up to speed. Try ctrl-alt-F2 thru F6 to check it out.
Bill

mlissner
15th September 2006, 06:50 AM
No, it spurts out this goop intermitantly regardless of how long the computer has been booted. This isn't normal output type stuff - it's very different. Looks almost like an error log, but it's not really quite human readable?

mlissner
17th September 2006, 12:31 AM
Any solutions out there for this? I'm beat. It makes using any of the virtual terminals pretty much useless, which is too bad.

I'd be happy to give up a sample of this goop, but I can't figure out how to capture it from the virtual terminal. I thought I could copy it to the clipboard, but CTRL+SHIFT+C doesn't work in the virtual terminal, nor does CTRL+C. I'm kind of surprised I can even select it using the mouse actually...

Any ideas on how to capture this info so we can look more closely...I tried screen captures too, but they only work in the graphical arena, and I don't have a camera...sorry.

I also tried starting up a sub-shell with the following:


bash 2> errors

Not surprisingly, that didn't work very well either. The output seems rather independent of the shell being used.

Here's an example of the Goop:
audit(1158449608.618.32637): avc: denied { getattr } for pid=22449 comm="csh" name="utmp" dev=md2 ino=1566311 scontext=user_u:system_r:hotplug_t: s0 tcontext=system_u:object_r:var_run_t:s0 tclass=file

Our brains can solve this one...

sebnukem
17th September 2006, 01:19 AM
Try checking your /etc/syslog.conf for entries like:
*.* /dev/tty1

sebnukem
17th September 2006, 01:21 AM
Also, try disabling SElinux. The goop example is a SElinux message.

mlissner
17th September 2006, 06:05 AM
Yep. Selinux was to blame. Once disabled, the messages seem to have gone away. Good thing too, they were driving me insane...

...now...any theories on how to have it enabled and not receive the goop?

Thanks all.