PDA

View Full Version : Printing Problem: No Errors, but No Output



Reisswolf
13th September 2006, 10:00 AM
Hi,

I have just installed an Epson Stylus C45 printer. I read the instructions at LinuxPrinting.org, and I first downloaded gutenprint-5.0.0. After installing gutenprint (during which there were no errors) I hooked up the printer itself.

Everything seemed to go smoothly. From System -> Administration -> Printing I was able to set up the printer. The options originally set in printconf were the following:



Name: EpsonC45
Queue type: Locally-connected
Device: /dev/usb/lp0 EPSON Stylus C45
Filter options: scp-fc5 true
Manufacturer: Generic
Driver: PostScript Printer


When I tried to print a test page, nothing happened. A little box said that the job had been sent to the printer and asked if the page looked okay. I clicked "No," which caused the following error messages to be displayed:



I [13/Sep/2006:09:51:17 +0100] Adding start banner page "none" to job 5.
I [13/Sep/2006:09:51:17 +0100] Adding end banner page "none" to job 5.
I [13/Sep/2006:09:51:17 +0100] Job 5 queued on "EpsonC45" by "root".
I [13/Sep/2006:09:51:17 +0100] Started filter /usr/lib/cups/filter/texttops (PID 3223) for job 5.
I [13/Sep/2006:09:51:17 +0100] Started filter /usr/lib/cups/filter/pstops (PID 3224) for job 5.
I [13/Sep/2006:09:51:17 +0100] Started filter /usr/lib/cups/filter/foomatic-rip (PID 3225) for job 5.
I [13/Sep/2006:09:51:17 +0100] Started backend /usr/lib/cups/backend/usb (PID 3226) for job 5.


I have tried chaging the driver to "Raw Print Queue," then changing the manufacturer to Epson and setting the model to be "Stylus" (C45 specifically is absent from the list), but in each case the result of trying to print a test page is a message similar to the error message above.

Does anyone know what is going on? LinuxPrinting.org says that the C45 works perfectly with gutenprint-5.0.0, but I can't seem to get it to work.

Thanks in advance for your help.

*****

One more error message. With the manufacturer set to "Epson" and the driver set to gutenprint-ijs-5.0, the error message generated by the test print attempt is:



I [13/Sep/2006:10:02:14 +0100] Adding start banner page "none" to job 7.
I [13/Sep/2006:10:02:14 +0100] Adding end banner page "none" to job 7.
I [13/Sep/2006:10:02:14 +0100] Job 7 queued on "EpsonC45" by "root".
I [13/Sep/2006:10:02:14 +0100] Started filter /usr/lib/cups/filter/texttops (PID 3329) for job 7.
I [13/Sep/2006:10:02:14 +0100] Started filter /usr/lib/cups/filter/pstops (PID 3330) for job 7.
I [13/Sep/2006:10:02:14 +0100] Started filter /usr/lib/cups/filter/foomatic-rip (PID 3331) for job 7.
I [13/Sep/2006:10:02:14 +0100] Started backend /usr/lib/cups/backend/usb (PID 3332) for job 7.
E [13/Sep/2006:10:02:14 +0100] PID 3331 (/usr/lib/cups/filter/foomatic-rip) stopped with status 3!
I [13/Sep/2006:10:02:14 +0100] Hint: Try setting the LogLevel to "debug" to find out more.

JaRaEeZ
13th September 2006, 12:56 PM
Im not quite sure but can you go to http://localhost:631/ then 'manage jobs' & see if your test prints are there? If so delete them then go to 'prinetrs' & take a look from there. Like I said im not to sure but this is how I have setup my HP 930c.

HTH

Reisswolf
13th September 2006, 11:34 PM
Thanks for the information. I am trying all that, but nothing is helping. The jobs are listed as "stopped" and resubmitting them does not really produce anything different. But when I try to print a test page from http://localhost:631, I get the following:

"/usr/lib/cups/filter/foomatic-rip failed"

I have done a Google search for that keyword, but no helpful link was returned.

JaRaEeZ
14th September 2006, 01:37 AM
can you try this from the CLI
FoomaticRIPPostPipe: "| cat > /dev/usb/lp0 which will try to print directly ( I believe!)

Reisswolf
14th September 2006, 01:58 AM
Hi,

When I type that, I get a little "greater than" sign, like so:



$ FoomaticRIPPostPipe: "| cat > /dev/usb/lp0
>

And then nothing happens. If I hit ENTER, a new "greater than" sign is displayed, but no printing is done. I have tried entering the name of a valid file at the ">" sign, but even after that I don't get any output.

JaRaEeZ
14th September 2006, 03:17 AM
ok & if you go back to http://localhost:631 are they any jobs in the queue?

Reisswolf
14th September 2006, 05:27 AM
Yes, evidently there are. The page http://localhost:631/jobs says that there are four active jobs:



Showing 4 of 4 active jobs.
EpsonC45-7
EpsonC45-8
EpsonC45-9
EpsonC45-10


If I try to "reprint" the job, CUPS says that the appropriate job has been restarted. But once again, there is no output.

Omega Blue
14th September 2006, 10:21 AM
Reisswolf: you shouldn't need to do that, CUPS should be able to handle it for you. Maybe you have installed stuff that created some conflict. Perhaps removing it and try using CUPS again? For FC5 that's System > Administration > Printer

JaRaEeZ
14th September 2006, 12:10 PM
I would agree with the re-installing of CUPS which should also make sure it's up-to-date