PDA

View Full Version : add & Remove problems



MintabiePete
13th September 2006, 01:43 AM
I havnt had fedora bordeau very long on this computer , and I really like it . It is easy to setup for a n00bie like me :) But I seem to be having problems with my YUM & add & remove . Here is the error file from it , can I do anything to repair it or would it be a lot easier to re install ?

Component: Software Manager
Summary: TB4426d5a1 ConfigParser.py:490:_read:ParsingError: File contains parsing errors: ///etc/yum.repos.d/livna.repo
[line 43]: 'livna-stable]\n'

Traceback (most recent call last):
File "/usr/sbin/pirut", line 390, in ?
main()
File "/usr/sbin/pirut", line 383, in main
pm = PackageManager(options.config)
File "/usr/sbin/pirut", line 57, in __init__
GraphicalYumBase.__init__(self, False, config)
File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
self.doConfigSetup(configfn)
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 104, in doConfigSetup
self.getReposFromConfig()
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 135, in getReposFromConfig
parser.read(files)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 225, in read
IncludingConfigParser.read(self,filename)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 126, in read
ConfigParser.read(self,filename)
File "/usr/lib/python2.4/ConfigParser.py", line 267, in read
self._read(fp, filename)
File "/usr/lib/python2.4/ConfigParser.py", line 490, in _read
raise e
ParsingError: File contains parsing errors: ///etc/yum.repos.d/livna.repo
[line 43]: 'livna-stable]\n'

Local variables in innermost frame:
sectname: livna
cursect: {'name': 'Livna for Fedora Core $releasever - $basearch - Base', 'failovermethod': 'priority', 'gpgkey': 'file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna', 'enabled': '0', 'baseurl': '\nhttp://rpm.livna.org/fedora/$releasever/$basearch/\nhttp://livna.cat.pdx.edu/fedora/$releasever/$basearch/\nhttp://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/\nhttp://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/', 'gpgcheck': '1', '__name__': 'livna'}
e: File contains parsing errors: ///etc/yum.repos.d/livna.repo
[line 43]: 'livna-stable]\n'
fpname: ///etc/yum.repos.d/livna.repo
vi: =
mo: <_sre.SRE_Match object at 0xb79ec6b0>
value: http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
optname: gpgcheck
fp: <open file '///etc/yum.repos.d/livna.repo', mode 'r' at 0xb79de770>
lineno: 71
line:
self: <yum.parser.IncludedDirConfigParser instance at 0xb796e4ac>
optval: 1

I hope I dont have to re install , that there is a way around this :)

Thanks

Peter

MintabiePete
13th September 2006, 11:11 PM
Fair dinkum , no one has any ideas :)

u-noneinc-s
13th September 2006, 11:17 PM
Look at your /etc/yum.repos.d/livna-stable.repo file. I think You'll find you left out the opening bracket in [livna-stable] (top of the file)
In the future, you can always run yum --disablerepo=reponame command to bypass problem repos

hollywoodb
13th September 2006, 11:24 PM
yes, there's a parsing error in one of your livna repo files. The output is somewhat hard to read, so here's what I suggest:

as root:

rm /etc/yum.repos.d/livna* && rpm -ivh --force http://rpm.livna.org/livna-release-5.rpm

that will remove your current livna repo files as well as download/install them again.

MintabiePete
13th September 2006, 11:25 PM
Thanks for the tip , lol I still dont really know what to do , this is a different setup than the other linux flavors I have tried , I notice another thread about uninstalling & reinstalling YUM that I have been trying to get a grasp on :)

MintabiePete
13th September 2006, 11:26 PM
Thanks again for those tips , it gives me something to work on :) Much appreciated

u-noneinc-s
13th September 2006, 11:41 PM
MintabiePete's suggestion will work fine, but I'll clarify mine. Using your favorite editor, open /etc/yum.repos.d/livna.repo. (You must edit this as root. I usually use vim). Scroll down to the livna-stable section. It should look like this [livna-stable] and not like this livna-stable] so you just need to add the [ before livna-stable]
I don't have a livna-stable repo, so, just curious, are you using FC4 or FC5 (or even FC3)?

u-noneinc-s
13th September 2006, 11:46 PM
Using KDE or Gnome desktop? KDE has a superuser terminal program. (root command line editor)
kmenu->system->more applications-> terminal program - Super User Mode.
Don't know about Gnome

MintabiePete
13th September 2006, 11:49 PM
[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/
failovermethod=priority
#mirrorlist=http://rpm.livna.org/mirrorlist-5
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

[livna-debuginfo]
name=Livna for Fedora Core $releasever - $basearch - Debug
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/debug/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/debug/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/debug/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/debug/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/debug/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/debug/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1

[livna-source]
name=Livna for Fedora Core $releasever - $basearch - Source
baseurl=
http://rpm.livna.org/fedora/$releasever/SRPMS/
http://livna.cat.pdx.edu/fedora/$releasever/SRPMS/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/SRPMS/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/SRPMS/
http://mirror.atrpms.net/livna/fedora/$releasever/SRPMS/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/SRPMS/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1
This is the livna-devel.repo file , not too sure why i need that , but when I run from your post hollywoodb it dosent seem to make much difference , I still get the error when i reboot and try to use add & remove and I have both KDE & Gnome installed and thanks again seems you are staying one post ahead of me I will try to catch up:)

MintabiePete
14th September 2006, 12:07 AM
where do I find this info ?
don't have a livna-stable repo, so, just curious, are you using FC4 or FC5 (or even FC3)?

u-noneinc-s
14th September 2006, 12:15 AM
Your first post says livna stable (with the missing bracket I mentiond). This last post doesn't show livna-stable, so I don't know where the livna stable is comming from. Are you trying to install anything in particular or trying to update your system or what.
Try yum instead of pirut (the add/remove app), and paste the error message from that. Also post your /etc/yum.conf (livna-stable is coming from somewhere).
Open a terminal and type
su -(That's su dash and enter your root password. Next type
yum update yum If you get an error message, paste it here (complete, from the command to the end) If you don't get an error (if it says nothing to do, or if it updates yum) type
yum install yumex

u-noneinc-s
14th September 2006, 12:21 AM
where do I find this info ?
don't have a livna-stable repo, so, just curious, are you using FC4 or FC5 (or even FC3)? All these things we are telling you are commands and require a terming (or console) You can press the key combination of alt+F2, and you will get a command promt. type konsole and hit enter and you will get a console. use that for these commands. To find what version you have, type uname -a

MintabiePete
14th September 2006, 12:28 AM
[peter@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 athlon i386 GNU/Linux
[peter@localhost ~]$

MintabiePete
14th September 2006, 12:33 AM
This is the error I get when I try to update
Password:
[root@localhost ~]# yum update yum
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in ?
yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 80, in main
base.getOptionsConfig(args)
File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
self.doConfigSetup(fn=opts.conffile, root=root)
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 104, in doConfigSetup
self.getReposFromConfig()
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 135, in getReposFromConfig
parser.read(files)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 225, in read
IncludingConfigParser.read(self,filename)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 126, in read
ConfigParser.read(self,filename)
File "/usr/lib/python2.4/ConfigParser.py", line 267, in read
self._read(fp, filename)
File "/usr/lib/python2.4/ConfigParser.py", line 490, in _read
raise e
ConfigParser.ParsingError: File contains parsing errors: ///etc/yum.repos.d/freshrpms.repo
[line 8]: 'freshrpms]\n'
[root@localhost ~]#

u-noneinc-s
14th September 2006, 12:41 AM
Notice the bottom line ... [line 8]: 'freshrpms]\n' It is also missing the leading [ in [freshrpms]. It is also not wise to mix freshrpms with livna. either use one or the other. I'll take a wild guess that you read something, and copied and pasted these entries into your repos and missed the [ when you copied them. still, we need to get it going. This time try
yum -disablerepo=freshrpms install yumex Take it one step at a time.

MintabiePete
14th September 2006, 12:52 AM
I managed to edit the freshness rpm file , but wont get ahead of myself , like you say 1 step at a time :) I will follow what you say , thanks

MintabiePete
14th September 2006, 12:55 AM
Password:
[root@localhost ~]# yum -disablerepo=freshrpms install yumex
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in ?
yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 80, in main
base.getOptionsConfig(args)
File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
self.doConfigSetup(fn=opts.conffile, root=root)
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 104, in doConfigSetup
self.getReposFromConfig()
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 135, in getReposFromConfig
parser.read(files)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 225, in read
IncludingConfigParser.read(self,filename)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 126, in read
ConfigParser.read(self,filename)
File "/usr/lib/python2.4/ConfigParser.py", line 267, in read
self._read(fp, filename)
File "/usr/lib/python2.4/ConfigParser.py", line 462, in _read
raise MissingSectionHeaderError(fpname, lineno, line)
ConfigParser.MissingSectionHeaderError: File contains no section headers.
file: ///etc/yum.repos.d/extras.repo, line: 1
'extras]\n'
[root@localhost ~]#

u-noneinc-s
14th September 2006, 01:04 AM
OK, You should start seeing the pattern here... file: ///etc/yum.repos.d/extras.repo, line: 1
'extras]\n'so do the same for extras. You should also decide which repo you want to use, freshrpms or livna, and go into the one you don't want and change enabled=1 to enabled=0. Personally I use both from time to time (not at the same time) and I have bothe disabled so when I want to use them I have to enable them (on the comman line or through yumex), but like I said, one at a time. And if you fixed freshrpms, just try
yum install yumex without the --disablerepo=freshrpms (or is that what you did after you fixed it?).

MintabiePete
14th September 2006, 01:14 AM
I just put the parenthesis that was missing , thats all

MintabiePete
14th September 2006, 01:22 AM
This is what I get
[peter@localhost ~]$ su -
Password:
[root@localhost ~]# yum install yumex
Repository livna-testing is listed more than once in the configuration
Setting up Install Process
Setting up repositories
livna-stable [1/19]
http://rpm.livna.org/fedora/5/i386/yum/stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Thu, 14 Sep 2006 00:17:22 GMT
Server: Apache/2.0.52 (CentOS)
Content-Length: 321
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: livna-stable
failure: repodata/repomd.xml from livna-stable: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from livna-stable: [Errno 256] No more mirrors to try.
[root@localhost ~]#

MintabiePete
14th September 2006, 01:25 AM
I think my add & remove is working , just cant find a server, seems to be no more errors and seems to be working when I click on add & remove software just seems the server is down :)

u-noneinc-s
14th September 2006, 01:33 AM
I don't know if this will work because I don't know where livna stable is coming from but it's good to see that the error has changed, so you're making progress. Try this. Look in /etc/yum.conf and if livna-stable is in there, set the enabled flag to 0. If it's not in there, try
yum --disablerepo=livna-stable install yumex,

u-noneinc-s
14th September 2006, 01:42 AM
I didn't see livna-stable in post #9, so if it's listed as /etc/yum.repos.d/livna-stable.repo, edit it and set enabed=0, and look in /etc/yum.conf and see if it's listed there too, and if it is, comment it out (put a # in front of it). You don't really need it, and I just noticed in your last post that it said it is listed twice.

MintabiePete
14th September 2006, 01:45 AM
Doesent seem to have an enabled section , but this is the file

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=fedora-release
tolerant=1
exactarch=0
# Added this because some mirrors go down and then retying takes forever.
retries=1

##################
## Basic Fedora ##
##################

[base]
name=Fedora Core $releasever - $basearch - Base
baseurl=ftp://linux.stanford.edu/pub/mirrors/fedora/linux/core/$releasever/$basearch/os
http://ftp.dulug.duke.edu/pub/fedora/linux/core/$releasever/$basearch/os
http://mirrors.kernel.org/fedora/core/$releasever/$basearch/os
# http://fedora.redhat.com/releases/fedora-core-$releasever
#gpgcheck=1

#[base-debuginfo]
#name=Fedora Core $releasever - $basearch - Debug Info
#baseurl=http://speakeasy.rpmfind.net/linux/fedora/core/$releasever/$basearch/debug
# ftp://linux.stanford.edu/pub/mirrors/fedora/linux/core/$releasever/$basearch/debug
# http://mirrors.kernel.org/fedora/core/$releasever/$basearch/os
##gpgcheck=1

[updates-released]
name=Fedora Core $releasever - $basearch - Released Updates
baseurl=http://mirrors.kernel.org/fedora/core/updates/$releasever/$basearch
ftp://linux.stanford.edu/pub/mirrors/fedora/linux/core/updates/$releasever/$basearch
http://speakeasy.rpmfind.net/linux/fedora/core/updates/$releasever/$basearch
http://ftp.dulug.duke.edu/pub/fedora/linux/core/updates/$releasever/$basearch
# http://fedora.redhat.com/updates/released/fedora-core-$releasever
#gpgcheck=1

#[updates-testing]
#name=Fedora Core $releasever - $basearch - Unreleased Updates
#baseurl=http://mirrors.kernel.org/fedora/core/updates/testing/$releasever/$basearch
# http://ftp.dulug.duke.edu/pub/fedora/linux/core/updates/testing/$releasever/$basearch
## http://fedora.redhat.com/updates/testing/fedora-core-$releasever
##gpgcheck=1

###################
## Fedora Extras ##
###################

[fedora-stable]
name=Fedora.us Extras (Stable)
baseurl=http://mirrors.kernel.org/fedora.us/fedora/fedora/$releasever/$basearch/yum/stable
http://fedora.quicknet.nl/fedora/fedora/$releasever/$basearch/yum/stable
http://download.fedora.us/fedora/fedora/$releasever/$basearch/yum/stable
#gpgcheck=1

[fedora-unstable]
name=Fedora.us Extras (Unstable)
baseurl=http://fedora.quicknet.nl/fedora/fedora/$releasever/$basearch/yum/unstable
http://mirrors.kernel.org/fedora.us/fedora/fedora/$releasever/$basearch/yum/unstable
http://download.fedora.us/fedora/fedora/$releasever/$basearch/yum/unstable
#gpgcheck=1

[fedora-testing]
name=Fedora.us Extras (Testing)
baseurl=http://download.fedora.us/fedora/fedora/$releasever/$basearch/yum/testing
http://mirrors.kernel.org/fedora.us/fedora/fedora/$releasever/$basearch/yum/testing
http://fedora.quicknet.nl/fedora/fedora/$releasever/$basearch/yum/testing
#gpgcheck=1

###############
## Livna.org ##
###############

[livna-stable]
name=Livna.org - Fedora Compatible Packages (stable)
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/yum/stable
#gpgcheck=1

[livna-unstable]
name=Livna.org - Fedora Compatible Packages (unstable)
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/yum/unstable
#gpgcheck=1

[livna-testing]
name=Livna.org - Fedora Compatible Packages (testing)
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/yum/testing
#gpgcheck=1


############
# Jpackage #
############

# JPackage is a GREAT repository for Java Software.
# However, you may have to compile some SRPMs to use it,
# so it's commented out by default. See
# <http://prdownloads.sourceforge.net/jpackage/direct_download/1.5/generic/SRPMS.non-free>
# For the SRPMs, and <http://www.jpackage.org> for the general details.
#
# Note: JPackage IS compatible with the fedora.us repositories.
# You can use JPackage and fedora.us at the same time, without
# any trouble.

#[jpackage-generic]
#name=JPackage Cross-Platform Packages
#baseurl=http://aleron.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/generic/free
# http://unc.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/generic/free
# http://umn.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/generic/free
##gpgcheck=1

#[jpackage-fedora]
#name=JPackage Fedora Packages
#baseurl=http://aleron.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/fedora-$releasever/free/
# http://unc.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/fedora-$releasever/free/
# http://umn.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/fedora-$releasever/free/
##gpgcheck=1

############################
## Alternate Repositories ##
############################

# Uncomment these to use them -- note that some packages
# from these repositories may conflict with the fedora.us
# packages. If you use these repositories, you may wish to
# comment-out the fedora.us and livna.org repositories.

#[freshrpms]
#name=FreshRPMs
#baseurl=http://ayo.freshrpms.net/fedora/linux/$releasever/$basearch/freshrpms/
# http://ftp.us2.freshrpms.net/linux/freshrpms/ayo/fedora/linux/$releasever/$basearch/freshrpms/
##gpgcheck=1

#[dag]
#name=Dag APT Repository
#baseurl=http://apt.sw.be/redhat/fc$releasever/en/$basearch/dag
##gpgcheck=1

#[newrpms]
#name=NewRPMs
#baseurl=http://newrpms.sunsite.dk/apt/redhat/en/$basearch/fc$releasever
##gpgcheck=1

#[atrpms-stable]
#name=ATrpms - Stable (Most Stable)
#baseurl=http://apt.physik.fu-berlin.de/fedora/fc$releasever/en/$basearch/at-stable
# http://ftp-stud.fht-esslingen.de/atrpms/fedora/fc$releasever/en/$basearch/at-stable
# http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/fc$releasever/en/$basearch/at-stable
##gpgcheck=1

#[atrpms-good]
#name=ATrpms - Good (2nd Most Stable)
#baseurl=http://ftp-stud.fht-esslingen.de/atrpms/fedora/fc$releasever/en/$basearch/at-good
# http://apt.physik.fu-berlin.de/fedora/fc$releasever/en/$basearch/at-good
# http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/fc$releasever/en/$basearch/at-good
##gpgcheck=1

#[atrpms-testing]
#name=ATrpms - Testing (3rd Most Stable)
#baseurl=http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/fc$releasever/en/$basearch/at-testing
# http://apt.physik.fu-berlin.de/fedora/fc$releasever/en/$basearch/at-testing
# http://ftp-stud.fht-esslingen.de/atrpms/fedora/fc$releasever/en/$basearch/at-testing
##gpgcheck=1

#[atrpms-bleeding]
#name=ATrpms - Bleeding (Least Stable)
#baseurl=http://apt.physik.fu-berlin.de/fedora/fc$releasever/en/$basearch/at-bleeding
# http://ftp-stud.fht-esslingen.de/atrpms/fedora/fc$releasever/en/$basearch/at-bleeding
# http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/fc$releasever/en/$basearch/at-bleeding
##gpgcheck=1

###################
## Miscellaneous ##
###################

[macromedia.mplug.org]
name=macromedia.mplug.org - Flash Plugin
baseurl=http://macromedia.mplug.org/apt/fedora/$releasever
http://sluglug.ucsc.edu/macromedia/apt/fedora/$releasever
http://ruslug.rutgers.edu/macromedia/apt/fedora/$releasever
http://macromedia.rediris.es/apt/fedora/$releasever
#gpgcheck=1

u-noneinc-s
14th September 2006, 01:57 AM
Make a copy of it and then comment out all of them all the way down the line. If it doesn't like that you can always uncomment them if you have a file to compare with. If it does like it, you can get rid of them. You don't need both in the yum.conf and the yum.repos.d. For sure, comment out the livna-stable. If it was me, I'd comment them all.

DO NOT COMMENT OUT THE TOP [main] section

MintabiePete
14th September 2006, 02:02 AM
I commented livna-stable out in /etc/yum.conf , ut can seem to find the other file to edit , this is what it tells me

[peter@localhost ~]$ su
Password:
[root@localhost peter]# gedit /etc/yum.repos.d/livna-stable.repo

(gedit:4766): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
[root@localhost peter]#

MintabiePete
14th September 2006, 02:10 AM
I have done this , is it correct ?
###############
## Livna.org ##
###############

#[livna-stable]
#name=Livna.org - Fedora Compatible Packages (stable)
#baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/#yum/stable
#gpgcheck=1

u-noneinc-s
14th September 2006, 02:18 AM
That's strange. I've never used gedit before. I am not the least bit familiar with it. Did you save the file before you tried to open /etc/yum.repos.d/livna-stable? did you check to make sure livna-stable is actually there? Not that any of that should have anything to do with authentication, Editing the yum.conf wouldn't do it either.
Try vi instead. It's not very user friendly. make sure you are still root. First cd /etc/yum.repos.d/and make sure livna-stable.repo exists. Then
vi livna-stable.repo. scroll down to the enabled = 1 line and press i key (to put you in insert mode) right arrow to the end of the line. ba ckspace to remove the 1 and type 0. press esc to exit insert mode. Type :wq! and press enterIt should say...
/etc/yum.repos.d/livna-stable.repo" 21L, 840C written (line numbers will vary).

u-noneinc-s
14th September 2006, 02:20 AM
I have done this , is it correct ?
###############
## Livna.org ##
###############

#[livna-stable]
#name=Livna.org - Fedora Compatible Packages (stable)
#baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/#yum/stable
#gpgcheck=1 Yes that looks good. Looks like I'm starting to run behind now ;)

Is this the yum.conf or the yum.repos.d?

u-noneinc-s
14th September 2006, 02:25 AM
To be honest, I think you should comment them all out. I don't think you need ANY "unstable" repos or testing repos, and the fedora repos are called core and updates not base and updates released (unless you are using an older release like FC3 or 4)

MintabiePete
14th September 2006, 02:32 AM
[peter@localhost ~]$ su -
Password:
[root@localhost ~]# cd /etc/yum.repos.d/
[root@localhost yum.repos.d]# livna-stable.repo
-bash: livna-stable.repo: command not found
[root@localhost yum.repos.d]#
I looked in /etc/yum.repos.d/ in the file system and can find livna.repo , livna-devel.repo and livna-testing.repo

MintabiePete
14th September 2006, 02:36 AM
I agree with you , I dont know how all those development repos got there in the first place . Is there a standard /etc/yum.repos. file that could replace everything ?

u-noneinc-s
14th September 2006, 02:38 AM
Did I make a typo (I do often), if I did, I meant to say
vi livna-stable.repo This is the command to opn vim editor with livna-stable.repo loaded.

MintabiePete
14th September 2006, 02:44 AM
This is what I get when I use that command

~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
"livna-stable.repo" [New File]

u-noneinc-s
14th September 2006, 02:50 AM
If you haven't :wq! yet, do just :q! instead. Don't forget esc key first. You can hit esc a couple times to be sure. It wont hurt. Then make sure you are in /etc/yum.repos.d and that livna-stable.repo exists in that dir. if so, do the same command again (vi livna-stable.repo) and by all means check my spelling if you are using copy/paste to do it.

MintabiePete
14th September 2006, 03:07 AM
When I go in and look this is all I find
I looked in /etc/yum.repos.d/ in the file system and can find livna.repo , livna-devel.repo and livna-testing.repo unless I am reading it ncorrectly You know I have had this problem for a while and have tried a few diffrent ways to repair it maybe I have deleted that file , will it work without it ?

u-noneinc-s
14th September 2006, 03:11 AM
Then commenting out the ones in /etc/yum.conf should be good enough. If you don't want to comment them all out, at least comment out all the linva ones in the yum.conf file (livna-unstable and livna-testing)

u-noneinc-s
14th September 2006, 03:14 AM
Don't worry about livna-devel and livna-testing in the yum.repos.d directory because they are probably disabled by default anyway.

MintabiePete
14th September 2006, 03:23 AM
This is what I have done
[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=fedora-release
tolerant=1
exactarch=0
# Added this because some mirrors go down and then retying takes forever.
retries=1

##################
## Basic Fedora ##
##################

[base]
name=Fedora Core $releasever - $basearch - Base
baseurl=ftp://linux.stanford.edu/pub/mirrors/fedora/linux/core/$releasever/$basearch/os
http://ftp.dulug.duke.edu/pub/fedora/linux/core/$releasever/$basearch/os
http://mirrors.kernel.org/fedora/core/$releasever/$basearch/os
# http://fedora.redhat.com/releases/fedora-core-$releasever
#gpgcheck=1

#[base-debuginfo]
#name=Fedora Core $releasever - $basearch - Debug Info
#baseurl=http://speakeasy.rpmfind.net/linux/fedora/core/$releasever/$basearch/debug
# ftp://linux.stanford.edu/pub/mirrors/fedora/linux/core/$releasever/$basearch/debug
# http://mirrors.kernel.org/fedora/core/$releasever/$basearch/os
##gpgcheck=1

[updates-released]
name=Fedora Core $releasever - $basearch - Released Updates
baseurl=http://mirrors.kernel.org/fedora/core/updates/$releasever/$basearch
ftp://linux.stanford.edu/pub/mirrors/fedora/linux/core/updates/$releasever/$basearch
http://speakeasy.rpmfind.net/linux/fedora/core/updates/$releasever/$basearch
http://ftp.dulug.duke.edu/pub/fedora/linux/core/updates/$releasever/$basearch
# http://fedora.redhat.com/updates/released/fedora-core-$releasever
#gpgcheck=1

#[updates-testing]
#name=Fedora Core $releasever - $basearch - Unreleased Updates
#baseurl=http://mirrors.kernel.org/fedora/core/updates/testing/$releasever/$basearch
# http://ftp.dulug.duke.edu/pub/fedora/linux/core/updates/testing/$releasever/$basearch
## http://fedora.redhat.com/updates/testing/fedora-core-$releasever
##gpgcheck=1

###################
## Fedora Extras ##
###################

[fedora-stable]
name=Fedora.us Extras (Stable)
baseurl=http://mirrors.kernel.org/fedora.us/fedora/fedora/$releasever/$basearch/yum/stable
http://fedora.quicknet.nl/fedora/fedora/$releasever/$basearch/yum/stable
http://download.fedora.us/fedora/fedora/$releasever/$basearch/yum/stable
#gpgcheck=1

[fedora-unstable]
name=Fedora.us Extras (Unstable)
baseurl=http://fedora.quicknet.nl/fedora/fedora/$releasever/$basearch/yum/unstable
http://mirrors.kernel.org/fedora.us/fedora/fedora/$releasever/$basearch/yum/unstable
http://download.fedora.us/fedora/fedora/$releasever/$basearch/yum/unstable
#gpgcheck=1

[fedora-testing]
name=Fedora.us Extras (Testing)
baseurl=http://download.fedora.us/fedora/fedora/$releasever/$basearch/yum/testing
http://mirrors.kernel.org/fedora.us/fedora/fedora/$releasever/$basearch/yum/testing
http://fedora.quicknet.nl/fedora/fedora/$releasever/$basearch/yum/testing
#gpgcheck=1

###############
## Livna.org ##
###############

#[livna-stable]
#name=Livna.org - Fedora Compatible Packages (stable)
#baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/yum/stable
#gpgcheck=1

#[livna-unstable]
#name=Livna.org - Fedora Compatible Packages (unstable)
#baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/yum/unstable
#gpgcheck=1

#[livna-testing]
#name=Livna.org - Fedora Compatible Packages (testing)
#baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/yum/testing
#gpgcheck=1


############
# Jpackage #
############

# JPackage is a GREAT repository for Java Software.
# However, you may have to compile some SRPMs to use it,
# so it's commented out by default. See
# <http://prdownloads.sourceforge.net/jpackage/direct_download/1.5/generic/SRPMS.non-free>
# For the SRPMs, and <http://www.jpackage.org> for the general details.
#
# Note: JPackage IS compatible with the fedora.us repositories.
# You can use JPackage and fedora.us at the same time, without
# any trouble.

#[jpackage-generic]
#name=JPackage Cross-Platform Packages
#baseurl=http://aleron.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/generic/free
# http://unc.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/generic/free
# http://umn.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/generic/free
##gpgcheck=1

#[jpackage-fedora]
#name=JPackage Fedora Packages
#baseurl=http://aleron.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/fedora-$releasever/free/
# http://unc.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/fedora-$releasever/free/
# http://umn.dl.sourceforge.net/sourceforge/jpackage/direct_download/1.5/fedora-$releasever/free/
##gpgcheck=1

############################
## Alternate Repositories ##
############################

# Uncomment these to use them -- note that some packages
# from these repositories may conflict with the fedora.us
# packages. If you use these repositories, you may wish to
# comment-out the fedora.us and livna.org repositories.

#[freshrpms]
#name=FreshRPMs
#baseurl=http://ayo.freshrpms.net/fedora/linux/$releasever/$basearch/freshrpms/
# http://ftp.us2.freshrpms.net/linux/freshrpms/ayo/fedora/linux/$releasever/$basearch/freshrpms/
##gpgcheck=1

#[dag]
#name=Dag APT Repository
#baseurl=http://apt.sw.be/redhat/fc$releasever/en/$basearch/dag
##gpgcheck=1

#[newrpms]
#name=NewRPMs
#baseurl=http://newrpms.sunsite.dk/apt/redhat/en/$basearch/fc$releasever
##gpgcheck=1

#[atrpms-stable]
#name=ATrpms - Stable (Most Stable)
#baseurl=http://apt.physik.fu-berlin.de/fedora/fc$releasever/en/$basearch/at-stable
# http://ftp-stud.fht-esslingen.de/atrpms/fedora/fc$releasever/en/$basearch/at-stable
# http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/fc$releasever/en/$basearch/at-stable
##gpgcheck=1

#[atrpms-good]
#name=ATrpms - Good (2nd Most Stable)
#baseurl=http://ftp-stud.fht-esslingen.de/atrpms/fedora/fc$releasever/en/$basearch/at-good
# http://apt.physik.fu-berlin.de/fedora/fc$releasever/en/$basearch/at-good
# http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/fc$releasever/en/$basearch/at-good
##gpgcheck=1

#[atrpms-testing]
#name=ATrpms - Testing (3rd Most Stable)
#baseurl=http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/fc$releasever/en/$basearch/at-testing
# http://apt.physik.fu-berlin.de/fedora/fc$releasever/en/$basearch/at-testing
# http://ftp-stud.fht-esslingen.de/atrpms/fedora/fc$releasever/en/$basearch/at-testing
##gpgcheck=1

#[atrpms-bleeding]
#name=ATrpms - Bleeding (Least Stable)
#baseurl=http://apt.physik.fu-berlin.de/fedora/fc$releasever/en/$basearch/at-bleeding
# http://ftp-stud.fht-esslingen.de/atrpms/fedora/fc$releasever/en/$basearch/at-bleeding
# http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/fc$releasever/en/$basearch/at-bleeding
##gpgcheck=1

###################
## Miscellaneous ##
###################

[macromedia.mplug.org]
name=macromedia.mplug.org - Flash Plugin
baseurl=http://macromedia.mplug.org/apt/fedora/$releasever
http://sluglug.ucsc.edu/macromedia/apt/fedora/$releasever
http://ruslug.rutgers.edu/macromedia/apt/fedora/$releasever
http://macromedia.rediris.es/apt/fedora/$releasever
#gpgcheck=1

MintabiePete
14th September 2006, 03:29 AM
It seems to be working when I click on add & Remove softare , but after a while I get an error saying that the server my be down . I will try again later . Thanks very much for the patience in helping me out and it has helped me get an even better understanding of linux . Keeping it in the head is another thing :)

u-noneinc-s
14th September 2006, 03:35 AM
Post back if you still have problems, and be careful with those testing and devel repos. yumex is a good tool. It's graphical, and you can enable and disable repos with a click, and you can see everything available (update/install/remove) at a glance. Good FC'ing

MintabiePete
14th September 2006, 06:24 AM
This the error I am getting trying to update , and I am definately online :)
http://img.photobucket.com/albums/v116/MintabiePete/Screenshot-1.png

u-noneinc-s
14th September 2006, 07:13 PM
I don't use add/remove. I use yum and yumex and occasionally smart. Yum and yumex will print out problems whereas add/remove only gives non-specific errors.
Again, try yum and post the output # yum update

Finalzone
14th September 2006, 07:55 PM
The mirror server is down which explain the errors.

u-noneinc-s
14th September 2006, 08:05 PM
The mirror server is down which explain the errors. Which mirror? I just ran updates and succeeded with repos loading (Fedora only - no updates available for me)

Finalzone
14th September 2006, 08:07 PM
Test one of url listed on the yum.conf submitted on this post (http://forums.fedoraforum.org/showpost.php?p=609342&postcount=39).

u-noneinc-s
14th September 2006, 09:58 PM
I found one that didn't work. These are all listed in his yum.conf, but he also has a yum.repos.d, so I recomended that he comment out all of the repos in the yum.conf.

MintabiePete: you never did say which release you were using. May not matter anyway, the mirrors all seem to list all the releases anyway.

Post the results of cat /etc/yum.repos.d/*

MintabiePete
15th September 2006, 12:50 AM
This is yum apdate :

Password:
[root@localhost peter]# yum update
Setting up Update Process
Setting up repositories
livna [1/16]
livna 100% |=========================| 951 B 00:00
updates-released [2/16]
updates-released 100% |=========================| 1.2 kB 00:00
fedora-testing [3/16]
http://mirrors.kernel.org/fedora.us/fedora/fedora/5/i386/yum/testing/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Thu, 14 Sep 2006 23:48:42 GMT
Server: Apache/2.2.2 (Fedora)
Content-Length: 260
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
http://fedora.quicknet.nl/fedora/fedora/5/i386/yum/testing/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Thu, 14 Sep 2006 23:56:00 GMT
Server: Apache/2.0.53 (Fedora)
Content-Length: 334
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
http://download.fedora.us/fedora/fedora/5/i386/yum/testing/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
Cannot open/read repomd.xml file for repository: fedora-testing
failure: repodata/repomd.xml from fedora-testing: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from fedora-testing: [Errno 256] No more mirrors to try.

MintabiePete
15th September 2006, 12:52 AM
and this is the version:
[peter@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 athlon i386 GNU/Linux
[peter@localhost ~]$

u-noneinc-s
15th September 2006, 01:03 AM
OK, if you take the first (error) line and copy the bedinning (http://mirrors.kernel.org/fedora.us) and paste that in a browser you get
Index of /fedora.us/fedora

Icon Name Last modified Size [DIR] Parent Directory -
[DIR] fedora/ 09-Nov-2004 20:48 -
[DIR] redhat/ 23-Jan-2004 23:28 -
[DIR] rss/ 26-Mar-2005 14:52 - If you click on Fedora you get 1 2 1nd 3 so this is a very old mirror and it came from your yum.conf, so I would comment out all those repos in the yum.conf and it should work.. If you eliminate them and it works fine, you can remove them (or leave them, It won't matter as long as they are commented out).
If it doesn't work, post the new error and the contents of yum.repos.d
cat /etc/yum.repos.d/*

MintabiePete
15th September 2006, 01:03 AM
It tells me that the results of cat /etc/yum.repos.d/* are too long and that I have to shorten them

MintabiePete
15th September 2006, 01:05 AM
I recomended that he comment out all of the repos in the yum.conf.
I tried that , but I couldnt seem to get add & remove to work and got errors so reverted back

u-noneinc-s
15th September 2006, 01:10 AM
I recomended that he comment out all of the repos in the yum.conf.
I tried that , but I couldnt seem to get add & remove to work and got errors so reverted back
Did you comment out the top section as well [main]? That section must remain. comment repos only

MintabiePete
15th September 2006, 01:17 AM
commented out first prt of fedora basic and get this error in add & remove
Component: Software Manager
Summary: TBdef7d2ae config.py:92:__set__:ValueError: Error parsing 'retries': invalid integer value

Traceback (most recent call last):
File "/usr/sbin/pirut", line 390, in ?
main()
File "/usr/sbin/pirut", line 383, in main
pm = PackageManager(options.config)
File "/usr/sbin/pirut", line 57, in __init__
GraphicalYumBase.__init__(self, False, config)
File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
self.doConfigSetup(configfn)
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in doConfigSetup
self.conf = config.readMainConfig(fn, root)
File "/usr/lib/python2.4/site-packages/yum/config.py", line 595, in readMainConfig
yumconf.populate(confparser, 'main')
File "/usr/lib/python2.4/site-packages/yum/config.py", line 407, in populate
setattr(self, name, value)
File "/usr/lib/python2.4/site-packages/yum/config.py", line 92, in __set__
raise ValueError('Error parsing %r: %s' % (optdata.name,
ValueError: Error parsing 'retries': invalid integer value

Local variables in innermost frame:
optdata: <yum.config.OptionData object at 0xb79c1dec>
self: <yum.config.IntOption object at 0xb7a7e68c>
e: invalid integer value
obj: [main]
alwaysprompt: True
assumeyes: False
bandwidth: 0
cachedir: '/var/cache/yum'
commands: []
debuglevel: 2
diskspacecheck: True
distroverpkg: 'fedora-release'
enable_group_conditionals: True
enabled: True
enablegroups: True
errorlevel: 2
exactarch: False
exactarchlist: ['kernel', 'kernel-smp', 'glibc', 'kernel-hugemem', 'kernel-enterprise', 'kernel-bigmem', 'kernel-devel']
exclude: []
failovermethod: 'roundrobin'
gpgcheck: False
http_caching: 'all'
installonlypkgs: ['kernel', 'kernel-bigmem', 'kernel-enterprise', 'kernel-smp', 'kernel-modules', 'kernel-debug', 'kernel-unsupported', 'kernel-source', 'kernel-devel']
installroot: '/'
keepalive: True
keepcache: True
kernelpkgnames: ['kernel', 'kernel-smp', 'kernel-enterprise', 'kernel-bigmem', 'kernel-BOOT']
logfile: '/var/log/yum.log'
metadata_expire: 1800
obsoletes: False
overwrite_groups: False
pluginpath: ['/usr/lib/yum-plugins']
plugins: False
proxy: None
proxy_password: None
proxy_username: None
recent: 7
reposdir: ['/etc/yum/repos.d', '/etc/yum.repos.d']
retries: 10
showdupesfromrepos: False
syslog_facility: 'LOG_DAEMON'
syslog_ident: None
throttle: 0
timeout: 30.0
tolerant: True
tsflags: []
yumversion: 'unversioned'
value: 1
# http://ftp.dulug.duke.edu/pub/fedora/linux/core/5/i386/os
#http://mirrors.kernel.org/fedora/core/5/i386/os

u-noneinc-s
15th September 2006, 01:18 AM
cat /etc/yum.repos.d/* > ~/repos
cd ~
gzip repos attach repos.gz

MintabiePete
15th September 2006, 01:21 AM
I go back to
[base]
name=Fedora Core $releasever - $basearch - Base
baseurl=ftp://linux.stanford.edu/pub/mirrors/fedora/linux/core/$releasever/$basearch/os
http://ftp.dulug.duke.edu/pub/fedora/linux/core/$releasever/$basearch/os
http://mirrors.kernel.org/fedora/core/$releasever/$basearch/os
# http://fedora.redhat.com/releases/fedora-core-$releasever
#gpgcheck=1
and it works

u-noneinc-s
15th September 2006, 01:25 AM
Lets try this.
mv /etc/yum.conf /etc/yum.conf.old create a new /etc/yum.conf (use vim or gedit whatever your comfortable with. (replace vi with the editor you choose)
vi /etc/yum.conf and copy/paste this
[main]
cachedir=/var/cache/yum
keepCACHE=0
debuglevel=2
exclude =
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
Add a carriage return to the end (so there is a blank line at the bottom) Save and exit

Double check and make sure everything is there.

u-noneinc-s
15th September 2006, 01:31 AM
Is it loading all the repos or just the core

MintabiePete
15th September 2006, 01:31 AM
this is what it asked me do I overrite it or not ?
I did
[peter@localhost ~]$ su
Password:
[root@localhost peter]# cat /etc/yum.repos.d/* > ~/repos
[root@localhost peter]# cd ~
[root@localhost ~]# gzip repos
gzip: repos.gz already exists; do you wish to overwrite (y or n)?

u-noneinc-s
15th September 2006, 01:36 AM
I'd say no. Just look and see if repos.gz is there and if it is, go ahead and attach It.

MintabiePete
15th September 2006, 01:38 AM
peter@localhost ~]$ su
Password:
[root@localhost peter]# mv /etc/yum.conf /etc/yum.conf.old
mv: cannot stat `/etc/yum.conf': No such file or directory
[root@localhost peter]#

MintabiePete
15th September 2006, 01:44 AM
I tried that mv /etc/yum.conf /etc/yum.conf.old first and I am sure it worked but now I am getting that error that it cant find it

I better slow down , although I cant help but think when I answered yes I should have answered no and mucked everything up

u-noneinc-s
15th September 2006, 01:45 AM
Try
whereis yum It couldn't just disappear. :eek: You just got though editing it. :rolleyes:

MintabiePete
15th September 2006, 01:49 AM
gzip: repos.gz already exists; do you wish to overwrite (y or n)? n
not overwritten
[root@localhost ~]# whereis yum
yum: /usr/bin/yum /etc/yum.conf~ /etc/yum.config /etc/yum.conf2~ /etc/yum /etc/yum.conf2 /usr/share/man/man8/yum.8.gz
[root@localhost ~]#

u-noneinc-s
15th September 2006, 01:50 AM
OK if you did moved yum.conf to yum.conf.old, and you're sure it worked, there will be no yum.conf. That's why you have to create one with vim or gedit.
Lets make sure yum.conf.old is there.
I better slow down , although I cant help but think when I answered yes I should have answered no and mucked everything up If you are referring to the gzip, no that wouldn't hurt anything.

MintabiePete
15th September 2006, 01:55 AM
when I try to gedit /etc/yum.conf
I get an empty folder
also when I use vi /etc/yum.conf
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
"/etc/yum.conf" [New File]

So I must have done something wrong it appears

MintabiePete
15th September 2006, 01:58 AM
I am getting an error message when I try to start add & remove
config error
No such config file /etc/yum.conf

so looks like I did lose it :)

no it is there as yum.conf. old

How ever did that happen ?

u-noneinc-s
15th September 2006, 02:07 AM
We are getting ahead of each other. You have 3 backups of yum.conf but no working yum.conf. Whenever you edit a file, it leaves a backup with the ~ character. The /etc/yum.conf.old may be in another dir like your home or the dir you were working from when you ran the command. You can probably trace it with the historycommand. The bash shell keeps track of the command you ran and history will print out a list. I would guess one of the ~'s is your origional from yesterday before you commented out the livna repos. lets not worry about that or gzip or anything else yet. Just to be safe,
mv /etc/yum.conf~ etc/yum.conf.old IF YUM.CONF.OLD IS THERE SOMEWHERE, FORGET THIS STEP Like I said we are getting ahead of each other ;)

then create a new yum.conf use vi and follow
vi /etc/yum.conf this should open a blank file type i (for insert mode copy and paste this
[main]
cachedir=/var/cache/yum
keepCACHE=0
debuglevel=2
exclude =
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d Make sure the cursor is at the bottom behind repos.d and press enter this will leave a blank line at the bottom. Hit esc key a couple of times type
:wq and hit enter

If you think you may have made a mistake instead of :wq type :q! to quit without writing

If you are not comfortable with this, just say so. I'm not familliar with gedit, but that should work.

MintabiePete
15th September 2006, 02:12 AM
Ok I got it back , copied it to /etc/yum.conf from /etc/yum.conf.old

MintabiePete
15th September 2006, 02:14 AM
I copied this back as I said , what do you want me to do ? , follow post #68 ?

u-noneinc-s
15th September 2006, 02:23 AM
What I'm trying to do is get you a new yum.conf, but I didn't want to lose the old one. When you "mv" a file to file.old, the origional is no longer there. thats why you got a blank file when you did gedit /etc/yum.conf. You were supposed to get an empty file. Do you now have yum.conf AND yum.conf.old?. If yes, then do like you did before with
gedit /etc/yum.conf and delete everything in the file, paste in what I gave you, add the blank line at the bottom and save. If you don't have yum.conf.old, copy or move /etc/yum.conf /etc/yum.conf.old and then continue on with these instructions.

MintabiePete
15th September 2006, 02:31 AM
OkI have done everything in post#68 I have stuck with gedit as I am used to that , and thanks for having patience :)

MintabiePete
15th September 2006, 02:33 AM
I am getting this error when I start add & remove software
Component: Software Manager
Summary: TB4426d5a1 ConfigParser.py:490:_read:ParsingError: File contains parsing errors: /etc/yum.conf
[line 17]: ':wq\n'

Traceback (most recent call last):
File "/usr/sbin/pirut", line 390, in ?
main()
File "/usr/sbin/pirut", line 383, in main
pm = PackageManager(options.config)
File "/usr/sbin/pirut", line 57, in __init__
GraphicalYumBase.__init__(self, False, config)
File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
self.doConfigSetup(configfn)
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in doConfigSetup
self.conf = config.readMainConfig(fn, root)
File "/usr/lib/python2.4/site-packages/yum/config.py", line 582, in readMainConfig
confparser.read(configfile)
File "/usr/lib/python2.4/site-packages/yum/parser.py", line 126, in read
ConfigParser.read(self,filename)
File "/usr/lib/python2.4/ConfigParser.py", line 267, in read
self._read(fp, filename)
File "/usr/lib/python2.4/ConfigParser.py", line 490, in _read
raise e
ParsingError: File contains parsing errors: /etc/yum.conf
[line 17]: ':wq\n'

Local variables in innermost frame:
sectname: main
cursect: {'metadata_expire': '1800', 'debuglevel': '2', 'tolerant': '1', 'keepcache': '0', 'cachedir': '/var/cache/yum', 'exactarch': '1', 'pkgpolicy': 'newest', 'distroverpkg': 'redhat-release', '__name__': 'main', 'gpgcheck': '1', 'exclude': '', 'logfile': '/var/log/yum.log', 'plugins': '1', 'obsoletes': '1'}
e: File contains parsing errors: /etc/yum.conf
[line 17]: ':wq\n'
fpname: /etc/yum.conf
vi: =
mo: None
optname: metadata_expire
fp: <open file '/etc/yum.conf', mode 'r' at 0xb7a08650>
lineno: 23
line:
self: <yum.parser.IncludingConfigParser instance at 0xb79984cc>
optval: 1800

u-noneinc-s
15th September 2006, 02:34 AM
Give it a try. It should work if your repos.d is ok. If it doesn't work, you know the drill. post the error and attach the repos.gz (if you click advanced and look just below this window you'll see a "manage atachments " button).

u-noneinc-s
15th September 2006, 02:40 AM
I am getting this error when I start add & remove software
Component: Software Manager
Summary: TB4426d5a1 ConfigParser.py:490:_read:ParsingError: File contains parsing errors: /etc/yum.conf
[line 17]: ':wq\n'
This one should be easy. I gave instructions for vi, and you used gedit. I should have edited my instructions accordingly. gedit the file again and remove :wq from the bottom. (Thats the vi command to save or "wrote and quit")

MintabiePete
15th September 2006, 02:56 AM
Yes that brought it back to normal , but when I run add& remove I still get that "Unable to retrieve software information. This could be caused by not having a network connection available." But not to worry , I will sort it out by trial & error eventually , even if i do a re install I havnt got that much on this computer as I have only been trying Fedora 5 , but i like it and will stay with it and the great support I have got from you forum members :)

u-noneinc-s
15th September 2006, 03:02 AM
Give yum one more try and post the error (a little more to work with). Or, I can give you my repos.d as well if you like.

MintabiePete
15th September 2006, 03:43 AM
I thank you for that offer, that would most likely be the best I think , anyway I will post that error , I am on another computer at the moment :) I will get back to you

MintabiePete
15th September 2006, 03:48 AM
The error is the same as back in post#42 that I posted a jpeg of

u-noneinc-s
15th September 2006, 03:54 AM
Is this (latest) error from the add/remove software app or did you try yum again and got the same error?

MintabiePete
15th September 2006, 03:56 AM
s this (latest) error from the add/remove software app Yes it is
did you try yum again and got the same error? no I havnt tried that I will go back & get command & try it & post

MintabiePete
15th September 2006, 04:00 AM
This is what I get when I yum update
[peter@localhost ~]$ su
Password:
[root@localhost peter]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/10]
flash [2/10]
dag [3/10]
http://apt.sw.be/fedora/5/en/i386/dag/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 15 Sep 2006 02:57:48 GMT
Server: Apache/2.2.2 (Unix)
Content-Length: 310
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: dag
failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
[root@localhost peter]#

MintabiePete
15th September 2006, 04:04 AM
this is what I get when I yum
Password:
[root@localhost peter]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/10]
flash [2/10]
dag [3/10]
http://apt.sw.be/fedora/5/en/i386/dag/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 15 Sep 2006 02:57:48 GMT
Server: Apache/2.2.2 (Unix)
Content-Length: 310
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: dag
failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
[root@localhost peter]# yum
Loading "installonlyn" plugin
You need to give some command

usage: yum [options] < update | install | info | remove | list |
clean | provides | search | check-update | groupinstall |
groupupdate | grouplist | groupinfo | groupremove |
makecache | localinstall | erase | upgrade | whatprovides |
localupdate | resolvedep | shell | deplist >

options:
-h, --help show this help message and exit
-t, --tolerant be tolerant of errors
-C run entirely from cache, don't update cache
-c [config file] config file location
-R [minutes] maximum command wait time
-d [debug level] debugging output level
-e [error level] error output level
-y answer yes for all questions
--version show Yum version and exit
--installroot=[path] set install root
--enablerepo=[repo] enable one or more repositories (wildcards allowed)
--disablerepo=[repo] disable one or more repositories (wildcards allowed)
--exclude=[package] exclude package(s) by name or glob
--obsoletes enable obsoletes processing during updates
--noplugins disable Yum plugins
[root@localhost peter]#

MintabiePete
15th September 2006, 04:06 AM
actually it is this when I yum
Password:
[root@localhost peter]# yum
Loading "installonlyn" plugin
You need to give some command

usage: yum [options] < update | install | info | remove | list |
clean | provides | search | check-update | groupinstall |
groupupdate | grouplist | groupinfo | groupremove |
makecache | localinstall | erase | upgrade | whatprovides |
localupdate | resolvedep | shell | deplist >

options:
-h, --help show this help message and exit
-t, --tolerant be tolerant of errors
-C run entirely from cache, don't update cache
-c [config file] config file location
-R [minutes] maximum command wait time
-d [debug level] debugging output level
-e [error level] error output level
-y answer yes for all questions
--version show Yum version and exit
--installroot=[path] set install root
--enablerepo=[repo] enable one or more repositories (wildcards allowed)
--disablerepo=[repo] disable one or more repositories (wildcards allowed)
--exclude=[package] exclude package(s) by name or glob
--obsoletes enable obsoletes processing during updates
--noplugins disable Yum plugins
[root@localhost peter]#

u-noneinc-s
15th September 2006, 04:10 AM
Yum is working OK, It loaded livna and flash but died on dag. Dag no longer exists, so you can get rid of it (of for now do the)
yum --disablerepo-dag update. I don't know how many repos you have in there, and how many may be obsolete. I'll send mine when I get a chance, but if you disable all the problem repos, I know it will work. Unfortunately, I don't know how to disable them for add/remove except for editing the repo files and setting disabled=0.

MintabiePete
15th September 2006, 04:24 AM
this is what happens
[peter@localhost ~]$ su
Password:
[root@localhost peter]# yum --disablerepo-dag update
Loading "installonlyn" plugin
usage: yum [options] < update | install | info | remove | list |
clean | provides | search | check-update | groupinstall |
groupupdate | grouplist | groupinfo | groupremove |
makecache | localinstall | erase | upgrade | whatprovides |
localupdate | resolvedep | shell | deplist >

Command line error: no such option: --disablerepo-dag
[root@localhost peter]#

MintabiePete
15th September 2006, 04:28 AM
I am still getting that error from package manager
"Unable to retrieve software information. This could be caused by not having a network connection available."
but as long as I can download updates with yum that wont particulary worry me , I was just thinking that if it was there it should work and it would be handy , maybe I have to get used to commands instead of the point & click

I will try a yum update

MintabiePete
15th September 2006, 04:29 AM
this is what I get from yum update
Password:
[root@localhost peter]# yum --disablerepo-dag update
Loading "installonlyn" plugin
usage: yum [options] < update | install | info | remove | list |
clean | provides | search | check-update | groupinstall |
groupupdate | grouplist | groupinfo | groupremove |
makecache | localinstall | erase | upgrade | whatprovides |
localupdate | resolvedep | shell | deplist >

Command line error: no such option: --disablerepo-dag
[root@localhost peter]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/10]
flash [2/10]
dag [3/10]
http://apt.sw.be/fedora/5/en/i386/dag/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 15 Sep 2006 03:28:20 GMT
Server: Apache/2.2.2 (Unix)
Content-Length: 310
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: dag
failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
[root@localhost peter]#

u-noneinc-s
15th September 2006, 04:32 AM
Yum is only part of the command. It calls or runs the app yum, but you also have to tell it what to do when it is called or ran. so It's always going to be yum update or yum install packagename or yum list or yum grouplist etc. So, run
yum --disablerepo=dag update
I'll send my repos shortly

u-noneinc-s
15th September 2006, 04:41 AM
this is what I get from yum update
Password:
[root@localhost peter]# yum --disablerepo-dag update
Loading "installonlyn" plugin
usage: yum [options] < update | install | info | remove | list |
clean | provides | search | check-update | groupinstall |
groupupdate | grouplist | groupinfo | groupremove |
makecache | localinstall | erase | upgrade | whatprovides |
localupdate | resolvedep | shell | deplist >

Command line error: no such option: --disablerepo-dag
[root@localhost peter]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/10]
flash [2/10]
dag [3/10]
http://apt.sw.be/fedora/5/en/i386/dag/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 15 Sep 2006 03:28:20 GMT
Server: Apache/2.2.2 (Unix)
Content-Length: 310
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: dag
failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
[root@localhost peter]#
My fault again, sorry, it's
yum --disablerepo=dag update update Like I said, I make typos. I hate typos, I double check, and still they happen.

MintabiePete
15th September 2006, 04:44 AM
okay this is what I get now
Password:
[root@localhost peter]# yum --disablerepo=dag update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/9]
flash [2/9]
jpackage-fedora [3/9]
jpackage-fedora 100% |=========================| 951 B 00:00
core [4/9]
core 100% |=========================| 1.1 kB 00:00
freshrpms [5/9]
freshrpms 100% |=========================| 951 B 00:00
jpackage-generic [6/9]
jpackage-generic 100% |=========================| 951 B 00:00
extras [7/9]
extras 100% |=========================| 414 B 00:00
http://mirror.clarkson.edu/pub/distributions/fedora/linux/extras/5/i386/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for extras: Error: other unknown root element html
Trying other mirror.
extras 100% |=========================| 1.1 kB 00:00
atrpms-stable [8/9]
http://apt.atrpms.net/fedora/5/en/i386/at-stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 15 Sep 2006 03:43:42 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 324
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms-stable
failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
[root@localhost peter]#

MintabiePete
15th September 2006, 04:46 AM
this is what I get when I run yum
Password:
[root@localhost peter]# yum
Loading "installonlyn" plugin
You need to give some command

usage: yum [options] < update | install | info | remove | list |
clean | provides | search | check-update | groupinstall |
groupupdate | grouplist | groupinfo | groupremove |
makecache | localinstall | erase | upgrade | whatprovides |
localupdate | resolvedep | shell | deplist >

options:
-h, --help show this help message and exit
-t, --tolerant be tolerant of errors
-C run entirely from cache, don't update cache
-c [config file] config file location
-R [minutes] maximum command wait time
-d [debug level] debugging output level
-e [error level] error output level
-y answer yes for all questions
--version show Yum version and exit
--installroot=[path] set install root
--enablerepo=[repo] enable one or more repositories (wildcards allowed)
--disablerepo=[repo] disable one or more repositories (wildcards allowed)
--exclude=[package] exclude package(s) by name or glob
--obsoletes enable obsoletes processing during updates
--noplugins disable Yum plugins
[root@localhost peter]#

MintabiePete
15th September 2006, 04:48 AM
And this is what I get when I run yum update , seems dag is still giving problems
[peter@localhost ~]$ su
Password:
[root@localhost peter]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/10]
flash [2/10]
dag [3/10]
http://apt.sw.be/fedora/5/en/i386/dag/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 15 Sep 2006 03:46:39 GMT
Server: Apache/2.2.2 (Unix)
Content-Length: 310
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: dag
failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
[root@localhost peter]#

I can find dag.repo but it is in yum.repos.d but I cant see anything to edit or comment out

MintabiePete
15th September 2006, 05:02 AM
I tried to comment all of this but it just gives errors

[dag]
name=RPMForge: Dag
baseurl=http://apt.sw.be/fedora/$releasever/en/$basearch/dag
#http://rh-mirror.linux.iastate.edu/pub/dag/fedora/$releasever/en/$basearch/dag
#http://ftp.heanet.ie/pub/freshrpms/pub/dag/fedora/$releasever/en/$basearch/dag
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY.dag.txt
enabled=0
[dag]
name=Dag
baseurl=http://apt.sw.be/fedora/$releasever/en/$basearch/dag/
enabled=1
gpgcheck=1

MintabiePete
15th September 2006, 05:07 AM
ok seemed to get rid of dag changing enabled from 1 to 0
this is what happens if I run yum update now
Password:
[root@localhost peter]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/9]
flash [2/9]
jpackage-fedora [3/9]
core [4/9]
freshrpms [5/9]
jpackage-generic [6/9]
extras [7/9]
atrpms-stable [8/9]
http://apt.atrpms.net/fedora/5/en/i386/at-stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 15 Sep 2006 04:05:35 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 324
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms-stable
failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
[root@localhost peter]#

u-noneinc-s
15th September 2006, 05:18 AM
Here we go. (Please check for typos)
Move your repos.d dir
mv /etc/yum.repos.d /etc/yum.repos.d.old (now you will not have a repos.d but don't worry) make a directory in your home (call it anything you want) and copy my yum.repos.d.tar.bz2 there. cd to that dir and unpack my repos with
tar jxvf yum.repos.d.tar.bz2. now move my repos.d to /etc
mv yum.repos.d /etc
Yum should work, add/remove should work. yum install yumex will give you a nice graphical interface for yum (I like it and it's pretty configurable.
Your dag repo had 2 dag entries in it one disabled and one enabled. your repos are probably left over from FC3 (or mistakenly installed, as was your yum.conf. .
I hope this works

u-noneinc-s
15th September 2006, 05:28 AM
GET RID OF ATRPMS. I never use atrpms, and if I did I would never use it for updates.
It could cause you a lot of trouble (as if you haven't already had your fill). At least disable it, but do it now, do it before you do an update.

MintabiePete
15th September 2006, 05:48 AM
I disabled ATRPMS by setting the value to 0 from 1 and have run a yum update and it seems to be working , it is downloading updates for 28 packages , so I am sending this from another computer .
I havnt done anything about replacing mine with yours yet , just waiting to see how it goes :)

I WILL change mine for yours , just want to see how this is going :)

u-noneinc-s
15th September 2006, 05:55 AM
Hey, that's great. If it's working, just hang on to mine in case you need it later. You probably won't need it, (but with all the old repos and the duplicates, you never know).
Add/remove programs should work too. I just started it up on mine and didn't see any update or upgrade options, just install or remove.

Just curious, did you upgrade this from FC3 or what? Where did all the repos come from?

MintabiePete
15th September 2006, 06:11 AM
No I never upgraded , first time I have put it on , I downloaded & burnt it to a dvd Fedora 5 Bordeau , but early in the game I started getting errors with yum and started playing around with it to the extent I completly b****ed it up , so noticed someone else having problems , and they were talking about swapping files , so thats most likely how I wound up with a lot more than I need , I swapped someone else's with all the repos to get it working , but it never did . Until this episode , now it is working , and I have learnyt a lot from it .

MintabiePete
15th September 2006, 06:17 AM
And package manager is working , when I click on add & remove after everything updated , so it looks like everything is OK . althoughj I will save that one of yours and keep it for a rainy day . Do you think I should keep it the way it is now , or use yours ?
And also thanks for your excellent step by step help and your patience :)

u-noneinc-s
15th September 2006, 06:32 AM
I don't know what you have besides these
ivna [1/9]
flash [2/9]
jpackage-fedora [3/9]
core [4/9]
freshrpms [5/9]
jpackage-generic [6/9]
extras [7/9]
atrpms-stable [8/9] , but I see You have core and extras so if you have updates too, that's fine. but I would recommend disableing either freshrpms or livna. Since you haven't really used either one yet, it doesn't matter much which you disable. (If any of tonights updates came from livna or freshrpms, stick with that one. there wil be a lvn or rf in the filename.
For updates, I only use core exras and updates. Everything else is disabled untill I want to check them.
some useful sites
http://stanton-finley.net/fedora_core_5_installation_notes.html (pay particular attention to this part (http://stanton-finley.net/fedora_core_5_installation_notes.html#Warning)
There is a fedora faq link at the top of this page. and of course, the man command Almost any command has a manual and man is the command ie: man yum will give you the yum man pages.
man rpm will give you the rpm manual. add remove is based on yum and yum is based on rpm so it's worth reading both of those mans. They are somewhat cryptic, but with practice you begin to understand. (There are many I don't understand)

MintabiePete
15th September 2006, 08:17 AM
I have disabled freshrpm and find that if I run yum update I am getting this error
Password:
[root@localhost peter]# gedit /etc/yum.conf

(gedit:9084): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
[root@localhost peter]# gedit /etc/yum.repos.d

(gedit:9091): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
[root@localhost peter]# gedit /etc/yum.repos.d/freshrpms.repo

(gedit:9142): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
[root@localhost peter]# yum
Loading "installonlyn" plugin
You need to give some command

usage: yum [options] < update | install | info | remove | list |
clean | provides | search | check-update | groupinstall |
groupupdate | grouplist | groupinfo | groupremove |
makecache | localinstall | erase | upgrade | whatprovides |
localupdate | resolvedep | shell | deplist >

options:
-h, --help show this help message and exit
-t, --tolerant be tolerant of errors
-C run entirely from cache, don't update cache
-c [config file] config file location
-R [minutes] maximum command wait time
-d [debug level] debugging output level
-e [error level] error output level
-y answer yes for all questions
--version show Yum version and exit
--installroot=[path] set install root
--enablerepo=[repo] enable one or more repositories (wildcards allowed)
--disablerepo=[repo] disable one or more repositories (wildcards allowed)
--exclude=[package] exclude package(s) by name or glob
--obsoletes enable obsoletes processing during updates
--noplugins disable Yum plugins
[root@localhost peter]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/7]
flash [2/7]
jpackage-fedora [3/7]
core [4/7]
jpackage-generic [5/7]
extras [6/7]
updates [7/7]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package bind-config.i386 30:9.3.2-20.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.2-20.FC5 for package: bind-config
--> Finished Dependency Resolution



This is the one I also got when I run package manager


Error: Missing Dependency: bind = 30:9.3.2-20.FC5 is needed by package bind-config
[root@localhost peter]#

MintabiePete
15th September 2006, 08:30 AM
This is the error I get
http://img.photobucket.com/albums/v116/MintabiePete/Screenshot-2.png

u-noneinc-s
15th September 2006, 09:17 AM
Don't worry about this one. It's a problem with the updates for bind, and it is a known issue. I thought it was fixed, but perhaps you didn't get an up to date mirror. If you run yum --exclude bind* update, or with the package manager, unselect bind. You only need to do this if there are other updates that are not getting done because of the error.
I don't know why you are getting those errors above with gedit though.
Do yum install yumex and then use yumex instead of the package manager or add remove packages. It's easy to use. You'll prpbably like it. It's like having add and remove and package manager rolled into one. It should show up in the menus after you install it, or if you can't fink it you can start it with yumex on the command line in a terminal or alt+F2 keys

MintabiePete
15th September 2006, 09:48 AM
I am not going to worry about bind , I wll leave it in , there are a few parts of bind , but I am aware of it , if it gets worse . I downloaded a lot of updates using yum , and I will put a shortcut on my desktop for yum . I just downloaded 34mb downloads with no errors , so everything seems to be ok . What time is in in the US now , you spend a lot of time on computers :) Thanks for all those links & shortcut commands , I am gradually getting these into the grey matter , in preparation of leaving windows forever . In fact in the last year I have spent very little time in windows .I mostly use Kubuntu 6.06 , but i am starting to get to like this Fedora 5 :)

gr1dlok
8th March 2007, 04:51 AM
i know this is an old thread, but earlier i was following a how-to re: updating media players, and it suggested livna as a repo to update them. It said that there would be no conflict as i use freshrpm, and the update and everything went fine. But now i want to remove the livna repo from the yum update and i cant find a clear discription on how to (or one that works for me or that my simple little brain can follow).

And yes I've cd to etc/yum.repos.d/
and tried to change enabled=1 to enabled=0 with gedit but for some reason it will not let me save or replace it.

Although everthing works fine now, i really want to remove livna so it stays that way. Oh yeah im running FC5.

Any help would be appreciated ... thnaks

u-noneinc-s
8th March 2007, 05:02 AM
rpm -e livna-release (may need to include the 5 or -5 or whatever the version is.
Or, you can edit /etc/yum.repos.d/livna.repo and changed enabled=1 to enabled=0 and it just won't get loaded anymore unless you specify it on the CLI with
yum --enablerepo=livna update packagename.

gr1dlok
8th March 2007, 06:10 AM
thanks for your quick reply. i followed you instructions...
[gr1dlok@localhost ~]$ rpm -e livna-release
and got ...
error: can't create transaction lock on /var/lib/rpm/__db.000
and with the second peice of advise i already tried that as SU but it says i dont have permission to change (or save/replace).

I know im missing somthing out but i cant figure out what?

u-noneinc-s
8th March 2007, 06:26 AM
It may be for the best that rpm -e didn't work. I just happened to think that it might take some dependencies with it. Forget that for now.

As for editing the repo, if you used SU, it should be su (loser case).

gr1dlok
8th March 2007, 06:53 AM
yeah sorry i did it in lower case (or loser case???? freudian slip mabe???)

u-noneinc-s
8th March 2007, 07:31 AM
Root can do anything. :confused: :rolleyes: . Maybe try again with su - The dash gives you root environment (though in this case it probably doesn't matter).

gr1dlok
8th March 2007, 07:48 AM
Thanks for everyones patience. When i went to /etc/yum.repos.d/livna.repo earlier i went through file browser and and attempted to change and save it (which as i said wouldnt do even as su). This time i went through terminal and gedit etc/yum.repos.d/livna.repo and it saved the change.
So thanks again for all your advise and patience for a noob like myself.