PDA

View Full Version : Display fonts like in windows?



yopnono
11th September 2006, 11:03 PM
Hi. I have been using ubuntu for awhile, and I did find a howto on displaying fonts like in windows. And I did really like to view the web pages like they are. (I like the msfont)

Anyhow now I'm on FC5 and I have really tried everything I know to set it up, like I use to have in my Dapper, but... no luck

Does anyone know how to set FC5 to use and display msfonts like they are?
Here is the howto I used.
http://ubuntuforums.org/showthread.php?t=208396


//Mike

zenarcher
11th September 2006, 11:27 PM
Here is the best information I've found.....

http://avi.alkalay.net/linux/docs/font-howto/Font.html

Cheers,
zenarcher

yopnono
12th September 2006, 12:17 AM
Here is the best information I've found.....

http://avi.alkalay.net/linux/docs/font-howto/Font.html

Cheers,
zenarcher


Yep it's working like it should now. Thanks.
I had to install the freetype-2.1.10-5.2.1.bci.i386.rpm
from this site: http://avi.alkalay.net/software/freetype.bci/FC5/

I use the font.conf from dapper and this freetype.bci = great

Thanks again.

zenarcher
12th September 2006, 12:48 AM
You are welcome. I'm real new to Fedora....just been using it for about a week now and that's one of the tips I ran across. I've been using SUSE for about two years, but there's a lot of new things to learn here. Good luck with your Fedora efforts!

Cheers,
zenarcher

yopnono
12th September 2006, 12:55 AM
This was one of the things that could make me leave FC, since I really don't like the default font rending. But now it's back like I want it.

Thanks.

Wayne
12th September 2006, 12:57 AM
This was one of the things that could make me leave FC, since I really don't like the default font rending. But now it's back like I want it.

Thanks.

Funny, I tried Dapper and left it after 10 days for exactly the same reasons. Western font rendering was fine but it really killed DBCS fonts! FC5 displays DBCS much more nicely out of the box :D

Wayne

yopnono
12th September 2006, 10:01 AM
Funny, I tried Dapper and left it after 10 days for exactly the same reasons. Western font rendering was fine but it really killed DBCS fonts! FC5 displays DBCS much more nicely out of the box :D

Wayne

Out of the box yes. But I don't and I mean don't like the linux world font rendering
Thats why I used the howto to get proper fonts. But I could not make it work in FC until now, using the updated libs for font rendering.

Check before and after img. nr 1 is org FC5, 2nd is FC5 updateded libs, 3rd is updateded FC5 and dapper howto fonts.

http://img100.imageshack.us/img100/5422/screenshot1fo4.th.png (http://img100.imageshack.us/my.php?image=screenshot1fo4.png) http://img165.imageshack.us/img165/2827/screenshot2be9.th.png (http://img165.imageshack.us/my.php?image=screenshot2be9.png) http://img91.imageshack.us/img91/1448/screenshot3la8.th.png (http://img91.imageshack.us/my.php?image=screenshot3la8.png)

Wayne
12th September 2006, 01:05 PM
Wanna see something really bad....? :D

BTW. You can attach files to your mesages, you don't have to use that awful imageshack thing that drives me nuts. Just scroll down a bit from the message input box and there's a button called 'Manage Attachments'

The second picture is what it *should* look like

There was also a bug in Dapper that made mounted partitions like /home, /var and /root show up in 'Computer'

Wayne

b00st
12th September 2006, 01:17 PM
edit: nevermind

yopnono
12th September 2006, 01:21 PM
Wanna see something really bad....? :D

BTW. You can attach files to your mesages, you don't have to use that awful imageshack thing that drives me nuts. Just scroll down a bit from the message input box and there's a button called 'Manage Attachments'

The second picture is what it *should* look like

There was also a bug in Dapper that made mounted partitions like /home, /var and /root show up in 'Computer'

Wayne

The partition icon issue is fix.

Yes i know you can attach to the forum.
imageshack = old habit :)

b00st
12th September 2006, 02:59 PM
For the most part it works, but in some areas there is no difference or fonts look poor. Gnome fonts (panel, main menu, etc.) did not change at all, but they do from within the program, like a webpage in firefox. Also, asian fonts remain blurry using the packages from the feodra repo, in both gnome and kde. The asian fonts from microsoft, they show fine(as in, not blurry) in gnome, but do not in any app based on qt/kde. sigh..... I can live with it for now though.

yopnono
12th September 2006, 03:21 PM
Make a backup of your "/etc/fonts" folder then replace it with the attached file (folder).
Untar it, and simply replace the fonts folder in the /etc/

then logout and login or restart the xserver.

b00st
12th September 2006, 03:51 PM
Make a backup of your "/etc/fonts" folder then replace it with the attached file (folder).
Untar it, and simply replace the fonts folder in the /etc/

then logout and login or restart the xserver.

Already did that when i followed that thread on the ubuntu forums. Bah, now it's getting me more agitated than i was before, lol. If I knew how and what file to edit, I would go about fixing it myself.

David Becker
12th September 2006, 04:04 PM
Already did that when i followed that thread on the ubuntu forums. Bah, now it's getting me more agitated than i was before, lol. If I knew how and what file to edit, I would go about fixing it myself.

I just put MS true type fonts in

/usr/share/X11/fonts/TTF

and insert the following line

<dir>/usr/share/X11/fonts/TTF</dir>

at the appropriate location in /etc/fonts/font.conf

And with that they become available in Gnome (window titles, apps, etc.)

David

b00st
12th September 2006, 04:42 PM
I just put MS true type fonts in

/usr/share/X11/fonts/TTF

and insert the following line

<dir>/usr/share/X11/fonts/TTF</dir>

at the appropriate location in /etc/fonts/font.conf

And with that they become available in Gnome (window titles, apps, etc.)

David

That worked for fixing the fonts in gnome, thank you for the tip. All that is left to fix is certain text showing up poorly and non-blurry asian fonts in qt/kde. I'm goign to dig in the files and see what i figure out.

Atleast for now, i can actually live with it.

yopnono
12th September 2006, 04:47 PM
The file I attached is little modified, try and see if that make any differents. But you need to replace the whole folder. (make sure it keeps the permissions (root))

And yes you need to install the msfonts aswell, also you can use this to update the font cache

fc-cache -fv

b00st
12th September 2006, 05:43 PM
The file I attached is little modified, try and see if that make any differents. But you need to replace the whole folder. (make sure it keeps the permissions (root))

And yes you need to install the msfonts aswell, also you can use this to update the font cache

fc-cache -fv

I followed everything exactly, here are 2 screenshots so that you se what I am talking about.

David Becker
12th September 2006, 05:53 PM
I followed everything exactly, here are 2 screenshots so that you se what I am talking about.

Those fonts looked ugly. Though the smaller font looked ok.

Which fonts did you choose? I'm guessing you're using something that can't be smoothed.

David

yopnono
12th September 2006, 05:55 PM
I followed everything exactly, here are 2 screenshots so that you se what I am talking about.

Did you install *all* msfonts. I have my fonts in "/usr/share/fonts/truetype/msttcorefonts"
Did you use the file i attached.
Did you run fc-cache -fv as root

Did you install the file:

I had to install the freetype-2.1.10-5.2.1.bci.i386.rpm
from this site: http://avi.alkalay.net/software/freetype.bci/FC5/

I use the font.conf from dapper and this freetype.bci = great

How is the font config setting system - preferences - fonts

MSFONTS:

Andale_Mono.ttf Impact.ttf
Arial_Black.ttf Tahomabd.ttf
Arial_Bold_Italic.ttf Tahoma.ttf
Arial_Bold.ttf Times_New_Roman_Bold_Italic.ttf
Arial_Italic.ttf Times_New_Roman_Bold.ttf
Arial.ttf Times_New_Roman_Italic.ttf
Comic_Sans_MS_Bold.ttf Times_New_Roman.ttf
Comic_Sans_MS.ttf Trebuchet_MS_Bold_Italic.ttf
Courier_New_Bold_Italic.ttf Trebuchet_MS_Bold.ttf
Courier_New_Bold.ttf Trebuchet_MS_Italic.ttf
Courier_New_Italic.ttf Trebuchet_MS.ttf
Courier_New.ttf Verdana_Bold_Italic.ttf
Georgia_Bold_Italic.ttf Verdana_Bold.ttf
Georgia_Bold.ttf Verdana_Italic.ttf
Georgia_Italic.ttf Verdana.ttf
Georgia.ttf Webdings.ttf

b00st
12th September 2006, 06:17 PM
Yea, i installed all the required stuff.

i have fonts on best shape and going to advanced options, smoothing is greyscale and hinting is at medium.

I know something went wrong because changing the settings don't work anymore.

edit: can you paste you .fonts.conf???

yopnono
12th September 2006, 06:27 PM
which font are you using as default. my font is set to sans (default font)
what is your dpi 96? default is 96

And you did replace the font folder in /etc not only copy in to it or over it.
make a backup of it. Delete it, then put the fonts folder i attached in the /etc

yopnono
12th September 2006, 06:33 PM
Yea, i installed all the required stuff.

i have fonts on best shape and going to advanced options, smoothing is greyscale and hinting is at medium.

I know something went wrong because changing the settings don't work anymore.

edit: can you paste you .fonts.conf???


The fonts.conf is not important, it's update every time you run font update.
And I cant paste it it's to big to many characters

Look in the attached file in my previous post

ogetbilo
12th September 2006, 06:33 PM
I hate those windows fonts.

Is there a way to uninstall these fonts in windows and put the linux fonts instead of them?

yopnono
12th September 2006, 06:39 PM
I hate those windows fonts.

Is there a way to uninstall these fonts in windows and put the linux fonts instead of them?

Haha, yes there is just remove all your fonts, and then install your linux fonts.

b00st
12th September 2006, 06:42 PM
Well, I completely removed the directory and put what you had put up, and still have the same problem, but atleast gdm seems to now use the new font settings :), lol. It's not a big deal, but it's just seems out of place. I also do not want to turn this into an IM conversation either. :D I have another pc I can try this on and see how that fairs.

I don't hate linux fonts, I just hate the way they are rendered. It's more tougher to read small text when everything is smothered.

b00st
13th September 2006, 02:24 PM
I tried it on my laptop and did not have any fonts render poorly. Though gnome doesn't pick up the new settings at all (even added the extra line). :( Looks to me this is along the lines of "results may vary".

Thanks for the help anyway.

sorry for double post.

yopnono
13th September 2006, 03:17 PM
You can always also try to play with the font setting like monocrom, lcd etc,etc.

b00st
13th September 2006, 05:29 PM
You can always also try to play with the font setting like monocrom, lcd etc,etc.

That stopped working once I followed the steps.


edit: I think I may have found my problem, but I will make sure first.

yopnono
13th September 2006, 05:44 PM
Yes I know since the .conf files set it up, but for some application/font that are not in the .conf files, the font setting does make a different. Like the terminal. For me it makes a different, if setting the font setting to monochrome. Anyhow I'm using the default Sans fonts.